LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Xine fails to play DVD with snd_pcm_open() (http://www.linuxquestions.org/questions/linux-software-2/xine-fails-to-play-dvd-with-snd_pcm_open-157359/)

joe_huddleston 03-13-2004 11:44 PM

Xine fails to play DVD with snd_pcm_open()
 
Hello,

I just installed Slackware 9.1 and Xine. When I try to play a DVD with Xine, it fails. The error is:

>>> Check if another program don't already use PCM <<<
snd_pcm_open() failed:-13:Permission denied

I'm not sure what to check in /dev to make sure the permissions are open.

Audio works, because xmms works fine. Any ideas?

Thanks,

Joe

joe_huddleston 03-13-2004 11:49 PM

Sorry, some details I should have put in the first one:

2.4.22 kernel, 1.0.3 Alsa driver, and my sound card is an Audigy 2.

lsmod shows, among other things:

Module Size Used by Tainted: P
snd-pcm-oss 38148 1 (autoclean)
snd-mixer-oss 12792 1 (autoclean) [snd-pcm-oss]
nvidia 1965216 6 (autoclean)
amd768_rng 1808 0 (unused)
amd7xx_tco 3388 0 (unused)
usb-ohci 17992 0 (unused)
usbcore 60320 1 [usb-ohci]
snd-emu10k1 65076 2
snd-pcm 57920 0 [snd-pcm-oss snd-emu10k1]
snd-timer 14692 0 [snd-pcm]
snd-hwdep 4960 0 [snd-emu10k1]
snd-util-mem 1152 0 [snd-emu10k1]
snd-page-alloc 6420 0 [snd-emu10k1 snd-pcm]
snd-ac97-codec 43868 0 [snd-emu10k1]
snd-rawmidi 13248 0 [snd-emu10k1]
snd-seq-device 3908 0 [snd-emu10k1 snd-rawmidi]
snd 30948 0 [snd-pcm-oss snd-mixer-oss snd-emu10k1 snd-pcm snd-timer snd-hwdep snd-util-mem snd-ac97-codec snd-rawmidi snd-seq-device]
soundcore 3556 8 [snd]
emu10k1-gp 1352 0 (unused)
gameport 1468 0 [emu10k1-gp]
ohci1394 24712 0 (unused)
ieee1394 44100 0 [ohci1394]
3c59x 27216 1
ide-scsi 9520 0
agpgart 40184 3


Thanks,

Joe

indeterminate 03-13-2004 11:53 PM

If you're using a sound system (like arts (kde) or esd (gnome)), you might have to turn it off before running xine. The arts daemon is usually pretty good about auto-suspending after 30 seconds of unuse or so, but it can't hurt to kill it off.

Another option is to use a program like soundwrapper that will try to redirect sound requests.

joe_huddleston 03-14-2004 09:44 AM

Quote:

Originally posted by indeterminate
If you're using a sound system (like arts (kde) or esd (gnome)), you might have to turn it off before running xine. The arts daemon is usually pretty good about auto-suspending after 30 seconds of unuse or so, but it can't hurt to kill it off.

Another option is to use a program like soundwrapper that will try to redirect sound requests.

I'm using alsa. Neither arts nor esd are running. Sound works fine through xmms, just not through xine.

Thanks,

Joe


All times are GMT -5. The time now is 06:28 AM.