LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-20-2003, 08:06 PM   #1
blade00
LQ Newbie
 
Registered: Oct 2003
Location: Ontario, Canada
Distribution: Slackware 9.1
Posts: 11

Rep: Reputation: 0
xine: error on movie load


whenever i startup xine i get the error:

there is no input plugin available to handle "filename" Maybe MRL syntax is wrong or filestream source doesnt exist

after getting this i ran xine-config. it returned

Quote:
Please be patient, this script may take a while to run...
[ good ] you're using Linux, doing specific tests
[ good ] looks like you have a /proc filesystem mounted.
[ good ] You seem to have a reasonable kernel version (2.4.20-8)
[ good ] intel compatible processor, checking MTRR support
[ good ] you have MTRR support and there are some ranges set.
[ good ] found the player at /usr/bin/xine
[ good ] /usr/bin/xine is in your PATH
[ good ] found /usr/bin/xine-config in your PATH
Usage: xine-config [OPTIONS] [LIBRARIES]
Options:
[--prefix[=DIR]]
[--exec-prefix[=DIR]]
[--version]
[--libs]
[--acflags]
[--cflags]
[--plugindir]
[--datadir]
[--scriptdir]
[--localedir]
[ good ] plugin directory /usr/lib/xine/plugins/1.0.0 exists.
[ good ] found unknown plugin: xineplug_flac.so
[ good ] found input plugins
[ good ] found demux plugins
[ good ] found decoder plugins
[ good ] found video_out plugins
[ good ] found audio_out plugins
[ good ] /dev/cdrom points to /dev/scd0
[ hint ] /dev/dvd is /dev/dvd, not a DVD device
/dev/dvd is the default device that xine uses for playing DVDs.
You could make your life easier by creating a symlink named /dev/dvd
pointing to your DVD device (something like /dev/scd0 or /dev/hdc).
If your DVD-ROM device is /dev/hdb (slave ATAPI device on primary bus),
rm /dev/dvd
ln -s hdb /dev/dvd
typed as root will give you the symlink.
Alternatively, you can configure xine to use the real device directly,
using the setup dialog within xine, but I can't check your DMA
settings in that case...
press <enter> to continue...

[ good ] found xvinfo: X-Video Extension version 2.2
[ good ] your Xv extension supports YUV overlays (improves MPEG performance)
[ good ] your Xv extension supports packed YUV overlays
[ good ] Xv ports: YUY2 YV12 UYVY I420 YUY2 YV12 UYVY I420
reason for the DVD error is because i dont have one.

i also ran xine in the xterm, that returned where my errors are coming from. i searched the board for answers to this but i didnt really find any.

Quote:
This is xine (X11 gui) - a free video player v0.9.22.
(c) 2000-2003 The xine Team.
Built with xine library 1.0.0 (1-rc0a)
Found xine library version: 1.0.0 (1-beta12).
XServer Vendor: The XFree86 Project, Inc. Release: 40300000,
Protocol Version: 11, Revision: 0,
Available Screen(s): 1, using 0
Depth: 24.
XShmQueryVersion: 1.1.
-[ xiTK version 0.10.5 [XMB]]-
-[ xiTK will use XShm ]-
-[ WM type: (GnomeCompliant) (EWMH) Metacity {Metacity} ]-
Display is not using Xinerama.
main: probing <aadxr3> video output plugin
load_plugins: failed to load video output plugin <aadxr3>
main: probing <dxr3> video output plugin
video_out_dxr3: Failed to open control device /dev/em8300-0 (No such file or directory)
load_plugins: failed to load video output plugin <dxr3>
main: probing <xv> video output plugin
main: probing <alsa> audio output plugin
load_plugins: failed to load audio output plugin <alsa>
main: probing <oss> audio output plugin
xine_interface: unknown param 10
xine_interface: unknown param 10
xine_interface: unknown param 16
xine_interface: unknown param 10
xine_interface: unknown param 10
vo_scale: invalid ratio, using 4:3
vo_scale: unknown aspect ratio (0) in stream => using 4:3
when i was searching, i ran into a thread that suggested that some plugins were missing, i listed my plugins and the ones they had suggested were missing but were there...

if there was a fix for this and i had missed it, could you please redirect me to that thread?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Xine Auto-closes when I try to play movie fatenabu Linux - Software 12 09-14-2005 11:03 PM
how do u make xine close after watching a movie doublefailure Linux - Software 4 05-28-2005 03:21 PM
error sound with xine movie player ojinovic Mandriva 1 10-27-2003 04:06 AM
xine: error on movie load blade00 Linux - Software 1 10-20-2003 09:17 PM
xine and DVD movie audio track Hannes Linux - Software 2 09-23-2003 02:47 PM


All times are GMT -5. The time now is 03:59 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration