LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-30-2003, 01:10 PM   #1
eats85
Member
 
Registered: Aug 2003
Location: Wisconsin USA
Distribution: Slackware 9.1
Posts: 36

Rep: Reputation: 15
XINE configure problems


Hi, I am trying to get xine installed on my system but when I configure the UI I got an error saying it couldnt find xine-lib. I got around it by typing

export LD_LIBRARY_PATH=/usr/local/lib

but then later I got another error for libpng saying it could not find it but I have it install in /usr/lib I believe. Anyone have any suggestions how to fix this or get around it?

checking for png_read_info in -lpng... no
configure: error: *** libpng is needed (PNG library not found) - try to use --with-png-prefix option ***

thanks
eats
 
Old 09-30-2003, 01:20 PM   #2
php
Member
 
Registered: Jun 2001
Location: USA
Distribution: Slackware
Posts: 825

Rep: Reputation: 30
After you installed the xine-lib did you run ldconfig as root?
 
Old 09-30-2003, 01:26 PM   #3
eats85
Member
 
Registered: Aug 2003
Location: Wisconsin USA
Distribution: Slackware 9.1
Posts: 36

Original Poster
Rep: Reputation: 15
No... ive never head of this command what exactly would I type to make it work correctly I tried just "ldconfig" and I still get the error. If there more to it that im missing please let me know I am going to look up more on this at the moment.

thank for your time
eats
 
Old 09-30-2003, 01:36 PM   #4
Kakaratos
LQ Newbie
 
Registered: Sep 2003
Posts: 2

Rep: Reputation: 0
I am also stuck on this issue as I can't get crap to work with it. I followed the instructions on the Xine website.

(Logged in a Root for all of these actions)

./configure
./make install

ldconfig

when I issue the ldconfig command it says
bash: ldconfig: command not found

I do however see a ld command in /usr/bin

so I tried ld config under /home/bill/downloads/xine-lib*
ld: cannot open config: no such file name or directory

So I am also following this thread

Thanks
 
Old 09-30-2003, 01:47 PM   #5
eats85
Member
 
Registered: Aug 2003
Location: Wisconsin USA
Distribution: Slackware 9.1
Posts: 36

Original Poster
Rep: Reputation: 15
Are you logged in as root or did you use su to become root. When I su my ldconfig command does the same thing along with hdparm and chroot. But if I log out of one user and log directly into root the commands work. So if you are doing su I would recomend trying that. But I am a newbie so its just a suggestion

eats
 
Old 09-30-2003, 02:16 PM   #6
Kakaratos
LQ Newbie
 
Registered: Sep 2003
Posts: 2

Rep: Reputation: 0
That worked fine! thanks.

Here is how I installed it.

extracted the xine-lib tar file into a directory
extracted the xine-ui tar file into a directory

exited the system
logged in as root

cd (to the extracted directory of the xine-lib)

./configure
./make install

when that was finished I typed in

ldconfig
it came up saying
/usr/local/bin/xine/..... blah blah blah is an unknown library.

so I typed in LD_LOCAL_PATH=/usr/local/lib

ran ldconfig again
it came up saying the same message

so I said screw it and then went into the directory where I had extracted xine-ui and did the following

./configure
./make install

when those finished I ran this still logged in as root
xine
basically it said it couldnt load the gui wich was good news to me.

so I exited as root
logged in as user

went to the prompts and typed startx
then opened a Terminal window and typed: xine

loaded up just fine now I'm gonna play around with it and see how well it works to see if I need to tweak it any.

Thanks for the info!
 
Old 09-30-2003, 03:10 PM   #7
eats85
Member
 
Registered: Aug 2003
Location: Wisconsin USA
Distribution: Slackware 9.1
Posts: 36

Original Poster
Rep: Reputation: 15
Well... I tried the same thing step by step and still no luck on my end....

eats
 
Old 10-05-2003, 03:51 PM   #8
g452
Member
 
Registered: May 2003
Location: tswane
Distribution: Slackware 9.1
Posts: 113

Rep: Reputation: 15
u must be root to do this ... hope it helps ...

First unpack xine-lib, then:


./configure
make install



Make sure your /etc/ld.so.conf contains /usr/local/lib, then:


ldconfig



Now unpack your frontend (gxine or xine-ui or ...), then:


./configure
make install

all i am strugling with is the sound ... ican't get that going ... and i don't use oss i use arts
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Configure error on xine-lib-rc8 linux-rulz Linux - Software 12 12-24-2004 03:57 AM
Xine ./configure error jonsey32 Linux - Software 2 12-20-2004 05:31 PM
xine configure error zlib does exist degraffenried13 Linux - General 2 12-13-2004 04:51 AM
xine-lib - configure ignoring options? lukebeales Linux - Software 4 05-28-2004 09:17 AM
configure plugger for xine degraffenried13 Linux - General 8 01-28-2004 10:22 AM


All times are GMT -5. The time now is 04:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration