LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-12-2003, 08:38 AM   #1
seppe
LQ Newbie
 
Registered: Jun 2003
Posts: 19

Rep: Reputation: 0
ximian has broken my apt


A few days ago, I happily installed Ximiam Desktop 2. And it rocks! But, later on when I did an apt-get update, everything was broken. First, my rpm database was broken, but I could fix this with:
rm -f /var/lib/rpm/__db*
rpm -vv --rebuilddb

But, apt still doesn't work. When I do an apt-get update, apt-get hangs on 66% when he tries to read my Package List:

[root@homebase lists]# apt-get update
Get:1 http://ayo.freshrpms.net redhat/9/i386 release [1168B]
Fetched 1168B in 0s (2074B/s)
Hit http://ayo.freshrpms.net redhat/9/i386/os pkglist
Hit http://ayo.freshrpms.net redhat/9/i386/os release
Hit http://ayo.freshrpms.net redhat/9/i386/updates pkglist
Hit http://ayo.freshrpms.net redhat/9/i386/updates release
Hit http://ayo.freshrpms.net redhat/9/i386/freshrpms pkglist
Hit http://ayo.freshrpms.net redhat/9/i386/freshrpms release
Hit http://ayo.freshrpms.net redhat/9/i386/os srclist
Hit http://ayo.freshrpms.net redhat/9/i386/updates srclist
Hit http://ayo.freshrpms.net redhat/9/i386/freshrpms srclist
warning: cannot get exclusive lock on /var/lib/rpm/Packages
Reading Package Lists... 66%


I get the warning of the exclusive lock because I tried apt-get several times. And everytime I tried, apt-get hangs and I can't kill those processes. That's why apt-get can't get an exclusive lock. But this is independant from the 'Reading Package Lists' which hangs at 66%. Anyone knows how I can fix this? Because I would *really* like to have apt and synaptic back!

By the way, it seems that some other people have the same problem as me (look in the previous messages for the original one).

So please help me out!
Thanks in advance!

Oh yeah, I'm running Redhat 9
 
Old 06-12-2003, 10:29 AM   #2
BigNate
Member
 
Registered: Mar 2003
Location: Harrisburg, PA
Distribution: Gentoo, Debian, Ubuntu, Red Hat/CentOS
Posts: 719

Rep: Reputation: 30
Have tried to reinstall apt?
 
Old 06-12-2003, 12:51 PM   #3
seppe
LQ Newbie
 
Registered: Jun 2003
Posts: 19

Original Poster
Rep: Reputation: 0
Yes, but that didn't worked either
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Broken apt-get ebenh Debian 12 04-11-2012 12:36 PM
apt-get is broken irvken Linux - Software 3 12-12-2004 04:18 AM
apt-get seems broken jon_k Linux - Software 1 12-09-2004 06:20 PM
apt-get is broken, please help! agentforsythe Linux - General 3 01-12-2004 03:24 AM
broken apt-get mindcry Linux - Software 0 05-24-2003 09:55 AM


All times are GMT -5. The time now is 03:31 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration