LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   XFCE session in VNC not starting (http://www.linuxquestions.org/questions/linux-software-2/xfce-session-in-vnc-not-starting-944291/)

darkduck 05-10-2012 04:44 PM

XFCE session in VNC not starting
 
I have a server machine, which runs Debian Squeeze XFCE. It also has VNC server installed (vnc4server).

Debian automatically boots into my user. I added VNC server startup command into the "Application autostart" part of the XFCE Session and Startup panel. The problem is that when I connect to the server from the client machine, it opens up vanilla X desktop, not the XFCE one. If I kill VNC server and restart it with exactly the same parameters, then VNC connection gets normal XFCE desktop. I don't understand the logic here.

Can someone explain how to get XFCE session in VNC connection right after the boot?

Thanks a lot!

darkduck 05-12-2012 06:56 PM

anyone?

TheMadIndian 09-12-2012 11:12 PM

I stumbled across your remote file server blog and saw you still didn't have an answer while this may not resolve your issue I ran into a similar issue with Slackware where I was running fluxbox but would get the vanilla X no matter what I did. I am using vncserver so I modified xstartup in .vnc in my home dir.

I finally ended up with this config in the file .vnc/xstartup

Code:

#!/bin/sh

#xrdb $HOME/.Xresources
#xsetroot -solid grey
#xterm -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
$colorPath = "/usr/X11R6/share/X11/rgb"
VNCSERVERARGS[1]="-geometry 1280x1024 -depth 24"
#twm &
fluxbox &


darkduck 09-13-2012 05:46 PM

Hi,

I tried your file, replacing fluxbox with startxfce4.
Still, it does not work. 8-(

EDDY1 09-13-2012 11:10 PM

I had the same problem getting LXDE working, was trying to get it going using fluxbox.
My solution was LXDM, in other words whatever your wm is that maybe what you need to be loading which will load XFCE.

darkduck 09-14-2012 04:24 AM

Quote:

Originally Posted by EDDY1 (Post 4779890)
I had the same problem getting LXDE working, was trying to get it going using fluxbox.
My solution was LXDM, in other words whatever your wm is that maybe what you need to be loading which will load XFCE.

Sorry, I am lost here. Maybe you can explain in details?
Thanks!

EDDY1 09-14-2012 04:39 AM

fluxbox xdm gdm lxdm are all window managers the also control which Desktop environment gets loaded.
http://xwinman.org/
http://xwinman.org/basics.php
https://wiki.archlinux.org/index.php/Window_Manager

darkduck 09-14-2012 06:26 PM

Thanks for the advice.
I replaced startxfce4 & with xfwm4 &.
Now I see a different screen. It is definitely Xfce4 now, not vanilla X. A little progress.
But it still only has a terminal window on the empty desktop. No desktop icons, no wallpaper, no panel.

Code:

Here is my xstartup file:
#!/bin/sh
xrdb $HOME/.Xresources
xsetroot -solid grey
x-terminal-emulator -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
xfwm4 &

And now restart of vncserver from Putty does not help.

JaseP 09-14-2012 07:11 PM

Exporting the X session, setting the environment???

Just shooting in the dark with those...

TheMadIndian 09-14-2012 07:13 PM

Quote:

Originally Posted by darkduck (Post 4780640)
Thanks for the advice.
I replaced startxfce4 & with xfwm4 &.
Now I see a different screen. It is definitely Xfce4 now, not vanilla X. A little progress.
But it still only has a terminal window on the empty desktop. No desktop icons, no wallpaper, no panel.

Code:

Here is my xstartup file:
#!/bin/sh
xrdb $HOME/.Xresources
xsetroot -solid grey
x-terminal-emulator -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
xfwm4 &

And now restart of vncserver from Putty does not help.

Now that you have the correct syntax did you try my file?

EDDY1 09-15-2012 02:19 PM

Maybe you should check configuration for Xfce & Xfwm.
Is VNC your only option? Can you login direct to machine?
If you can login direct is evrything showing on Desktop?

darkduck 09-15-2012 06:00 PM

Quote:

Originally Posted by TheMadIndian (Post 4780661)
Now that you have the correct syntax did you try my file?

Yes, but without success.:(

Quote:

Originally Posted by EDDY1
Maybe you should check configuration for Xfce & Xfwm.
Is VNC your only option? Can you login direct to machine?
If you can login direct is evrything showing on Desktop?

When I login directly to the machine, it works perfectly.
The problem is only with remote login.

EDDY1 09-15-2012 07:07 PM

I think that the settings the MadIndian posted will work as your settings have everything labled for an x terminal. You have to comment out a few lines.
In fact everything is commented out except xfwm4

darkduck 09-16-2012 05:20 PM

Quote:

Originally Posted by EDDY1 (Post 4781292)
I think that the settings the MadIndian posted will work as your settings have everything labled for an x terminal. You have to comment out a few lines.
In fact everything is commented out except xfwm4

Indeed, I tried this option too yesterday. No luck.:(

EDDY1 09-16-2012 07:34 PM

This 1 says to do it onclient level instead of network
http://narnia.cs.ttu.edu/drupal/node/132

Forget the above post for now
This 1 is the way you're trying to do it.
http://www.szewong.com/2009/06/setti...vnc-slicehost/


All times are GMT -5. The time now is 05:25 AM.