LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 09-20-2005, 08:52 PM   #1
Tylerious
Member
 
Registered: Feb 2005
Location: USA
Distribution: Gentoo
Posts: 72

Rep: Reputation: 15
xdm doesn't login


First off, I'm running Slackware 10.2. It defaults to starting up to runlevel 3, but I edited my /etc/inittab file so it starts up to runlevel 4 (X login manager runlevel for Slack). I rebooted and it brought up XDM, which I expected since I haven't installed GDM yet. Here's the problem:

I enter my username and password. The screen goes blank, the hard drive does some stuff and it brings XDM back up! I know it's the right name/password (also tried root), but it just doesn't work. If I hit Ctrl+Alt+Backspace once, it half quits out of X, but then brings back XDM. If I hit it a second time, it brings me back to the console, but it doesn't echo anything I type. The only thing I know works it Ctrl+Alt+Delete to restart (and start the whole process over again).

I'm kinda in limbo right now because I have no way (that I know of) to change back my /etc/inittab file to runlevel 3! Please, is there a way to bypass X during startup or something so I can edit that darn file? I'd really not have to reinstall, ya know. Hope it's not one of those mistakes..

Last edited by Tylerious; 09-20-2005 at 08:54 PM.
 
Old 09-20-2005, 11:50 PM   #2
TomaCzar
Member
 
Registered: Dec 2003
Location: Roc City (Rochester-NY)
Distribution: Slacker 4 Life
Posts: 125

Rep: Reputation: 15
Tylerious,

Here are a few things you should know:

1) You can choose the runleve you wish to boot to at the lilo boot prompt. So if you don't want to go to graphical user mode (runlevel four) you can simply type '3' after the lilo boot choice and it should boot up into runlevel 3. I would look like this

boot: linux 3

2) You can switch to another tty from the XDM login screen Simply press Ctrl + Alt + F6 and that should do the trick. To get back to the XDM login screen press Ctrl + Alt + F2.

3) If you have the Slack install disk, or an emergency disk, or any disk that you can boot off of and can read the file system type of your installation you can boot off of that, mount the partition with your /etc/inittab file on it, edit the inittab, umount, and reboot.

As for your actual problem, it sounds as if XDM doesn't know what window manager to hand things off to. Did you install a window manager/desktop environment?? If you did you should check the files in /etc/X11/xdm to make sure everything is as it should be. Especially the /etc/X11/xdm/Xresources file (make sure your window manager is listed there). If those files are OK, make sure your [homedir]/.xsession file is as it should be (again, make sure the command to load your window manager is present). If that file also contains what it should ... check the permissions on it. If that doesn't set you straight it's beyond my ability. Good luck.

-Tomaczar
 
Old 09-21-2005, 10:48 AM   #3
Tylerious
Member
 
Registered: Feb 2005
Location: USA
Distribution: Gentoo
Posts: 72

Original Poster
Rep: Reputation: 15
I tried switching tty. It didn't work.

You can specify runlevel with LILO? That's a very good thing to remember, just in case it happens again.

I booted from the install disk, started up with its basic kernel, mounted the partition, edited /etc/inittab with vi (gawd, I hate that program), etc. Just like you say, actually. Whoohoo..

Yes, I built Openbox. I had installed TWM and Blackbox with the install, but decided to uninstall Blackbox. However, I think it still tries to link to some its nonexistant files. I'll check the /etc/X11/xdm/Xresources file because I doubt Openbox is listed. Will the .Xsession file be the same as my .xinitrc file?

And thanks for the first bit. Got it back to runlevel 3 until I get things fixed.
 
Old 09-21-2005, 01:42 PM   #4
teckk
Senior Member
 
Registered: Oct 2004
Distribution: FreeBSD Arch
Posts: 1,773

Rep: Reputation: 197Reputation: 197
http://www.slackbook.org/html/book.html
ftp://ftp.slackbook.org/pub/slackbook/slackbook-2.0.pdf

Last edited by teckk; 09-21-2005 at 01:43 PM.
 
Old 09-22-2005, 08:40 AM   #5
TomaCzar
Member
 
Registered: Dec 2003
Location: Roc City (Rochester-NY)
Distribution: Slacker 4 Life
Posts: 125

Rep: Reputation: 15
Tylerious,

Happy that you're up and running again. teckk's links are to an awesome resource that I didn't even know was out there and available for free. Also, if you haven't already, you'll probably want to check out Shilo's thread for a quick n' dirty on many of the things you'll need/want to do as a Slack admin. Remember the bounds of your abilities are defined by your willingness to research.

The file in your home directory is .xsession, not .Xsession (not sure if it would still work, but I doubt it). Yes, .xsession works similarly to .xinitrc with one major difference being .xinitrc is called when you initiate X from the command line (startx) however .xsession is called when you login using a runlevel 4 gui. /etc/X11/xdm/Xresources is simply an example file to give you a base of some of the things you'll need in your ~/.xsession.

I'm not quite sure why the tty switch didn't work, you may wish to try all the F# keys and see if you have a different combination/configuration. It's a great ability to have when you make harmless little changes to things like font directories, vid card drivers, /etc/X11/xorg.conf and the like and for on reason or another X doesn't appreciate your efforts.

Also, keep the boot disk/mount option on the top of your brain. I don't know what types of mistakes you've made that you've had to reinstall before however when I first came over to Slack I was reinstalling unnecessarily a couple times a week (kernel compiling is only fun when it works!!). After a while of that I figured there had to be a better way and started researching recovery options for some of my more common foul-ups. Turns out there were plenty of them and now I only re-install if I need to modify partitions (and there's ways around that as well, but I just miss re-installing from time to time *SMILE*). Best of Luck.

-Tomaczar

P.S. You should get used to vi (and even proficient if you can). Being a linux admin and hating vi is like being an auto mechanic and hating ratchets.
 
Old 09-22-2005, 09:30 AM   #6
Tylerious
Member
 
Registered: Feb 2005
Location: USA
Distribution: Gentoo
Posts: 72

Original Poster
Rep: Reputation: 15
Oh, xsession, not Xsession. I'll fix that. I couldn't see anyplace to list my window manager in the Xresources file, but there was a list in the /etc/X11/xdm/Xsession. I added it there; didn't work, but maybe it will once I get the xsession file renamed.

I'll remember the Slackware book, but I won't try loading it on that box again until I get some more memory installed, heh.

I've always been changing tty with Alt+Fwhatever, not Ctrl+Alt+Fwhatever. Wow, I swear I'll get the hang of this sooner or later.

I haven't had to reinstall yet due to mistakes. Besides the mistake of Debian, that is. I've gotten better with vi, but it doesn't help that the documentation is so confusing. I prefer GNU's Nano personally, since I don't need to perform all sorts of funky commands on my stuff.

Edit:
Oops, didn't make it executable. All better now, thanks.

Last edited by Tylerious; 09-23-2005 at 11:05 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Xdm and login backgrounds. Paiway Linux - Software 1 12-14-2004 03:40 AM
Automatic login to X without XDM? JohnKFT Slackware 3 10-02-2004 01:22 PM
XDM opens XDM after login jpbarto Linux - Software 1 01-26-2004 11:23 PM
turn off auto-login XDM eduac Linux - Software 2 12-24-2003 11:07 AM
Disable XDM graphical login john8675309 Linux - General 2 10-22-2003 09:46 PM


All times are GMT -5. The time now is 06:09 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration