LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 09-19-2008, 02:17 PM   #1
Braynid
Member
 
Registered: May 2006
Location: Romania
Distribution: CentOS
Posts: 140

Rep: Reputation: 15
Question Xdebug install problems


Hey,

What I want to do is to install XDEBUG for PHP on my CentOS server. I'm running PHP Version 5.1.6 with Apache 2.

Compiling it is not really an option so I went for:
Code:
pecl install xdebug
It all went fine until:
Code:
Build process completed successfully
Installing '/usr/lib/php/modules/xdebug.so'

Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 119 bytes) in /usr/lib/php/pear/PEAR/PEAR/Registry.php on line 1061

Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 40 bytes) in /usr/lib/php/pear/PEAR/PEAR.php on line 776
Which is weird because as far as I am aware of the Allowed memory size is controlled by PHP. So I went and modified php.ini and increased the allowed_memory but still it gave me the same error.

Thing is the file xdebug.so is where is supposed to be so I've tried to put it in php.ini as the documentation says.
Code:
zend_extension_ts="/usr/lib/php/modules/xdebug.so"
After that I've restarted HTTPD then looked at phpinfo() and there was no sign of xdebug...

Any ideas on that?
Thaks!
 
Old 09-22-2008, 03:07 AM   #2
Braynid
Member
 
Registered: May 2006
Location: Romania
Distribution: CentOS
Posts: 140

Original Poster
Rep: Reputation: 15
I've tried to compile the stuff as a standalone with no luck. Do you have any idea on how can I make it work ?

Thanks
 
Old 02-24-2009, 09:21 AM   #3
dooug
LQ Newbie
 
Registered: Feb 2009
Posts: 1

Rep: Reputation: 0
Quote:
Originally Posted by Braynid View Post
Thing is the file xdebug.so is where is supposed to be so I've tried to put it in php.ini as the documentation says.
Code:
zend_extension_ts="/usr/lib/php/modules/xdebug.so"
I believe on CentOS this line in the php.ini file should be:

Code:
extension="/usr/lib/php/modules/xdebug.so"
And substitute the correct path to the xdebug.so file. Hopefully that helps.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: How to Debug PHP with Vim and XDebug on Linux LXer Syndicated Linux News 0 03-04-2008 04:40 AM
apt-get install dependency problems with hplip software and kde install for Agnula maybi7 Linux - Software 1 02-03-2007 05:16 PM
install suse 9.3 on a PIII system??? problems in the install screen : flickers! :( akshay_jp Suse/Novell 3 09-12-2006 11:53 AM
Ethernet Adsl Modem Driver Problems And Install Problems... akhilnair Linux - Hardware 12 11-28-2004 08:19 AM
SuSE problems; Mouse doesn't work, Wine won't install, WM won't install... Konig Linux - Distributions 1 01-21-2004 11:05 PM


All times are GMT -5. The time now is 12:13 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration