LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-04-2003, 10:30 PM   #1
John Newbie
LQ Newbie
 
Registered: Jun 2003
Location: Denmark
Distribution: KUbuntu
Posts: 15

Rep: Reputation: 0
XawTv - no picture at all


Help, please help

I use Linux v 2.4.18-bf2.4 (debian).
I use the newest driver for my NVidia TI4200 graphics card; resolution 1280x1024.
I installed Xawtv (3.72), scantv, fbtv via Debian (apt-get install)
I got a AverMedia TVCapture98 TV-card (pci-card).
Linux found the card (card=13 tuner=5).
When I run scantv, I find my tv-channels and can hear the correct sound, so I guess the tuner works ok.
But when I start XawTV (kde3.1.2) I just think for a very long time then stops and nothing happens.

XF86Config:
Option "omit xfree86-dga" # don't initialise the DGA extension
(no v4l in any line in any form)

modules.conf:
# The BTTV module does not load the tuner module automatically,
# so do that in here
post-install bttv insmod tuner
post-remove bttv rmmod tuner
########## TV Card ################
alias char-major-89 i2c
options i2c i2c_debug=0 verbose=1 scan=1
alias char-major-81 videodev
alias char-major-81-0 bttv
options bttv card=13 radio=0
options tuner debug=0 type=5
options msp3400

When I run Xawtv as root (command-line style, not GUI) I get:
This is xawtv-3.72, running om Linux/i686 (2.4.18-bf2.4)
Eroor: Can't open display:

When I run fbtv I get:
usinf linux console font "/usr/share/consolefonts/lat1-16.psf.gz"
map: vt01=> bf0
can handle only packed pixel frame buffers

v4l-conf (as root):
map: vt01=> bf0
v4l-conf: using frame buffer device /dev/fb0
can handle only packed pixel frame buffers

lsmod (as root):
bttv 60448 0 (unused)


After surfing the forums through I do think it is a TV- <> Graphics card problem.
I am almost sure, it is just a small think missing, like always with computer-stuff
Any ideas, please and thanks



 
Old 07-18-2003, 07:08 AM   #2
slapNUT
Member
 
Registered: Jun 2001
Location: Recycle Bin
Distribution: Linux & Everything else on VirtualBox
Posts: 144

Rep: Reputation: 15
Make sure the modules are loaded, bttv and i2c

lsmod

Make sure the video devices are in /dev

ls -l /dev/vid*

Then try running xawtv like this:

xawtv -c /dev/video0

If you have more than one video device, try the other one:

xawtv -c /dev/video1
 
Old 09-06-2003, 10:28 AM   #3
pe2338
Member
 
Registered: Dec 2002
Location: Bucharest,RO
Distribution: debian etch, sarge and sid
Posts: 407

Rep: Reputation: 30
Angry Terratec TV+ tuner not working

Hey, I have a simillar problem....

I have 2.4.21-4-k7 installed (debian) and a Terratec TV+ video card.

For me scantv does not do anything...
just says no station on every frequency it searches...

And another thing I don't have a "i2c" module just "i2c_core", "i2c_dev" and other simillar modules but none are "pure" i2c.


In xawtv I can see only for a moment a clear picture when I switch from NTSC to PAL.

Could anyone help me with this?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
xawtv has picture but no sound FreakWent Mandriva 9 04-26-2007 09:09 AM
xawtv picture scattered Brain Drop Linux - General 1 03-19-2005 09:17 PM
Xawtv + mandrake 9.2 = picture without sound VincentB Mandriva 10 01-13-2004 09:19 AM
Wintv xawtv not getting sound or picture, RH9 kidashy Linux - Software 1 07-25-2003 11:27 PM
XawTV no Picture? nus Linux - Newbie 5 06-16-2003 04:22 AM


All times are GMT -5. The time now is 02:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration