LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   xauth: timeout in locking authority file ~/.Xauthority? (http://www.linuxquestions.org/questions/linux-software-2/xauth-timeout-in-locking-authority-file-%7E-xauthority-32420/)

otbibb 10-10-2002 08:05 AM

xauth: timeout in locking authority file ~/.Xauthority?
 
Hello all!

This is my first post to this forum, but I have learned so much already. I have been using slackware for about a year, but yesterday I put 8.1 on the machine, with few problems. This time I decided to get my new wireless NIC installed, and that, too, went without a hitch. (My comp is a Dell Inspiron laptop, by the way).

So, here's my question. Yesterday, I created a user account for myself, Bryan, and set up my fluxbox prefs and such, no problem. While logged in as Bryan, I used my wireless network, and I also suspended the computer (kapmd running) for a little while. THEN, last night, I tried startx from my Bryan account, X started very slowly, and gave me this error 4 times before starting, and once as it exited:

xauth: timeout in locking authority file /home/bryan/.Xauthority

My root account started X no problem. Also, under Bryan I could do xinit and then do fluxbox with no problem. I did not have my wireless NIC in, by the way.

So, I created another user, Bibb, which generated a fresh copy of the .Xauthority file, and had no trouble starting X.

THEN, this morning my Bibb account experienced exactly the same problem. Even after fluxbox started, things weren't working right, as I expected. Mozilla would not boot, for example. I am currently connected through the network, typing this message in my third personal account in 2 days, and it's working fine.

Any ideas? Do I need to create a new account each time I use my computer? ;-)

Bryan

otbibb 10-11-2002 07:52 AM

Turns out, when I installed some software to my home directory, I had screwed up the ownership and permissions settings, so that I had no write access to my own home directory. Not optimal, to be sure.

The problem was that xauth could not modify the .Xauthority file to "lock" it, hence the error message.

Just thought I'd update, in case anyone's interested.

BB

muntus_maximus 08-06-2008 04:45 AM

Fix - X11 timeout in locking authority file
 
Perfect, have been waiting for a fix for a while and your post confirmed the same problem,

After chmod & chgrp whole <user> directory to that of the user it began working properly without error.

Thanks.

Jamesag37 11-15-2009 12:07 AM

Thank you, I hope that this will help me, as well.

tjackson 05-24-2012 07:21 AM

Another Solution
 
Got the same "timeout in locking ...." and finally figured out
I was logging in using "ssh -Y" when no X-server was started on
the destination host. My choices are, since I'm the admin,
boot the machine in RunLevel-5 (X) or just do plain "ssh".
(Oh, and it took a long time to complete login process.)

tjackson 09-18-2012 04:07 PM

Yet Another Solution
 
Was getting the same "time out while trying to lock .Xauthority .."

Turns out that selinux was set to "Enforcing".
One either needs to change settings on $HOME
directories (I had created them manually) or change
the security level to "Permissive" or "Disabled"
in /etc/selinux/config and re-boot.

cwcarlson 08-28-2013 01:42 PM

Setting home directory context
 
Rather than disabling selinux, one can also change the context of the user's home directory.

To find out what the context is, use the -Z option on ls. Note that for a directory, you may also need to use -d option. For example, to get the context of my home directory, I did: "ls -Zd $HOME" and got the following:

Code:

drwx--x--x. carlson carlson unconfined_u:object_r:user_home_dir_t:s0 /home/carlson
To set the context, use the chcon command. You probably need to be root in order to do this. You can look at the man page, but a command like: "
Code:

chcon 'unconfined_u:object_r:user_home_dir_t:s0' $HOME
"

I would not change directory context arbitrarily. For example, if you have an Apache server running from /var/www and you've created a user apache whose home directory is /var/www, you don't want to change the context (which was
Code:

system_u:object_r:httpd_sys_content_t:s0
).

Note there are 4 fields:
Code:

ssss_u:oooo_r:cccc_t:s0
You can read about selinux contexts here: https://docs.fedoraproject.org/en-US..._Contexts.html


All times are GMT -5. The time now is 01:17 AM.