LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 12-08-2010, 10:56 PM   #1
yzhang738@hotmail.com
LQ Newbie
 
Registered: Oct 2010
Posts: 14

Rep: Reputation: 0
x264-devel and lame-devel cannot be installed by yum


I tried to install x264-devel and lame-devel on CentOS 5.5, using
Code:
yum install x264-devel
yum install lame-devel
but it gave:
Code:
No package x264-devel available.
Nothing to do
I need help for this. Thanks.
 
Old 12-09-2010, 06:02 AM   #2
nowonmai
Member
 
Registered: Jun 2003
Posts: 481

Rep: Reputation: 47
Can you show the full output of yum?
 
Old 12-09-2010, 08:29 AM   #3
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,522

Rep: Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503Reputation: 2503
# yum install x264-devel lame-devel

... works OK, when you have enabled the rpmforge.repo :

http://wiki.centos.org/AdditionalRes...ories/RPMForge

...
 
Old 12-09-2010, 07:19 PM   #4
John VV
Guru
 
Registered: Aug 2005
Posts: 12,698

Rep: Reputation: 1687Reputation: 1687Reputation: 1687Reputation: 1687Reputation: 1687Reputation: 1687Reputation: 1687Reputation: 1687Reputation: 1687Reputation: 1687Reputation: 1687
but be warned rpmforge and cent-plus repos DO NOT GET ALONG
so use the you plugin "prioritys" and set centplus to be used first

also the mplayer( and the dependencies) from rpmforge are incompatible with most things in the centos repos
 
  


Reply

Tags
ffmpeg


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Qt libraries not found during compile - but libqt3-devel and libqt4-devel installed! prasadbrg Mandriva 5 12-02-2008 05:58 AM
Need help with yum install kernel-devel buckwheat12 Fedora 9 12-28-2006 02:16 PM
kdelibs3-devel or kdelibs-devel? meknb Linux - Software 4 06-18-2006 03:35 PM
Package fam-devel needs libselinux-devel belkins Linux - Newbie 2 10-18-2004 03:02 PM
mplayer and gtk-devel and libpng-devel ... purpleburple Linux - Software 1 03-16-2003 03:57 AM


All times are GMT -5. The time now is 08:53 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration