LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 08-30-2005, 10:50 PM   #1
Radical_Dreamer
LQ Newbie
 
Registered: Jan 2005
Posts: 20

Rep: Reputation: 0
x11vnc In firefox.


Hello, I recently emerged x11vnc and cant seem to get it to work with a javascript enabled firefox. =/ I type

x11vnc -shared -forever -rfbport 5800 -display :0

And it sets up fine, says the server is up and what what, But when I connect with firefox to the server at http://myipaddress:5800/ I get a page that says "RFB 003.003" I know that means my server is up, and all the ports are forewarded but I dont get a login or a desktop. Any help will be greatly appreciated.

--Rad
 
Old 08-31-2005, 05:32 AM   #2
Radical_Dreamer
LQ Newbie
 
Registered: Jan 2005
Posts: 20

Original Poster
Rep: Reputation: 0
rad@Rad ~ $ x11vnc -shared -forever -rfbport 5800 -display :0
31/08/2005 06:26:53 passing arg to libvncserver: -rfbport
31/08/2005 06:26:53 passing arg to libvncserver: 5800

Settings:
display: :0
authfile: null
subwin: 0x0
-sid mode: 0
flashcmap: 0
force_idx: 0
visual: null
overlay: 0
ovl_cursor: 1
scaling: 0 1.00000
viewonly: 0
shared: 1
conn_once: 0
timeout: 0
inetd: 0
connect: null
connectfile null
vnc_conn: 1
allow: null
input: null
passfile: null
accept: null
gone: null
users: null
using_shm: 1
flipbytes: 0
onetile: 0
solid: null
blackout: null
xinerama: 0
xrandr: 0
xrandrmode: null
padgeom: null
logfile: null
logappend: 0
rc_file: ""
norc: 0
bg: 0
mod_tweak: 1
isolevel3: 0
xkb: 0
skipkeys: null
addkeysyms: 0
xkbcompat: 0
clearmods: 0
remap: null
norepeat: 1
nofb: 0
watchbell: 1
watchsel: 1
watchprim: 1
cursor: 1
multicurs: 0
curs_mode: null
xfixes: 1
alphacut: 240
alphafrac: 0.33
alpharemove:0
alphablend: 1
cursorshape:1
cursorpos: 1
xwarpptr: 0
buttonmap: null
dragging: 1
ptr_mode: 2
inputskip: 10
speeds: null
debug_ptr: 0
debug_key: 0
defer: 30
waitms: 30
take_naps: 1
sb: 60
sigpipe: null
threads: 0
fs_frac: 0.75
gaps_fill: 4
grow_fill: 3
tile_fuzz: 2
snapfb: 0
gui: 0
gui_mode: null
noremote: 0
safemode: 0
deny_all: 0

31/08/2005 06:26:53 x11vnc version: 0.7.1 lastmod: 2005-02-23
31/08/2005 06:26:53 Using X display :0
31/08/2005 06:26:53 XFIXES available on display, resetting cursor mode
31/08/2005 06:26:53 to: '-cursor most'.
31/08/2005 06:26:53 to disable this behavior use: '-cursor arrow'
31/08/2005 06:26:53 or '-noxfixes'.
31/08/2005 06:26:53 using XFIXES for cursor drawing.
31/08/2005 06:26:53 default visual ID: 0x21
31/08/2005 06:26:54 Read initial data from X display into framebuffer.
31/08/2005 06:26:54 X display :0.0 is 32bpp depth=24 true color

FrameBuffer Info:
width: 1600
height: 1200
scaled_width: 1600
scaled_height: 1200
indexed_color: 0
bits_per_pixel: 32
depth: 24
red_mask: 0x00ff0000 00000000111111110000000000000000
green_mask: 0x0000ff00 00000000000000001111111100000000
blue_mask: 0x000000ff 00000000000000000000000011111111
red: max: 255 shift: 16
green: max: 255 shift: 8
blue: max: 255 shift: 0
mainfb_bytes_per_line: 6400
rfb_fb_bytes_per_line: 6400
format: ZPixmap
byte_order: LSBFirst
bitmap_pad: 32
bitmap_unit: 32
bitmap_bit_order: LSBFirst

31/08/2005 06:26:54 setting up 32 cursors...
31/08/2005 06:26:54 done.
31/08/2005 06:26:54 Listening for VNC connections on TCP port 5800
31/08/2005 06:26:54 created 50 tile_row shm polling images.
31/08/2005 06:26:54 screen setup finished.
31/08/2005 06:26:54
31/08/2005 06:26:54 The VNC desktop is Rad:5800
31/08/2005 06:26:54 possible alias: Rad::5800
PORT=5800

This is my output from the server, if I go to http://myipaddress:5800 it adds more lines here saying a connection has been established and what what.
 
Old 08-31-2005, 02:24 PM   #3
Radical_Dreamer
LQ Newbie
 
Registered: Jan 2005
Posts: 20

Original Poster
Rep: Reputation: 0
Any ideas? Yes, no? Hows about...

"Yes do this!" (Insert solution).
Or
"No, you can never do this or anything like it, get off my internets."
 
Old 08-31-2005, 03:13 PM   #4
Radical_Dreamer
LQ Newbie
 
Registered: Jan 2005
Posts: 20

Original Poster
Rep: Reputation: 0
Fixed it, x11vnc doesent come with its own java classes. Sooo...

emerge tightvnc

x11vnc -httpdir /usr/share/tightvnc/classes -httpport 5800 -display :0
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
x11vnc through putty? nicedreams Linux - Software 1 06-04-2005 04:37 AM
x11vnc persistant? Lleb_KCir Linux - Software 11 01-14-2005 11:07 PM
x11VNC Disconnects jonty_11 Linux - General 2 10-06-2004 09:28 PM
x11vnc + gnome Fuwex Linux - Software 0 09-27-2004 09:14 AM
x11vnc error mediaboy Linux - Software 1 06-24-2004 12:01 AM


All times are GMT -5. The time now is 03:34 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration