LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 10-19-2004, 10:08 PM   #1
Equin
Member
 
Registered: Oct 2004
Location: Merrimack, NH
Distribution: Ubuntu / Apple
Posts: 46

Rep: Reputation: 15
Question X11 Issue


Here's a good question that I'm trying to figure out...

X11 seems to lock up my server. Is there a way to prevent X from starting without using the server? IE open an SSH session or FTP to the config files


Thanks,
-Eq
 
Old 10-19-2004, 10:22 PM   #2
langsuyar13
LQ Newbie
 
Registered: Oct 2004
Location: San Antonio, TX, USA
Distribution: Slackware 10.2 Highly Customized, Gentoo
Posts: 10

Rep: Reputation: 0
This is probably possible on RedHat/Fedora (I use Slackware)

SSH into the computer and log in as root

vi /etc/inittab

You should see a section that looks like this:

# Default runlevel. The runlevels used by RHS are:
# 0 - halt (Do NOT set initdefault to this)
# 1 - Single user mode
# 2 - Multiuser, without NFS (The same as 3, if you do not have networking)
# 3 - Full multiuser mode
# 4 - unused
# 5 - X11
# 6 - reboot (Do NOT set initdefault to this)
#
id:5:initdefault:



in the last line, change the 5 to a 3, write and quit, reboot, and you should be set!

To change to runlevel 3 without rebooting, just type (as root):
telinit 3

Langsuyar

-

P.S., just checked on a fedora system, this should work.

Last edited by langsuyar13; 10-19-2004 at 10:28 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Core 4 - X11-devel complains about X11-libs which are installed Ephracis Fedora 3 09-05-2005 09:32 AM
Slack 10.1 -- Mouse issue / X11 issue Pozican Linux - General 4 04-19-2005 03:44 AM
X11 Forwarding Issue gauge73 Linux - Networking 1 11-10-2004 09:20 AM
Slackware 8.1 X11 keyboard issue eth0holic Slackware - Installation 1 09-27-2004 01:18 AM
Roaming X11/Xfree86, X11 proxy zapp Linux - Software 1 09-12-2003 08:06 AM


All times are GMT -5. The time now is 07:33 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration