LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   X: video drivers "ati" and "fglrx" show same fonts differently (http://www.linuxquestions.org/questions/linux-software-2/x-video-drivers-ati-and-fglrx-show-same-fonts-differently-658235/)

simopal6 07-25-2008 11:27 AM

X: video drivers "ati" and "fglrx" show same fonts differently
 
Hello!
I'm having this problem recently, it started when I upgraded Ati fglrx driver from 8.6 to 8.7, but still stayed when I reverted to 8.6.
After the upgrade, font size shrinked: in KDE Control Center I had to increase by one all fonts (DejaVu) in order to make everything look like before (nevertheless, the result is not the same: I've got the impression that font quality has decreased, somehow).
If I use the default X ati driver, the font size gets back to how it was before.
Anyway, I need fglrx for DRI.
Is this normal? Shouldn't a font be visualized always in the same way?
By the way, of course the resolution has not been changed, it's always 1280x800.
Thanks!

amani 07-25-2008 06:15 PM

DPI setting?
If that changes, fonts will be scaled.

jlinkels 07-25-2008 09:10 PM

I have seen this often before. When I changed my driver from 'nv' to 'nvidia' same thing. Sometimes you can get the old situation back by changing the DPI.

I also have different computers with the same installation with the fonts looking slightly different. Or the kerning, or the line spacing.

On this computer where I type now, all fonts became about 80% of the original size after a power outage. The machine had reboot at least a dozen times before that event without anything strange, and after the event I also rebooted a few times, and the fonts stayed the same 80%.

Beats me...

jlinkels

simopal6 07-27-2008 02:21 AM

Thanks to everyone.
What DPI settings should I change?
In KDE's Control Center, I can only force DPI to 96 or 120, and both make fonts look too big.
Is there something I have to add to xorg.conf?
Thanks again!

P.S.: some fonts always stay the same, regardless of the video driver being used; for example, Firefox's fonts don't change.

jlinkels 07-27-2008 07:37 PM

The DPI setting is changed in /etc/kde3/kdm/Xserver. I hope this use is not depreciated yet.

I have this as first line:
:0 local@tty1 /usr/X11R6/bin/X -nolisten tcp -dpi 75

There might be other Xserver files around, if there is one in your ~/.kde that one might take preference.

It is normal for FF to have its own font system somehow. I don't know the details, but those fonts seems to be independent of KDE settings. I have seen hundreds of post from users having a problem with that, noticable with older versions, so you are quite lucky!

jlinkels

simopal6 07-28-2008 04:00 AM

Inside that folder, I have some files (like Xsetup, Xstartup, Xsession), but no Xserver (I'll take a look somewhere else in the filesystem).
Anyway, I've read that the "DisplaySize" option allows to indirectly set the DPI value (there is a formula involving the screen resolution). It seems strange to me, because I thought that DPI were calculated FROM the screen resolution.
I mean, does the correct value of the DPI depend on the screen resolution, or is it me who has to choose a custom value for the DPI?
Thanks!

jlinkels 07-28-2008 06:00 AM

I already feared that the Xserver file might be placed somewhere else dependent on distro.

I can't answer what DPI exactly does, you have to try and find some docs on X. I do know that the DPI setting only has to do with fonts. When you change it, just the font changes, not the dimension of the windows and widgets. Some years ago I had terrible problems with font sizes using GTK apps in KDE. It was impossible to get decent and consistent font sizes for both of them. The problem was eventually solved by installing gtk-qt-engine and the said DPI setting. This is what I posted about it at that time.

Since I do not encounter these problems anymore with new installations, I assume much progress has been made. Your problems might not be related to this, it is just for illustration.

jlinkels

simopal6 07-30-2008 02:36 AM

I've found Xservers in /etc/X11/xdm/, and it's quite similar to jinkels' one:
Code:

:0 local /usr/bin/X :0
I've tried adding "-dpi 75" or "-dpi 96" after /usr/bin/X, but nothing changed.
I'm going to try xorg.conf option "DisplaySize" now...


All times are GMT -5. The time now is 08:23 PM.