LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 06-22-2006, 09:59 AM   #1
hradtke
Member
 
Registered: May 2006
Distribution: Fedora Core 6
Posts: 38

Rep: Reputation: 15
X server will not load on boot (sessions problem?)


When I boot Red Hat ES at a runlevel of 5, X will not completely load. The blue screen comes up, but then an hourglass will display and it will never finish loading. Thus, I cannot even login. I have no errors or warnings in my /var/log/XFree86.0.log. I see nothing that catches my eye in /var/log/messages.

If I boot with a runlevel of 3, login as root and use the command 'startx', I can successfully load X and login. When I logout, I do notice 'error: permissions error in pam_timestamp_check'.

I am not sure if this is related, but I noticed that I am unable to switch users at all. I get the following:
[root@advlnx26 root]# su hermanr
could not open session
[root@advlnx26 root]# su - hermanr
could not open session
[root@advlnx26 root]#

If I try to login to a user directly from the command line I get the following:
-bash: /etc/profile: Permission denied
[I have no name!@advlnx26 490 ~] (Please note that the 490 denotes a release level for a project).

Giving /etc/profile the permissions of 0777 does not change this.

Possible causes:
I did basically two things worth mentioning before this occured.
1) I changed my display to Generic LCD 1024x768 ( was 800 x 600 ).
2) I changed my sendmail.cf file using m4

When the error occured I immediately changed the display settings back to what they were. To rule out a corrupt XFreeConfig file, I copied one from a colleague. However, the behavior is exactly the same with either config.

Anyone have any clue or suggestion to solve thie problem?

Thanks,
Herman Radtke

Last edited by hradtke; 06-22-2006 at 10:02 AM.
 
Old 06-22-2006, 11:28 AM   #2
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
Try disabling SElinux at boot.........

1. When the grub splash screen is displayed press any key
2. Select the Linux boot choice and press the 'e' key
3. Select the line that starts with 'kernel' and press the 'e' key
4. At the end of the line add a space followed by selinux=0 (zero)
5. When done press the 'Enter' key followed by the 'b' key

If this works and you can log on as a user (not root) then you need to adjust your SElinux policy.

See; http://fedora.redhat.com/docs/selinux-faq-fc3/ for additional help.
 
Old 06-23-2006, 09:43 AM   #3
hradtke
Member
 
Registered: May 2006
Distribution: Fedora Core 6
Posts: 38

Original Poster
Rep: Reputation: 15
Thanks for the reply Lenard. Unfortunately, SELinux is not being deployed on my system. I confirmed this by checking /etc/sysconfig/ and looking for a selinux file. There was none.

Still to be sure, I followed the steps you suggested, but it still did not allow me to switch users.
 
Old 06-23-2006, 11:05 AM   #4
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
OK understood...............

Next step after switching users, what happens when you use startx????
Take a look at the users .xsession-errors file

You might want to do (as root of course);

system-config-display --reconfigure --set resolution 1024x768 --set depth 24

You also might want to remove the rhgb portion from your /boot/grub/grub.conf file also.

Last edited by Lenard; 06-23-2006 at 11:07 AM.
 
Old 06-23-2006, 12:21 PM   #5
hradtke
Member
 
Registered: May 2006
Distribution: Fedora Core 6
Posts: 38

Original Poster
Rep: Reputation: 15
When I 'startx' from the command line I get no new errors. I was messing with sendmail, and I see errors from there. Nothing that stands out to me however.

Here is the log:
Quote:
SESSION_MANAGER=local/advlnx26.adventresources.com:/tmp/.ICE-unix/4573
Error: permissions error in pam_timestamp_check

(evolution:4720): camel-WARNING **: Invalid root: '//root/evolution/local/Outbox
/mbox.ibex.index'

(evolution:4720): camel-WARNING **: version: TEXT.000 (TEXT.000)

(evolution:4720): camel-WARNING **: block size: 1024 (1024) OK

(evolution:4720): camel-WARNING **: free: 0 (0 add size < 7168) OK

(evolution:4720): camel-WARNING **: last: 8192 (8192 and size: 7168) BAD

(evolution:4720): camel-WARNING **: flags: unSYNC
/etc/mail/submit.cf: line 528: fileclass: cannot open '/etc/mail/trusted-users':
World writable directory
can not chdir(/var/spool/clientmqueue/): Permission denied
Program mode requires special privileges, e.g., root or TrustedUser.

(evolution:4720): GLib-GObject-WARNING **: gsignal.c:2010: instance `0x9528820'
has no handler with id `2275'
*** loading the extensions datasource
Saving session: gnome-terminal --use-factory --window-with-profile-internal-id=D
efault --show-menubar --role=gnome-terminal-4765--1870063828-1150904604 --title
root@advlnx26:~ --working-directory /root --zoom 1 --tab-with-profile-internal-i
d=Default --title root@advlnx26:/ --working-directory / --zoom 1 --tab-with-prof
ile-internal-id=Default --title root@advlnx26:/etc --working-directory /etc --zo
om 1 --tab-with-profile-internal-id=Default --title root@advlnx26:/var/spool --w
orking-directory /var/spool --zoom 1
The application 'Gecko' lost its connection to the display :0.0;
most likely the X server was shut down or you killed/destroyed
the application.
I used redhat-config-xfree86 -reconfig --set-resolution=124x768 --set-depth=24 s
ince system-config-display was not a valid command. However, it set the monitor
to "Unknown" and did not set the DPI. I changed it to the proper settings usin
g the GUI. I also noticed the following message when running that command:
Quote:
* ddcprobe returned bogus values:
ID: None
Name: None
HorizSync: None
VertSync: None
Now that flagged me as being a major problem. However, I checked out /etc/X11/XF86Config and everything checks out fine. However, it continues to show up even when all the settings are correctly set.

I did not see a rhgb portion in my /boot/grub/grub.conf file.

Last edited by hradtke; 06-23-2006 at 12:29 PM.
 
Old 06-26-2006, 09:21 AM   #6
hradtke
Member
 
Registered: May 2006
Distribution: Fedora Core 6
Posts: 38

Original Poster
Rep: Reputation: 15
The problem stemmed from the permissions on /etc. They were rwxr--r-- and when I changed them to rwxr--r-- everything began working again.

Last edited by hradtke; 06-26-2006 at 09:48 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dropped/hung TCP sessions on both NIC's, Compaq server with Debian doctorcisco Linux - Networking 1 01-16-2006 08:16 AM
High server load problem eagletalontim Linux - General 5 01-12-2006 10:42 AM
X server sessions.... Basslord1124 Linux - Newbie 5 07-20-2004 06:00 AM
Problem with php sessions sashhoney Linux - Software 7 08-28-2003 07:30 AM
VNC Server Sessions Sabeer Linux - Networking 1 05-21-2003 02:56 AM


All times are GMT -5. The time now is 10:31 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration