LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 08-19-2004, 12:54 AM   #1
pradi_net
LQ Newbie
 
Registered: Apr 2004
Posts: 15

Rep: Reputation: 0
X Server taking CPU processes


I am running Linux 8 (kernel 2.4.14-18) on my machine. Sometimes the system become too slow, even I can't move the mouse. When I checked the process status using "top" I found "X" taking 99.9% of the CPU. This happens often. What is the reason behind this? DO I need to kill any application?
 
Old 08-19-2004, 01:15 AM   #2
Mega Man X
Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 63
Question

We will need some details:

1 - What is Linux 8? Is it Mandrake? Redhat? SuSE?

2 - What are your sys specifications?

3 - Which desktop/window manager are you using? Gnome? KDE? Fluxbox?

...
 
Old 08-19-2004, 01:18 AM   #3
pradi_net
LQ Newbie
 
Registered: Apr 2004
Posts: 15

Original Poster
Rep: Reputation: 0
Here are the details
1. It is RedHAT Linux 8
2. I am using DELL POWEREDGE 400sc machine with 40GB hard disk and 2GB RAM.
3. I am using Ximian Desktop Manager.
 
Old 08-19-2004, 11:55 PM   #4
Mikhail_16
Member
 
Registered: Oct 2003
Distribution: Gentoo rules them all
Posts: 279

Rep: Reputation: 31
Hmm, with your hardware you should be flying.... Few pieces of advice though:

Ditch Redhat and go Gentoo .
Shutdown all unneened services, redhat has a lot of stuff that is useless for you and its starts it all up and that eats up cpu
I do assume that you partitioned properly and have at least 1 gb of swap space, otherwise your problem is easily identifiable as memory paging.
Recompile the kernel, while it sounds pretty nasty, and you will likely mess it up few times at first, it gets much easier with practice and you WILL need it eventually.
Seriously now, ditch RedHat, its not even supported anymore.
 
Old 08-20-2004, 01:40 AM   #5
Mega Man X
Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 63
Quote:
Originally posted by Mikhail_16
Hmm, with your hardware you should be flying.... Few pieces of advice though:

Ditch Redhat and go Gentoo .
Shutdown all unneened services, redhat has a lot of stuff that is useless for you and its starts it all up and that eats up cpu
I do assume that you partitioned properly and have at least 1 gb of swap space, otherwise your problem is easily identifiable as memory paging.
Recompile the kernel, while it sounds pretty nasty, and you will likely mess it up few times at first, it gets much easier with practice and you WILL need it eventually.
Seriously now, ditch RedHat, its not even supported anymore.

That seems to be more like a hardware related problem then a Redhat issue, meaning that using Gentoo won't guaranty any better performance. What I would recommend in this case is using a light desktop manager, as blackbox to see if there are any major improvements.

If not, try tweaking a little bit your XF86Config, located at /etc/X11/, as changing screen resolution, monitor refresh rate and video driver. Also, talking about video driver, if you've got a nvidia, I highly recommend you getting the official drivers from nvidia's page. It will make wonders.

Also, you really have no need at all for 1 GB of swap space. Swap is nearly _never_ used under Linux, and with 2GB of memory RAM, you can be sure that RAM will be enough, unless you are running a big server on it. Make a 256MB swap partition, and that's it.

And about Gentoo, make sure that you have a lot of time (and by a "lot", I'm being kind, the correct is, make sure that you "don't have a life") compiling an insane number of programs. If you need i686 optmization, get a i686 distribution and save the time to have some fun with your computer, ratter then wasting days compiling KDE, and you will not even notice the difference to be fair .

Last edited by Mega Man X; 08-20-2004 at 01:42 AM.
 
Old 08-20-2004, 01:58 AM   #6
Mikhail_16
Member
 
Registered: Oct 2003
Distribution: Gentoo rules them all
Posts: 279

Rep: Reputation: 31
Remembered something: Oh, also check that the bios setting for the cpu is NOT set into compatible mode, that seems to kill performance on 400cs. (and yes i actually own one of those and infact its my primary home machine)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
SUSE 9.3 esd taking 40% of CPU ?? wiresquire Suse/Novell 2 04-22-2005 06:20 AM
Apache - libhttpd.ep taking over CPU jbeiter Linux - Software 1 12-01-2004 11:06 AM
Apache httpd taking 99% CPU Usage nimish Linux - Software 1 11-04-2004 06:49 AM
how do i find which script is taking up my cpu time? Pete Dogg Linux - Software 4 07-23-2004 06:35 PM
magicdev taking up too much cpu time phahn Linux - Software 2 04-29-2002 01:13 PM


All times are GMT -5. The time now is 06:12 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration