LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 08-01-2006, 04:24 PM   #1
snow93
LQ Newbie
 
Registered: Aug 2006
Location: Cambridge, UK
Distribution: Fedora Core 6 x86_64/i386
Posts: 4

Rep: Reputation: 0
X server not working after yum update & font server problems


My X server (so Gnome also) will not start.

What happened at first was the classic could not find font 'fixed error message'. after I did yum update.
So in /etc/X11/Xorg.conf I changed the fonts line from unix/:7100 to /usr/X11R6/lib/X11/fonts/misc
Everything from /usr/X11R6/lib/ onwards I created myself as it wasn't there. So I downloaded the misc fonts package. I did mkfontdir, and my fonts.alias file says:
Quote:
Fixed -Misc-Fixed-Medium-R-Normal--7-70-75-75-C-50-ISO10646-1
Cursor -Misc-Fixed-Medium-R-Normal--7-70-75-75-C-50-ISO10646-1
After all that I did not receive any more error messages - that is what I have done so far. Now for the main bit:
1. I did yum update (all) which apparently breaks dbus or something.
2. dbus (messagebus) does not work, which causes the Avahi and HAL daemons to stop working.
3. I start in init 1 and do "chcon -t system_dbusd_exec_t /bin/dbus-daemon".
4. Then When I go to init 3 and/or 1 after that, it messes up with error messages and things such as the keyboard typing wrong and text-based login screens appearing wrong. I will try and get hold of some error messages if anyone wants me to.
5. If I don't co the dbus things, Avahi and HAL don't start and neither does X.
6. Although in my above post X gave errors. here are the last few lines of /var/log/Xorg.0.log (and .1.log):
Quote:
(II) XINPUT: Adding extended input device "Keyboard0" (type: KEYBOARD)
(II) XINPUT: Adding extended input device "Mouse0" (type: MOUSE)
(II) XINPUT: Adding extended input device "NVIDIA Event Handler" (type: Other)
(II) Mouse0: ps2EnableDataReporting: succeeded
(II) NVIDIA(0): Setting mode "1280x1024"
(II) Mouse0: ps2EnableDataReporting: succeeded
No error messages after that or anything.
7. However, after the Nvidia logo flashing 1 or 2 times, and the screen clicking, I am left with the flashing underscore in the top left hand corner of the screen and a rectangular white console cursor, unable to type anything.
8. When I do Ctrl+alt+F1, it seems to have messed up too. There is an error message about not being able to start GTK. Text input is weird, just like I described in #4 (above).
9. OF course, the system still thinks it's in init 5.
10. Lastly, the only way to get X/Gnome to start is to put in "startx" when I'm logged on as root in init 1,3 or 5. When Gnome starts, I get one opr two messages about power-manager not being able to start because of dbus not running (see #2). Of course, this means I can't start X/Gnome when I am logged on as myself (Edward).

Thankyou very, very much to anyone who tries to help me. I do not understand this problem at all. Again, thinks in advance.[/QUOTE]
 
Old 08-02-2006, 05:26 AM   #2
snow93
LQ Newbie
 
Registered: Aug 2006
Location: Cambridge, UK
Distribution: Fedora Core 6 x86_64/i386
Posts: 4

Original Poster
Rep: Reputation: 0
Is there any more information I can give?
 
  


Reply

Tags
dbus, fonts, gnome, messagebus, x11, xorg


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
vncserver not working after yum update rvilarl Fedora 2 05-04-2006 04:11 PM
X Server Crashed after Yum Update a1opus Fedora 8 03-23-2006 09:00 PM
yum update stopped working hakukani Fedora 3 10-09-2005 05:25 AM
How to install Font Server in FedoraCore2--my font server failed covaigold Fedora 0 02-21-2005 12:42 AM
yum update not working, fedora core 1 glider7rgs Fedora 2 07-11-2004 02:41 AM


All times are GMT -5. The time now is 07:03 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration