LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-07-2003, 03:10 PM   #1
boblucci
Member
 
Registered: Dec 2001
Location: New Jersey
Distribution: RedHat 9
Posts: 34

Rep: Reputation: 15
X problems with Mandrake 9.0


I just tried to install mandrake 9.0 on my laptop.
I have an ATI Mobility M4 video card and it's not being detected for some reason. when i type startx i get this error...

Parse error on line 13 of section files in file /etc/X11/XF86Config-4
" is not a valid keyword in this section.

Now i'm not a programmer but i dont see anything wrong with this file, am i wrong?
<edit> I'm running X version 4.2.1 </edit>



# File generated by XFdrake.

# **********************************************************************
# Refer to the XF86Config man page for details about the format of
# this file.
# **********************************************************************

Section "Files"
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Mandrake 6.0 and later now use a font server independent of
# the X server to render fonts.
FontPath "unix/:-1"
EndSection

Section "ServerFlags"
#DontZap # disable <Crtl><Alt><BS> (server abort)
AllowMouseOpenFail # allows the server to start up even if the mouse doesn't work
#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx" # 3D layer
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "Keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
Option "XkbOptions" ""
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "PS/2"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons"
Option "Emulate3Timeout" "50"
EndSection

Section "Monitor"
Identifier "monitor1"
VendorName "Generic"
ModelName "Flat Panel 1280x1024"
HorizSync 31.5-67
VertRefresh 50-75

# Sony Vaio C1(X,XS,VE,VN)?
# 1024x480 @ 85.6 Hz, 48 kHz hsync
ModeLine "1024x480" 65.00 1024 1032 1176 1344 480 488 494 563 -hsync -vsync

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
EndSection

Section "Device"
Identifier "device1"
BoardName "ATI|Rage Mobility M4"
Driver "r128"
#Option "DPMS"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 24

Subsection "Display"
Depth 8
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
EndSubsection

Subsection "Display"
Depth 15
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
EndSubsection

Subsection "Display"
Depth 16
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
EndSubsection

Subsection "Display"
Depth 24
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
EndSubsection
EndSection

Section "ServerLayout"
Identifier "layout1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
Screen "screen1"
EndSection

Last edited by boblucci; 04-07-2003 at 03:14 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mandrake Sound Problems xmms problems.... devinWhalen Mandriva 6 04-16-2004 05:05 PM
internet problems with mandrake 10, eth problems rApT0r Linux - Newbie 10 04-11-2004 07:44 PM
Mandrake 9.1 Install problems (Graphical problems) sw4eternity Linux - Newbie 5 11-01-2003 09:43 PM
Mandrake 9.0 Installation Problems: X-Server, GUI Problems? chromelocust Linux - Software 4 03-21-2003 02:59 AM
Some problems with Mandrake sloptaco Linux - Distributions 2 08-15-2001 06:30 PM


All times are GMT -5. The time now is 01:16 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration