LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 07-11-2005, 05:19 PM   #1
rdfoerster
LQ Newbie
 
Registered: Aug 2004
Location: Arizona
Distribution: Fedora
Posts: 9

Rep: Reputation: 0
X not accepting remote system connections


Just setup a fedora core 4 system and I am having issues with it not accepting X connections from remote systems.

An example of what was done is:

On the receiving system: xhost +192.168.10.194
On the remote system xterm --display 192.168.10.8:0.0

I get an error message of: "Error: Can't open display: 192.168.10.8:0.0"

That is all I should have to do for everything to work. I have even run xhost + to no avail.

I am using KDE 3.4 as the desktop.

On a side note anyone else have an issue of the install not intalling inetd or xinetd?

Thanks
 
Old 07-11-2005, 05:27 PM   #2
masand
Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 58
try with

"192.168.10.8:0"

instead of

"192.168.10.8:0.0"
 
Old 07-11-2005, 05:53 PM   #3
rdfoerster
LQ Newbie
 
Registered: Aug 2004
Location: Arizona
Distribution: Fedora
Posts: 9

Original Poster
Rep: Reputation: 0
Gave it a try but no luck.

I ran an strace of the xterm command and received the following output over and over again.

rt_sigprocmask(SIG_BLOCK, [CHLD], [], 8) = 0
rt_sigaction(SIGCHLD, NULL, {SIG_DFL}, 8) = 0
rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
nanosleep({1, 0}, {1, 0}) = 0
socket(PF_INET6, SOCK_STREAM, IPPROTO_IP) = 3
getrlimit(RLIMIT_NOFILE, {rlim_cur=1024, rlim_max=1024}) = 0
setsockopt(3, SOL_TCP, TCP_NODELAY, [1], 4) = 0
close(3) = 0
socket(PF_INET, SOCK_STREAM, IPPROTO_IP) = 3
getrlimit(RLIMIT_NOFILE, {rlim_cur=1024, rlim_max=1024}) = 0
setsockopt(3, SOL_TCP, TCP_NODELAY, [1], 4) = 0
setsockopt(3, SOL_SOCKET, SO_KEEPALIVE, [1], 4) = 0
connect(3, {sa_family=AF_INET, sin_port=htons(6000), sin_addr=inet_addr("192.168.10.8")}, 16) = -1 ECONNREFUSED (Connection refused)
close(3)

Could there be something that needs to be changed on FC4 for X to allow remote windowing?
 
Old 07-11-2005, 05:57 PM   #4
jcliburn
Member
 
Registered: Dec 2003
Location: Mississippi, USA
Distribution: Fedora
Posts: 435

Rep: Reputation: 33
Is your local firewall blocking port 6000?
 
Old 07-11-2005, 06:01 PM   #5
rdfoerster
LQ Newbie
 
Registered: Aug 2004
Location: Arizona
Distribution: Fedora
Posts: 9

Original Poster
Rep: Reputation: 0
Firewall is off. Turned it off during install.
 
Old 07-11-2005, 06:17 PM   #6
jcliburn
Member
 
Registered: Dec 2003
Location: Mississippi, USA
Distribution: Fedora
Posts: 435

Rep: Reputation: 33
Assuming you used ssh to access the remote system, modify /etc/ssh/ssh_config on the local system and add

ForwardX11 yes
 
Old 07-11-2005, 06:27 PM   #7
jcliburn
Member
 
Registered: Dec 2003
Location: Mississippi, USA
Distribution: Fedora
Posts: 435

Rep: Reputation: 33
Quote:
Originally posted by jcliburn
Assuming you used ssh to access the remote system, modify /etc/ssh/ssh_config on the local system and add

ForwardX11 yes
And also, on the remote system, modify /etc/ssh/sshd_config and add

X11Forwarding yes

Sorry for leaving that out.
 
Old 07-11-2005, 06:32 PM   #8
rdfoerster
LQ Newbie
 
Registered: Aug 2004
Location: Arizona
Distribution: Fedora
Posts: 9

Original Poster
Rep: Reputation: 0
Would like to go with that solution but unfortunatly some of the systems I work with don't have ssh and it is not available for the platform. (too old)
The computers are running X11R3.

The application that is running on them does not work on a newer version of the os.

Thanks for the suggestion though.
 
Old 07-11-2005, 06:50 PM   #9
madluther
Member
 
Registered: Aug 2004
Distribution: LFS
Posts: 350

Rep: Reputation: 30
Perhaps the X server on the host is being launched with the '-nolisten tcp' option, in which case no connections will accepted. You should be able to see if this is the case with something like 'ps -aux | grep X'

HTH

Mad.
 
Old 07-11-2005, 07:45 PM   #10
jcliburn
Member
 
Registered: Dec 2003
Location: Mississippi, USA
Distribution: Fedora
Posts: 435

Rep: Reputation: 33
I think madluther hit on it. Try modifying /etc/X11/gdm/gdm.conf. Find the line that contains the string "Disallow" and add the following line after it:

DisallowTCP=false

You'll need to restart X to make the change take effect.
 
Old 07-11-2005, 07:49 PM   #11
rdfoerster
LQ Newbie
 
Registered: Aug 2004
Location: Arizona
Distribution: Fedora
Posts: 9

Original Poster
Rep: Reputation: 0
That is it. The nolisten option is set on the command line.

Thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
VNC not accepting connections Red Squirrel Linux - Newbie 4 02-20-2004 09:55 PM
ftp/telnet not accepting connections mstembri Linux - Newbie 6 10-05-2003 03:11 PM
port 110 isn't accepting connections member57 Linux - Networking 8 07-23-2003 10:11 PM
proftpd not accepting outside connections sohmc Linux - Software 0 07-18-2003 08:40 AM
FTPd has stop accepting connections shiny heed Linux - General 1 05-02-2003 07:20 PM


All times are GMT -5. The time now is 06:41 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration