LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 10-25-2004, 03:14 PM   #1
imranakbar
LQ Newbie
 
Registered: Oct 2004
Posts: 6

Rep: Reputation: 0
x missing font


Hi,
I was adding a hard drive and restarted the comp a couple of times, and when linux booted I couldn't startx - it would try and then give me the error msg:

Fatal server error:
could not open default font 'fixed'

I tried
/sbin/service xfs status
and it was running....

i had been using kde instead of gnome on fc2 around this time if that's in any way related.

thanks
 
Old 10-25-2004, 05:56 PM   #2
UsualTuxpect
Member
 
Registered: Aug 2004
Location: New York
Distribution: --------- Gentoo-2004.2 [2.6.8] Redhat-9 [2.6.6]
Posts: 545

Rep: Reputation: 31
Check your /etc/X11/XF86Config file


check for --> FontPath and provide the directory where your Fonts are located

This is in my config file
FontPath "/usr/share/fonts/TrueType/"
 
Old 10-25-2004, 06:10 PM   #3
imranakbar
LQ Newbie
 
Registered: Oct 2004
Posts: 6

Original Poster
Rep: Reputation: 0
I've got
FontPath "unix/:7100"

i tried system-config-display but that won't work either.

Thanks
 
Old 10-25-2004, 06:14 PM   #4
UsualTuxpect
Member
 
Registered: Aug 2004
Location: New York
Distribution: --------- Gentoo-2004.2 [2.6.8] Redhat-9 [2.6.6]
Posts: 545

Rep: Reputation: 31
try deleting every thing in /tmp
 
Old 10-26-2004, 10:14 AM   #5
imranakbar
LQ Newbie
 
Registered: Oct 2004
Posts: 6

Original Poster
Rep: Reputation: 0
Tried it... just have a bunch of keyrings left... doesn't do anything. Shoudl i try a reinstall or repair?
 
Old 10-26-2004, 12:57 PM   #6
UsualTuxpect
Member
 
Registered: Aug 2004
Location: New York
Distribution: --------- Gentoo-2004.2 [2.6.8] Redhat-9 [2.6.6]
Posts: 545

Rep: Reputation: 31
Do this

1)check if you have the file [fonts.alias] by doing a #ls -l /usr/X11R6/lib/X11/fonts/misc/
2)chmod a+r /usr/X11R6/lib/X11/fonts/misc/fonts.alias
3)service xfs restart
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Font missing in Konsole!!!!! kholdstare Linux - Software 5 05-01-2005 02:54 AM
Wine and an astrology program - What font am I missing / how do I add it? SBing Linux - Software 2 10-04-2004 02:45 PM
KOffice Formulas....Missing Symbol Font?? HokieEngr Linux - Software 1 05-30-2004 05:24 AM
font missing kholdstare Linux - Software 0 03-23-2004 10:42 AM
X server crash caused missing font sanjeevan Linux - Newbie 1 07-11-2003 06:20 PM


All times are GMT -5. The time now is 03:59 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration