LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-31-2002, 04:33 AM   #16
wonderpun
Member
 
Registered: Aug 2002
Location: Geekland, Planet Earth
Distribution: Slackware 9.1
Posts: 323

Rep: Reputation: 30

Hi GT! Well the only thing I can think of is that you can create a xinitrc.fluxbox file and put the:
exec fluxbox
line in it. And then put the file in your /etc/X11/xinit directory. Good luck!
 
Old 10-31-2002, 04:39 AM   #17
wonderpun
Member
 
Registered: Aug 2002
Location: Geekland, Planet Earth
Distribution: Slackware 9.1
Posts: 323

Rep: Reputation: 30
Alright. There's a file /etc/X11/xdm/Xsession. Find the section where the file mentions the other wm's and try adding fluxbox to the file. And make it similar to those already written there only type:
exec fluxbox
Well, good luck!!

P.S. You must have created the Fluxbox entry with your KDE Control Center in order for this to work.

Last edited by wonderpun; 10-31-2002 at 04:41 AM.
 
Old 11-01-2002, 12:36 AM   #18
GT I.N.C
Member
 
Registered: May 2002
Location: Australia, Sydney, St.Clair
Distribution: Rh 7.3
Posts: 836

Original Poster
Rep: Reputation: 30
Hey Wonderpun,

Yeh i have checked that out as well...sooo many times hehe

heres what it contains....

Code:
#!/bin/sh
# Modification for Linux-Mandrake by Chmouel Boudjnah <chmouel@mandraksoft.com>
# 20000309, Francis Galiegue <fg@mandrakesoft.com>: imwheel -k added for wheel
# mice and braindead-not-supporting-wheel-yet toolkits (this includes Qt...)

# read the user (~/.i18n) or system-wide (/etc/sysconfig/i18n) i18n settings
. /etc/profile.d/lang.sh

# redirect errors to a file in user's home directory if we can
for errfile in "$HOME/.xsession-errors" "${TMPDIR-/tmp}/xses-$USER" "/tmp/xses-$USER"
do
    if ( cp /dev/null "$errfile" 2> /dev/null )
    then
	chmod 600 "$errfile"
	exec > "$errfile" 2>&1
	break
    fi
done

# Mandrake default background
if [ "`whoami`" = root ]; then
    xsetroot -solid "#B20003"
else
    xsetroot -solid "#21449C"
fi

AGENT=$(type -p ssh-agent)
if [ -x "$AGENT" ]; then
    if [ -r $HOME/.ssh/identity -o -r $HOME/.ssh2/identification -o -r $HOME/.ssh/id_dsa -o -r $HOME/.ssh/id_rsa ]; then
	SSH_AGENT="$AGENT --"
    fi
fi    

# clean up after xbanner
if [ -f /usr/X11R6/bin/freetemp ]; then
    freetemp
fi

userresources=$HOME/.Xresources 
userresources2=$HOME/.Xdefaults
sysresources=/etc/X11/Xresources 

# merge in defaults and keymaps 
if [ -f $sysresources ]; then 
    xrdb -merge $sysresources 
fi 
 
if [ -f $userresources ]; then 
    xrdb -merge $userresources 
fi 

if [ -f $userresources2 ]; then 
    xrdb -merge $userresources2
fi 

if [ -x /etc/X11/xinit/fixkeyboard ]; then
    /etc/X11/xinit/fixkeyboard
fi

if [ -z "$BROWSER" ] ; then
	# we need to find a browser on this system
	BROWSER=`which mozilla`
	if [ -z "$BROWSER" ] || [ ! -e "$BROWSER" ] ; then
	# not found yet
		BROWSER=
	fi
fi

if [ -z "$BROWSER" ] ; then
	# we need to find a browser on this system
	BROWSER=`which netscape`
	if [ -z "$BROWSER" ] || [ ! -e "$BROWSER" ] ; then
	# not found yet
		BROWSER=
	fi
fi

if [ -z "$BROWSER" ] ; then
	# we need to find a browser on this system
	BROWSER=`which lynx`
	if [ -z "$BROWSER" ] || [ ! -e "$BROWSER" ] ; then
	# not found yet
		BROWSER=
	else
		BROWSER="xvt -e lynx"
	fi
fi
export BROWSER

export HELP_BROWSER="$BROWSER"

if [ -x /usr/sbin/chksession ];then 
    LIST=$(/usr/sbin/chksession -l)
else
    LIST="kde Gnome AfterStep Icewm AnotherLevel failsafe"
fi

# run scripts in /etc/X11/xinit.d
for i in /etc/X11/xinit.d/* ; do
    [ -d $i ] && continue
    # Don't run ??foo.{rpmsave,rpmorig,rpmnew} scripts
    [ "${i%.rpmsave}" != "${i}" ] && continue
    [ "${i%.rpmorig}" != "${i}" ] && continue
    [ "${i%.rpmnew}" != "${i}" ] && continue

    if [ -x $i ]; then
	$i &
    fi
done

# now, we see if xdm/gdm/kdm has asked for a specific environment
if [ $# = 1 ]; then
    DESKTOP=$1
else
    # use default DESKTOP from config file
    # users may want to choose their own desktop
    # even when x-session is started by startx command.
    # -- Jaegeum --
    if [ -f $HOME/.desktop ]; then
        . $HOME/.desktop >/dev/null 2>&1
    elif [ -f /etc/sysconfig/desktop ]; then
	. /etc/sysconfig/desktop >/dev/null 2>&1
    fi
fi

### Launch an XIM input server if needed
# it must be after definition of DESKTOP variable; but before any
# program that may want user input
if [ -x /etc/X11/xinit/XIM ]; then
    . /etc/X11/xinit/XIM
fi

### Launch first time wizard if needed
if [ ! -e $HOME/.drakfw ] && type drakfw > /dev/null 2>&1; then
    touch $HOME/.drakfw
    exec drakfw
fi

if [ -n "$DESKTOP" ]; then
    case $DESKTOP in
    	failsafe)
	exec $SSH_AGENT xvt -geometry 80x24-0-0
	exec $SSH_AGENT xterm -geometry 80x24-0-0
	;;
	default)
	;;
	*)
	exec $SSH_AGENT /bin/sh -c "$(/usr/sbin/chksession -x=$DESKTOP)"
	;;
    esac
fi

# otherwise, take default action
if [ -x "$HOME/.xsession" ]; then
	exec $SSH_AGENT "$HOME/.xsession"
elif [ -x "$HOME/.Xclients" ]; then
	exec $SSH_AGENT "$HOME/.Xclients"
fi

# We may try with chksession
if [ -x /usr/sbin/chksession ];then
#get the first available
	SESSION=$(/usr/sbin/chksession -F)
	[ "$SESSIONxxx" != "xxx" ] && exec $SSH_AGENT sh -c "$(/usr/sbin/chksession -x=$SESSION)"
fi

# Argh! Nothing good is installed. Fall back to icewm
if [ -x /usr/X11R6/bin/icewm ];then
	exec $SSH_AGENT /usr/X11R6/bin/icewm
else
	# gosh, neither icewm is available; 
	# fall back to failsafe settings
	xclock -geometry 100x100-5+5 &
	xvt -geometry +0+50 &
	if [ -x "$BROWSER" -a -f /usr/doc/HTML/index.html ]; then
	    $BROWSER /usr/share/doc/HTML/index.html &
	fi
	if [ -x /usr/X11R6/bin/icewm-light ];then
	    exec $SSH_AGENT icewm-light
	elif [ -x /usr/X11R6/bin/twm ];then
	    exec $SSH_AGENT twm
	else
	    exec $SSH_AGENT xsm
	fi
fi
I have no idea where to put it...geeez all this trouble for fluxbox lol

Garry
 
Old 11-01-2002, 04:06 AM   #19
wonderpun
Member
 
Registered: Aug 2002
Location: Geekland, Planet Earth
Distribution: Slackware 9.1
Posts: 323

Rep: Reputation: 30
Hi Garry Well, I must say that your Xsession file doesn't look like mine, that's for sure I'm sorry that I can't help you much, never used Mandrake. But I have a question to you. When kdm loads, it asks you for your username the password and then what? It lets you choose what wm you want to load? If yeah then I have an idea You see at the end of the Xsession file there's a section that starts:
# Argh! Nothing good is installed. Fall back to icewm
Try to change the:
/usr/X11R6/bin/icewm
to
/usr/local/bin/fluxbox
Then when you select icewm from the menu it should load flux. If I'm right and this worked then post back and will try to think out a way how to add flux to the menu If not, then sorry I couldn't help you much Good luck GT!
 
Old 11-01-2002, 04:45 AM   #20
GT I.N.C
Member
 
Registered: May 2002
Location: Australia, Sydney, St.Clair
Distribution: Rh 7.3
Posts: 836

Original Poster
Rep: Reputation: 30
Ok thanks, i'll get straight onto it.....

Garry
 
Old 11-01-2002, 04:51 AM   #21
GT I.N.C
Member
 
Registered: May 2002
Location: Australia, Sydney, St.Clair
Distribution: Rh 7.3
Posts: 836

Original Poster
Rep: Reputation: 30
Nope sorry, didn't work, it just loaded Ice....thanks for your help anyway...

Garry
 
Old 11-01-2002, 05:01 AM   #22
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
GT, /usr/local/bin/fluxbox is rather a suggested path, you would actually find the one that is on your system and use it. I am thinking this might be your problem

Do this:
whereis fluxbox

Note the location, then wherever you are editing these files, use that location. Example:

whereis fluxbox
/opt/wm/whoknows/nowhere/fluxbox /usr/man/man1/fluxbox.gz

So you see that fluxbox is in /opt/wm/whoknows/nowhere/fluxbox

So this will be your flux path.

Cool
 
Old 11-01-2002, 05:03 AM   #23
GT I.N.C
Member
 
Registered: May 2002
Location: Australia, Sydney, St.Clair
Distribution: Rh 7.3
Posts: 836

Original Poster
Rep: Reputation: 30
Yeh thats my correct path....checked it first hehe

Code:
[root@localhost root]# whereis fluxbox
fluxbox: /usr/local/bin/fluxbox
Garry
 
Old 11-01-2002, 05:04 AM   #24
GT I.N.C
Member
 
Registered: May 2002
Location: Australia, Sydney, St.Clair
Distribution: Rh 7.3
Posts: 836

Original Poster
Rep: Reputation: 30
All i need to know is how to make flux a selectable wm at the login screen....geeez didn't think it would be this hard

Garry
 
Old 11-01-2002, 05:14 AM   #25
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Post here the contents of ~/.xsession and/or ~/.Xclients

Cool
 
Old 11-01-2002, 05:16 AM   #26
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Well here's the deal I think so far...

I am basically newbie with a kagillion posts, so my experience is my knowledge. Most of my "experience" comes from Slack. I could easily tell you how to do this on slack, but for Mandy it's not the same. I am thinking pretty much the same boat for other's trying to help so far.

So instead of LQ Addict, I could still have "newbie" as my title and it'd be more fitting

Anyway, let's see if we can get this one going, I will do some searching after I see whats in those 2 files above.

Cool
 
Old 11-01-2002, 05:32 AM   #27
GT I.N.C
Member
 
Registered: May 2002
Location: Australia, Sydney, St.Clair
Distribution: Rh 7.3
Posts: 836

Original Poster
Rep: Reputation: 30
Xsession is up above ^

Xclients is....
Code:
#!/bin/bash

exec /etc/X11/Xsession
Garry
 
Old 11-01-2002, 07:12 AM   #28
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Living dangerously now, I'd try this:

Place a # sign in front of exec /etc/X11/Xsession in your Xclients file. Place a line below it with:
exec /path/to/fluxbox
replacing /path/to/fluxbox with the correct path.

So your Xclients should now look like:
#!/bin/bash

#exec /etc/X11/Xsession
exec fluxbox


Again, only if you wanna live dangerously, because I really don't know what effect this will produce. You might wanna post a few more things here instead first. Maybe the contents of your /etc/X11/xinit directory (if it exists).

At worst I think that would not allow you to enter X, you could probably still enter the file via command line and edit back to normal, but I really don't know.

Good Luck
 
Old 11-01-2002, 08:49 PM   #29
GT I.N.C
Member
 
Registered: May 2002
Location: Australia, Sydney, St.Clair
Distribution: Rh 7.3
Posts: 836

Original Poster
Rep: Reputation: 30
Hmmm i don't think i wanna try that just yet hehe

heres /etc/X11/xinit

Code:
[root@localhost xinit]# ls -al
total 24
drwxr-xr-x    2 root     root         4096 Sep 29 05:55 ./
drwxr-xr-x   19 root     root         4096 Nov  1 20:49 ../
-rwxr-xr-x    1 root     root         2019 Feb 28  2002 fixkeyboard*
-rwxr-xr-x    1 root     root           36 Feb 28  2002 Xclients*
-rwxr-xr-x    1 root     root         2658 Feb 28  2002 XIM*
-rwxr-xr-x    1 root     root           61 Feb 28  2002 xinitrc*
Anything else you wanna check out?

Garry
 
Old 11-02-2002, 12:24 AM   #30
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Ok, so, what is in that file there xinitrc? Post the contents of /etc/X11/xinit/xinitrc

Then, from there you might symlink this file to your user's home directory...

hmm, might be on to something...

Anyway post the contents of that first

Cool
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Qt headers and libraries not found c-- Ubuntu 12 03-03-2009 08:16 PM
Fluxbox install, X libraries and headers csb Linux - Software 3 07-15-2005 09:59 AM
QT Libraries & Headers inescapeableus Linux - Software 9 05-03-2005 02:14 AM
KDevelop cannot find QT headers and libraries?! mscollins1 Programming 1 04-10-2004 05:12 PM
QT-1.3 (headers and libraries) not found. p_reah Linux - Software 2 04-17-2003 08:11 PM


All times are GMT -5. The time now is 08:27 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration