LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 10-27-2002, 02:23 AM   #1
GT I.N.C
Member
 
Registered: May 2002
Location: Australia, Sydney, St.Clair
Distribution: Rh 7.3
Posts: 836

Rep: Reputation: 30
X libraries & headers for fluxbox


Hey all, i'm thinking of converting to fluxbox....

Well anyway i tried compiling it and i got this....

Code:
checking for X... no
configure: error: Fluxbox requires the X Window System libraries and headers.
Kinda weird...i do have X installed...well how else am i on this , and ummm i tried searching for x libraries headers etc. in rpmdrake and i can't seem to find anything....anyone can give me some pointers?

Garry

Last edited by GT I.N.C; 10-27-2002 at 02:24 AM.
 
Old 10-27-2002, 02:36 AM   #2
nautilus_1987
Member
 
Registered: Aug 2002
Distribution: Slackware 8.1
Posts: 750

Rep: Reputation: 30
GT do you have KDE and Gnome installed?
 
Old 10-27-2002, 03:35 AM   #3
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,379

Rep: Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963
well it's not looknig for kde or gnome is it?? it's looking for X. just install the Xfree860devel packaeg, and you'll be fine.
 
Old 10-27-2002, 03:49 AM   #4
GT I.N.C
Member
 
Registered: May 2002
Location: Australia, Sydney, St.Clair
Distribution: Rh 7.3
Posts: 836

Original Poster
Rep: Reputation: 30
Thanks Acid that worked fine! Oh and thanks nautilus for trying to help!

Garry
 
Old 10-27-2002, 04:05 AM   #5
nautilus_1987
Member
 
Registered: Aug 2002
Distribution: Slackware 8.1
Posts: 750

Rep: Reputation: 30
Mine is in /root/.xinitrc ( exec fluxbox )
 
Old 10-27-2002, 04:10 AM   #6
GT I.N.C
Member
 
Registered: May 2002
Location: Australia, Sydney, St.Clair
Distribution: Rh 7.3
Posts: 836

Original Poster
Rep: Reputation: 30
Ok now i can't seem to install it...i followed the instructions on the site...unless i created .xinitrc in the wrong directory....i made it in /home (it said in the home directory) is this wrong? Because when i logged out fluxbox wasn't there as a selectable window manager....

Garry
 
Old 10-27-2002, 04:25 AM   #7
GT I.N.C
Member
 
Registered: May 2002
Location: Australia, Sydney, St.Clair
Distribution: Rh 7.3
Posts: 836

Original Poster
Rep: Reputation: 30
Ok i'll move it now...but i won't try it till a bit later....(homework)

Garry
 
Old 10-27-2002, 04:37 AM   #8
nautilus_1987
Member
 
Registered: Aug 2002
Distribution: Slackware 8.1
Posts: 750

Rep: Reputation: 30
I am having one week holiday now....hehehe
 
Old 10-27-2002, 11:17 PM   #9
GT I.N.C
Member
 
Registered: May 2002
Location: Australia, Sydney, St.Clair
Distribution: Rh 7.3
Posts: 836

Original Poster
Rep: Reputation: 30
Ok that didn't work, fluxbox isn't a selectable window manager.....

What else am i doing wrong?

Is it because i have .xinitrc in the wrong directory...

Garry
 
Old 10-28-2002, 08:58 AM   #10
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Yes, you want it in your USER home, not the system home. So ~ rather than /home

Your xinitrc should be found by typing this:
~/.xinitrc

If that makes sense. ~ means to go to the home of whatever user you are logged in as. Not the /home but a deeper directory of something like /home/gtinc
So:
/home/gtinc/.xinitrc
would be correct.

Here's a peek at mine so you can see what one looks like:
Code:
#!/bin/sh
# $XConsortium: xinitrc.cpp,v 1.4 91/08/22 11:41:34 rws Exp $
  
userresources=$HOME/.Xresources
usermodmap=$HOME/.Xmodmap 
sysresources=/usr/X11R6/lib/X11/xinit/.Xresources
sysmodmap=/usr/X11R6/lib/X11/xinit/.Xmodmap

# merge in defaults and keymaps
    
if [ -f $sysresources ]; then
    xrdb -merge $sysresources
fi
    
if [ -f $sysmodmap ]; then
    xmodmap $sysmodmap
fi

if [ -f $userresources ]; then
fi
    
if [ -f $usermodmap ]; then
    xmodmap $usermodmap
fi
    
# Start the window manager:
exec root-tail /var/log/messages,red /var/log/xferlog,white /var/log/proftpd.lo$
exec gkrellm -w &
exec /opt/fluxbox/bin/fluxbox
But all you really need in there is simply:
exec fluxbox

Or possibly the entire path, as I have if you do not have the directory in your path.

Cool
 
Old 10-29-2002, 12:16 AM   #11
GT I.N.C
Member
 
Registered: May 2002
Location: Australia, Sydney, St.Clair
Distribution: Rh 7.3
Posts: 836

Original Poster
Rep: Reputation: 30
So when i do that will that make Fluxbox start automatically....or will it allow it to be selected?

Garry
 
Old 10-29-2002, 12:39 AM   #12
GT I.N.C
Member
 
Registered: May 2002
Location: Australia, Sydney, St.Clair
Distribution: Rh 7.3
Posts: 836

Original Poster
Rep: Reputation: 30
Ok i tried it.....putting .xinitrc in /home/gt and /root

They don't work.....when Mandrake starts up it's not selectable......

Garry
 
Old 10-29-2002, 02:22 PM   #13
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
No it's not, that's for 'startx' rather than having it be in your list of choices at your KDM screen. If that's what you are looking to have/do you might want to find the actual Mandrake RPM for it, this will set everything up for you, and place the entries in the correct file for that.

If you wanna do it yourself, I believe the setting is in the KDE control Center, not the Mandrake Control center. Poke around in there, find the section for login, and see if you can make a new entry for Flux.

If you have more problems, or don't have a clue what I mean, post back, I will be happy to walk you through it better, and I will boot into Mandy and give you some screenshots to help.

Cool
 
Old 10-29-2002, 07:44 PM   #14
GT I.N.C
Member
 
Registered: May 2002
Location: Australia, Sydney, St.Clair
Distribution: Rh 7.3
Posts: 836

Original Poster
Rep: Reputation: 30
I'm at school now, geeez how slow is the network hehe

Yeh ummmm i went around KDE Control center last night, and from memory i found a session or window manager option and it had IceWm etc. i added fluxbox....but i couldn't do anything else it just added it to it's list, it didn't ask me what command to use or anything, so when i logged out 'fluxbox' was in the list but when i selected it and logged in it just went to IceWm....

Thanks

Garry
 
Old 10-31-2002, 01:40 AM   #15
GT I.N.C
Member
 
Registered: May 2002
Location: Australia, Sydney, St.Clair
Distribution: Rh 7.3
Posts: 836

Original Poster
Rep: Reputation: 30
Man, no one has a slight idea?

I have been going through a billion configuration files and i can't find what i want......

Last edited by GT I.N.C; 10-31-2002 at 01:43 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Qt headers and libraries not found c-- Ubuntu 12 03-03-2009 07:16 PM
Fluxbox install, X libraries and headers csb Linux - Software 3 07-15-2005 08:59 AM
QT Libraries & Headers inescapeableus Linux - Software 9 05-03-2005 01:14 AM
KDevelop cannot find QT headers and libraries?! mscollins1 Programming 1 04-10-2004 04:12 PM
QT-1.3 (headers and libraries) not found. p_reah Linux - Software 2 04-17-2003 07:11 PM


All times are GMT -5. The time now is 05:06 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration