LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-10-2003, 11:19 PM   #1
i_is_cat
Member
 
Registered: Apr 2003
Distribution: redhat 7.2
Posts: 159

Rep: Reputation: 30
x cd roast


i just upgraded from redhat 7.2 to redhat 7.3 and i don't like it much so far it looks weird but anyways my problem is xcdroast won't come up i type in cdroast and the window pops up to enter the root pass so i enter it and then i get this error message

Xlib: connection to "0.0" refused by server
Xlib: No protocol specified


Gtk-WARNING **: cannot open display: 0.0

does anyone know what that means i've never encountered this problem before :/
 
Old 05-10-2003, 11:22 PM   #2
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
This means that you aren't in root's X environment. You either have to export root's display to your users (some distros do this for you by default, RH 7.2 may have, where 7.3 may not have) OR you have to open up a seperate X session for root:
startx -- :1

HTH

Cool
 
Old 05-11-2003, 02:05 AM   #3
yowwww
Member
 
Registered: Apr 2003
Location: Ontario, Canada
Distribution: Arch Linux
Posts: 533

Rep: Reputation: 30
k3b is much better

http://prdownloads.sourceforge.net/k...3.rpm?download
 
Old 05-11-2003, 06:00 AM   #4
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
Quote:
Originally posted by MasterC
This means that you aren't in root's X environment. You either have to export root's display to your users (some distros do this for you by default, RH 7.2 may have, where 7.3 may not have) OR you have to open up a seperate X session for root:
startx -- :1

HTH

Cool
or just run "xhost +localhost" as your normal user before becoming root. But then *anything* is better than xcdroast...

Cola
 
Old 05-11-2003, 01:44 PM   #5
i_is_cat
Member
 
Registered: Apr 2003
Distribution: redhat 7.2
Posts: 159

Original Poster
Rep: Reputation: 30
i tried startx -- :1 and it freaked me out at first heh it launched into gnome which i never use and i clicked on run and went to x cd roast and nothing happened.. any other suggestions?? and how can anything be better than x cd roast? i thought it was the only cd burning program for linux :/
 
Old 05-11-2003, 01:52 PM   #6
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
tried my advice?
 
Old 05-11-2003, 01:55 PM   #7
zakl
Member
 
Registered: May 2003
Location: Texas
Distribution: Gentoo
Posts: 80

Rep: Reputation: 15
If you don't want gnome to run when you startx as root, edit your .xinitrc in root's home directory and enter the window manager you prefer. I'm guessing you would want KDE, which to get KDE, simply log in as root at the console and type:

# echo "startkde" > ~/.xinitrc

That line will add the line "startkde" to your .xinitrc file and from now on when you type startx as root, you will load KDE instead of gnome.

As far as anything better than XCDroast, I personally think it's one of the best CD burning programs available for linux. But then again I really haven't used anything else

You probably need to enable non-root-mode for XCDroast. To do so:

1) startx as root
2) load XCDroast
3) go into setup, and click on the users tab.
4) at the bottom click on the button for "Chang non-root configuration"
5) click on "enable non-root mode"

This will enable standard users to execute and use XCDroast.

Let me know how it works out,

Zak

Last edited by zakl; 05-11-2003 at 01:57 PM.
 
Old 05-11-2003, 05:47 PM   #8
i_is_cat
Member
 
Registered: Apr 2003
Distribution: redhat 7.2
Posts: 159

Original Poster
Rep: Reputation: 30
acid_kewpie i don't even know what your advice is heh sorry man but i'm not that advanced with linux yet if you could explain it in detail plz? and zak i tried what you said but it didn't work it still opened to gnome and this time xcdroast wouldn't pop up at all i mean before logged in as a user it gave me the root pass prompt but it does nothing when logged in as root
the exact error message is as posted:

Xlib: connection to "0.1" refused by server
Xlib: No protocol specified


Gtk-WARNING **: cannot open display: .1

it was different earlier when i posted it which i'm assuming is because the first one was under a user...
 
Old 05-11-2003, 05:54 PM   #9
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
Quote:
run "xhost +localhost" as your normal user before becoming root
erm.. really can't see how to make it simpler... er... type it in...
 
Old 05-11-2003, 05:56 PM   #10
i_is_cat
Member
 
Registered: Apr 2003
Distribution: redhat 7.2
Posts: 159

Original Poster
Rep: Reputation: 30
damn i can't believe how stupid i am (or maybe just baked) lol
thanks for explaining it more clearly acid
that worked perfuectly thanx again
 
Old 06-26-2003, 07:16 PM   #11
zakl
Member
 
Registered: May 2003
Location: Texas
Distribution: Gentoo
Posts: 80

Rep: Reputation: 15
Hey, just wanted to update you... XCDRoast is teh SUX... I must have been mad to have said it was one of the best without exploring other options.

If you want to use IMHO the best, easiest CD creation software, get K3B. www.k3b.org. This program is practically a Roxio Easy CD Creator clone for linux, but it does MUCH MUCH more than Roxio. Simply the best GUI CD-R software.

Zak
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
X-CD-Roast reaky Linux - Software 1 02-18-2004 06:19 AM
X-CD-Roast help priest_judas Linux - Software 1 02-02-2004 08:52 PM
X-CD-Roast sparkplug55 Linux - Newbie 1 09-01-2003 10:39 PM
X-CD-Roast harrygraham Linux - Software 6 06-10-2003 08:04 PM
help on using x cd roast winex_user Linux - Software 8 02-09-2003 11:36 AM


All times are GMT -5. The time now is 04:30 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration