LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   wxWidgets plotctrl not installed by Opensuse package manager. (http://www.linuxquestions.org/questions/linux-software-2/wxwidgets-plotctrl-not-installed-by-opensuse-package-manager-846300/)

sniff 11-24-2010 10:32 AM

wxWidgets plotctrl not installed by Opensuse package manager.
 
Hello,

I am trying to install a program (snoopy2 petri net editor) under Opensuse 11.3 that requires libwxcode_gtk2u_plotctrl-2.8.so.0. This part of wxWidgets doesn't seem to be installed by Opensuse. Can I install it from source separately? Or is there a compatible binary somewhere?

Any help gratefully received.
Phil

knudfl 11-25-2010 12:01 AM

'snoopy2' http://www-dssz.informatik.tu-cottbus.de/snoopy.html
Code:

# rpm -Uvh snoopy-stable-linux-suse-2010-09-28.rpm
Failed dependencies:
        libwxcode_gtk2u_ogl-2.8.so.0 is needed by snoopy-3.01.1-1.i586
        libwxcode_gtk2u_plotctrl-2.8.so.0 is needed by snoopy-3.01.1-1.i586
        libwxcode_gtk2u_things-2.8.so.0 is needed by snoopy-3.01.1-1.i586
        rpmlib(PayloadIsLzma) <= 4.4.6-1 is needed by snoopy-3.01.1-1.i586

# 'rpm -Uvh --nodeps snoopy-stable-linux-suse-2010-09-28.rpm' will do.
The three missing files are included in the Fedora 13 package,
snoopy-stable-linux-fedora-2010-09-28.rpm
'rpm2cpio snoopy-stable-linux-fedora-2010-09-28.rpm | cpio -idmv' to open it.
Suse 11.2 : I did try with a copy to /usr/lib/ :
# cp libwxcode* /usr/lib/ , but the files are not compatible with Suse 11.2.

It may work in Suse 11.3 - 32, please try it out yourself.

I only have 11.3 - 64bits : No snoopy test possible, I think.

You may need this for your bug report ..
Contact: snoopy@informatik.tu-cottbus.de
..

P.S. : 'snoopy2' will open the GUI application OK on Fedora 13 - 32.
..

sniff 11-26-2010 07:05 AM

The snoopy team added the libraries to the rpm. Thanks snoopy team.:)


All times are GMT -5. The time now is 04:55 PM.