LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   wireshark rpm installation thru yum on RHEL5 (http://www.linuxquestions.org/questions/linux-software-2/wireshark-rpm-installation-thru-yum-on-rhel5-771369/)

g.navink 11-25-2009 12:05 AM

wireshark rpm installation thru yum on RHEL5
 
Hi,

I am using RHEL5 OS on Intel Core 2 Duo processor (64 bit processor).
I have a query regarding installation of wireshark on RHEL5.



Installed the repository release package from rpm
i updated the release package rpmforge-release-0.3.6-1.el5.rf.x86_64.rpm from " http://dag.wieers.com/rpm/packages/rpmforge-release/ "


After setting the proxy information, i was able to install vlc package thru yum confirming my yum configurations are ok. But when i do
$sudo yum install wireshark the below error occurs:

Loaded plugins: aliases, changelog, downloadonly, fastestmirror, filter-data, : keys, kmod, list-data, protect-packages, protectbase, rhnplugin,: security, tmprepo, verify, versionlock
This system is not registered with RHN.
RHN support will be disabled.
Loading mirror speeds from cached hostfile
* rpmforge: apt.sw.be
rpmforge | 1.1 kB 00:00
Reading version lock configuration
0 packages excluded due to repository protections
Skipping filters plugin, no data
Setting up Install Process
Parsing package install arguments
No package wireshark available.
Nothing to do

Upon going to rpmforge package directories found there is no wireshark package available. could that be the reason for the above message..


used the rpm wireshark-gnome-1.0.8-1.el5_3.1.i386.rpm from
for CentOS 5.3 from the link
"http://rpm.pbone.net/index.php3/stat/3/srodzaj/1/search/wireshark".

Upon doing yum install gnome-1.0.8-1.el5_3.1.i386.rpm as root, got error messages of dependency :
--> Running transaction check
---> Package wireshark-gnome.i386 0:1.0.8-1.el5_3.1 set to be updated
--> Processing Dependency: wireshark = 1.0.8-1.el5_3.1 for package: wireshark-gnome
--> Processing Dependency: libwireshark.so.0 for package: wireshark-gnome
--> Processing Dependency: libwiretap.so.0 for package: wireshark-gnome
--> Finished Dependency Resolution
wireshark-gnome-1.0.8-1.el5_3.1.i386 from wireshark-gnome-1.0.8-1.el5_3.1.i386.rpm has depsolving problems
--> Missing Dependency: wireshark = 1.0.8-1.el5_3.1 is needed by package wireshark-gnome-1.0.8-1.el5_3.1.i386 (wireshark-gnome-1.0.8-1.el5_3.1.i386.rpm)
wireshark-gnome-1.0.8-1.el5_3.1.i386 from wireshark-gnome-1.0.8-1.el5_3.1.i386.rpm has depsolving problems
--> Missing Dependency: libwireshark.so.0 is needed by package wireshark-gnome-1.0.8-1.el5_3.1.i386 (wireshark-gnome-1.0.8-1.el5_3.1.i386.rpm)
wireshark-gnome-1.0.8-1.el5_3.1.i386 from wireshark-gnome-1.0.8-1.el5_3.1.i386.rpm has depsolving problems
--> Missing Dependency: libwiretap.so.0 is needed by package wireshark-gnome-1.0.8-1.el5_3.1.i386 (wireshark-gnome-1.0.8-1.el5_3.1.i386.rpm)
Error: Missing Dependency: wireshark = 1.0.8-1.el5_3.1 is needed by package wireshark-gnome-1.0.8-1.el5_3.1.i386 (wireshark-gnome-1.0.8-1.el5_3.1.i386.rpm)
Error: Missing Dependency: libwiretap.so.0 is needed by package wireshark-gnome-1.0.8-1.el5_3.1.i386 (wireshark-gnome-1.0.8-1.el5_3.1.i386.rpm)
Error: Missing Dependency: libwireshark.so.0 is needed by package wireshark-gnome-1.0.8-1.el5_3.1.i386 (wireshark-gnome-1.0.8-1.el5_3.1.i386.rpm)

suggestions are welcome... thanks..
-navin

kbp 11-25-2009 12:32 AM

Wireshark is already included in RHEL 5, why are you downloading from 3rd party sites ?

g.navink 11-25-2009 03:51 AM

wireshark on RHEL5
 
it seems its not installed by default on my machine.. and i do not have access the dvd media. haven't checked on the rhel website..

knudfl 11-25-2009 05:27 AM

Redhat EL5 is unusable without the paid subscription.
The third party repo's like rpmforge will work only
when the basic repo is present and working.

Suggest : Install the free copy of EL5 : CentOS 5.4
.....


All times are GMT -5. The time now is 06:13 AM.