LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 02-10-2006, 05:05 PM   #1
IslanderTexas
LQ Newbie
 
Registered: Dec 2005
Posts: 12

Rep: Reputation: 0
Unhappy WinXP home client sees Linux Samba server but no access to shares


I've seen this problem posted on the net but never found an answer.
The Windows client sees the Samba server in Network Neighborhood but any attempt to access the server gives the error message:
\\Dell is not ccessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions.
The network path was not found.

The setup:
Server - Ubuntu Breezy 5.10
Cleint - Windows XP home sp2

my smb.conf file:
# Global parameters
[global]
workgroup = MILLENNIUM
server string = %h
security = SHARE
passdb backend = tdbsam, guest
passwd program = /usr/bin/passwd %u
passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spassword:* %n\n .
syslog = 0
log file = /var/log/samba/log.%m
max log size = 1000
preferred master = No
local master = No
domain master = No
dns proxy = No
wins support = Yes
panic action = /usr/share/samba/panic-action %d
invalid users = root

[homes]
comment = Home Directories
read only = No
create mask = 0775
directory mask = 0775
guest ok = Yes

[printers]
comment = All Printers
path = /tmp
create mask = 0700
printable = Yes
browseable = No

[print$]
comment = Printer Drivers
path = /var/lib/samba/printers

[dellserver]
path = /home
read only = No
guest ok = Yes

[shared_files]
path = /home/shared_files
force group = MILLENNIUM
read only = No
create mask = 0775
directory mask = 0775
guest ok = Yes
I have tried a million things to fix this including a complete re-install of Ubuntu. (no small fete with a raid5 disk array)
netbios ports are set in services
hostname = Dell
tried user vs share
can't access share with run command either
I have swat installed and running.
username and password are the same in Linux users, Samba users and on WinXp machine.
testparm is happy
I'll worry about security after I can get in! (intranet use of course, router serving DHCP addy's)
I'm stumped.
 
Old 02-10-2006, 07:51 PM   #2
accessrichard
Member
 
Registered: Apr 2005
Distribution: Fedora Core (latest version)
Posts: 156

Rep: Reputation: 30
I read that you added a user in SWAT but for some reason I tried that also and it didnt work. I would try setting security back to user and then ...

security = user


Code:
[root@localhost ~]# smbpasswd -a my_samba_username
New SMB password:
Retype new SMB password:
Added user my_samba_username
then in the shares add

valid users = my_samba_username

Last edited by accessrichard; 02-10-2006 at 07:57 PM.
 
Old 02-10-2006, 08:56 PM   #3
shaunw
Member
 
Registered: Dec 2005
Posts: 77

Rep: Reputation: 15
accessing network shares

Try making the shared directories browseable.
 
Old 02-11-2006, 03:38 AM   #4
IslanderTexas
LQ Newbie
 
Registered: Dec 2005
Posts: 12

Original Poster
Rep: Reputation: 0
Thanks for the input. I did try both things before but just to be sure I followed both suggestions. No change. I also made the share public. Again nothing.
If you install SWAT in Ubuntu you also need to install netkit-inetd.
 
Old 02-13-2006, 05:20 PM   #5
taiwf
Member
 
Registered: Jun 2005
Distribution: debian, ubuntu, redhat,knoppix
Posts: 194

Rep: Reputation: 31
hmm, i got similar problem as well. But later i found that if i use winxp pro with sp2 with lastest windows update it has no problem. (btw i am using workgroup setting too. All static ip) You can try using \\ip-address which should work(ip address work even with my xp pro sp1 machine). For home edition , i am not really sure coz never used it before.
 
Old 02-14-2006, 01:08 AM   #6
IslanderTexas
LQ Newbie
 
Registered: Dec 2005
Posts: 12

Original Poster
Rep: Reputation: 0
\\ip-address doesn't help. I can ping the server by ip address OR host/netbios name. Server shows up in Network neighborhood. It just won't let me access it.
I know XP home is um "less than ideal" for networking tasks but I'm trying to set this server up for a charity and I know some of their workstations have XP home. Also it does work for some people. The major difference would appear to be XP home does not support domains, only workgroups which is fine for their small network.
My latest unsucessful idea was to add the server to Zone Alarm's trusted zone. Somebody must know what I'm missing...
 
Old 02-14-2006, 10:36 AM   #7
IslanderTexas
LQ Newbie
 
Registered: Dec 2005
Posts: 12

Original Poster
Rep: Reputation: 0
From Windows services log:The name "MILLENNIUM :1d" could not be registered on the Interface with IP address 192.168.10.2(the winpc). The machine with the IP address 192.168.10.3(the linux server) did not allow the name to be claimed by this machine.
 
Old 02-15-2006, 04:20 AM   #8
Gunsnwater
LQ Newbie
 
Registered: Feb 2006
Posts: 9

Rep: Reputation: 0
I have the same problem, but I also get the message that the host name is a duplicate. My red hat 8 box shows up a samba server (localhost) I think I must name it something else as localhost is a loop back. I did manage to get linux to see win xp home share, but I had to be logged on as root. This is the second time and machine I am trying this on. The first one would crash my network when I got close to it working. I had apache running and wanted to write pages on widows boxes and transfer them to linux. This time I have a real server with 2 pent3 700mghz same red hat distro.8 this time I chose sever install and left out any dns services. I use a router and I think the dns was butting heads with the router. One other thing I used the slaxs bootable cd in windows laptops and the network browser worked without a problem. It doesnt find built in wifi but it does find pcmcia wifi cards. So I know this can work, I just dont know how yet.
 
Old 02-15-2006, 05:39 AM   #9
fotoguy
Senior Member
 
Registered: Mar 2003
Location: Brisbane Queensland Australia
Distribution: KirraMail Live Email Server
Posts: 1,275

Rep: Reputation: 61
Under the share you have this `force group = MILLENNIUM`, this will force all users accessing the share to the group MILLENNIUM, if it doesn't exist it maybe stopping you from accessing the share. Try commenting out the share and see if it works then:

#force group = MILLENNIUM

Also I'm not sure if it matters but everything in the global and shares except for comments should be lower case ,not upper case. It may not make a difference but i'm not sure if this is a problem for samba.

Did you also add root to samba as well, not just the normal users:

smbpasswd -a root

Also i'm not sure why you have this in the share section:

[dellserver]
path = /home
read only = No
guest ok = Yes

By default samba shares the users home directories (/home/username), do it this way will allow others to read or access other users home directories
 
Old 02-16-2006, 01:34 AM   #10
IslanderTexas
LQ Newbie
 
Registered: Dec 2005
Posts: 12

Original Poster
Rep: Reputation: 0
Thanks, fotoguy for the well thought suggestions. Forcing the group was just one of the million things I've tried. So at this point.
removed force group = MILLENNNIUM
added user root to smb users (I really thought that sounded like a gotcha)
changed the path for [dellserver] to /var (again just something I had tried)
changed all text in smb.conf to lower case, interestingly testparm show no and yes params as No and Yes. (I did confirm it's the same smb.conf)

One additional observation; if the Linux/Samba server is up when I boot the XP pc I get the no access message when trying to open the workgroup. In other words I can't even get to the XP pc in the network neighborhood.

I really don't want to wipe the Linux box and install Windows server ...
 
Old 02-16-2006, 02:14 AM   #11
timmeke
Senior Member
 
Registered: Nov 2005
Location: Belgium
Distribution: Red Hat, Fedora
Posts: 1,515

Rep: Reputation: 61
In the past, I have already seen some problems with XP Home connecting to Samba shares. The issue was related to the login, but you'll need to try it yourself to be sure.

The problem was this:
XP Home uses the full user's name (ie "John Doe", rather than the short username (ie "jdoe") to make the connection. XP Pro doesn't do that. When the Samba server sees that, he'll refuse the connection, since he doesn't know any user by the name of "John Doe", he only knows "jdoe".

Another issue maybe any intervening firewalls. A quick Google search shows that you should unblock ports 137, 138 and 139 (the netBIOS ports). XP SP2 has it's own firewall, so you may want to check it's configuration.
If your Linux box also has a firewall (like "iptables"), you may want to check that config too.

Furthermore, I've also noticed that Win XP Home doesn't reconnect the drives at reboot automatically, which can be a drag, for instance if you're using shared printers on the same host too (for some reason, Win XP Home needs to have a valid connection to a share on the machine before it can use the printers).

Gunsnwater, check your network configuration. You're not supposed to have the same hostname for 2 different IP addresses. This can be a DNS cache issue (try flushing it's cache). Or disable DNS altogether.

IslanderTexas, try contacting (ping) the Win box from the Server, using both hostnames and IP addresses. If your Win box can't register it's own computer's name, it's probably a networking error, but it can be a temporary glitch that goes away very rapidly. You can also try doing an "nslookup" (on the Win box) of your Win box's name and IP.
 
Old 02-16-2006, 06:51 AM   #12
dgw789
LQ Newbie
 
Registered: Feb 2006
Posts: 3

Rep: Reputation: 0
Try turning of IPTables on the Ubuntu Samba Server
 
Old 02-16-2006, 07:44 AM   #13
timmeke
Senior Member
 
Registered: Nov 2005
Location: Belgium
Distribution: Red Hat, Fedora
Posts: 1,515

Rep: Reputation: 61
Disabling a firewall is a possibility on the short term, for testing. But it can't be considered as
a safe, permanent solution.
If indeed iptables is the problem, try changing it's configuration to allow the traffic needed for the Samba stuff, not simply disable it altogether.
 
Old 02-16-2006, 05:42 PM   #14
IslanderTexas
LQ Newbie
 
Registered: Dec 2005
Posts: 12

Original Poster
Rep: Reputation: 0
I did solve one part of it. The sometimes inability to access the workgroup. It seems the default settings in XP networking is to use NetBIOS setting from DHCP server if available. The solution is to enable NetBIOS over TCP/IP You cannot access shared files and folders or browse computers in the workgroup
This doesn't allow me to access the samba box, just see it and the rest of the workgroup (the xp pc).
 
Old 02-16-2006, 05:59 PM   #15
IslanderTexas
LQ Newbie
 
Registered: Dec 2005
Posts: 12

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by dgw789
Try turning of IPTables on the Ubuntu Samba Server
How? I tried
$ sudo iptables -L

and get

Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination

I do have the NetBIOS ports listed in etc/services...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
WinXP cannot access samba shares from RH9 kc8tbe Linux - Software 24 02-20-2006 08:33 PM
Can't access samba from WinXP home Provi Linux - Networking 5 08-05-2004 11:21 AM
Samba: Can't access shares with WinXP thorax Linux - Software 14 07-28-2004 06:13 AM
How to access Linux Shares from WINXP Pro? murbz Linux - Networking 4 07-17-2004 06:10 AM
access linux shares from winxp flynnhandley Linux - Networking 2 08-27-2003 02:55 PM


All times are GMT -5. The time now is 01:41 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration