LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Winecfg crashes on sound tab with Pulseaudio and no 'sounddrivers' without pulseaudio (http://www.linuxquestions.org/questions/linux-software-2/winecfg-crashes-on-sound-tab-with-pulseaudio-and-no-%27sounddrivers%27-without-pulseaudio-813822/)

William (Dthdealer) 06-13-2010 03:09 AM

Winecfg crashes on sound tab with Pulseaudio and no 'sounddrivers' without pulseaudio
 
1 Attachment(s)
After losing all of my files to a dumb partitioning mistake on my part, I'm happy with my shiny new fedora 13 system.

I'm reinstalling my Windows games under wine currently ( Total Annihilation currently ) and everything works except the sound. By experience I know I have to open the 'audio' tab in winecfg and wine will normally auto-detect my sound settings.

No such luck. Winecfg crashes when I look at the tab. Knowing the problem is probably pulse-audio related, I did a yum remove pulseaudio ; killall pulseaudio.

Sound still works with the rest of the system, and the sound tab does not crash in winecfg. But now I'm presented with an empty list of 'Sound Drivers' with an options labelled 'Sound Drivers' that looks like it will expand when I click on its little '+' but it does not budge.

Changing the wine registry audio key to ALSA does not yield results either.

See attached

Is there a solution to my problem?

Fedora 13 64-bit

David the H. 06-13-2010 04:37 AM

I believe the driver entry is case sensitive. I tried editing mine from "alsa" to "ALSA" and subsequently winecfg complained that it was a non-existent driver.

If alsa isn't working for you, you can also try using the esd driver, since pulse was designed to be a drop-in replacement for it.

In addition to using regedit (HKEY_CURRENT_USER\Software\Wine\Drivers), you can also edit the ~/.wine/user.reg file directly. The sound driver entry is this:

Code:

[Software\\Wine\\Drivers] 1276414916
"Audio"="esd"

Muliple drivers can be separated with commas ("Audio"="esd,alsa"), although as the dialog says, this isn't recommended. My wine shows alsa, esd, oss, jack, and nas as options.

BTW, the number string on the first line appears to be simply the time (in epoch form) when the setting was changed.

And just for completeness, the DirectSound settings at the bottom part of the dialog appear to use this entry:

Code:

[Software\\Wine\\DirectSound] 1276414916
"DefaultBitsPerSample"="16"
"DefaultSampleRate"="44100"
"EmulDriver"="Y"
"HardwareAcceleration"="Full"

DefaultBitsPerSample can be 8 or 16, and DefaultSampleRate has options for 8000 11025 16000 22050 44100 or 48000. 44100/16 is CD quality, of course.

EmulDriver is Y or N. I'm not 100% sure what this does, since there's no direct equivalent for it in the gui. Best to just leave it on, I think.

HardwareAcceleration can be either Full or Emulation.

William (Dthdealer) 06-13-2010 05:03 AM

Quote:

Originally Posted by David the H. (Post 4001855)
I believe the driver entry is case sensitive. I tried editing mine from "alsa" to "ALSA" and subsequently winecfg complained that it was a non-existent driver.

Just tried. Caps or not putting alsa in the key does not change the outcome.

[quote[
If alsa isn't working for you, you can also try using the esd driver, since pulse was designed to be a drop-in replacement for it.
[/QUOTE]

A yum install esound and then changing the key to esd does not work either :(

David the H. 06-13-2010 05:35 AM

You didn't need to install esound. As I said, pulse is a drop-in replacement for esound. If you have pulse running, then anything that uses esd should work with it out-of-the-box.

But if none of the settings are working, then your problem must be something deeper than just winecfg. You might try stepping back to a previous version of wine, to determine if this is a recent bug.

William (Dthdealer) 06-13-2010 07:07 AM

Quote:

Originally Posted by David the H. (Post 4001879)
You didn't need to install esound. As I said, pulse is a drop-in replacement for esound. If you have pulse running, then anything that uses esd should work with it out-of-the-box.

But if none of the settings are working, then your problem must be something deeper than just winecfg. You might try stepping back to a previous version of wine, to determine if this is a recent bug.

Installing esound just installs the pulseaudio-esound-compat packages.

I cannot downgrade wine AFAIK, but I am new to the YUM system
Code:

root ~ $ yum list wine
Loaded plugins: presto, refresh-packagekit
fedora/metalink                                                                                                | 3.2 kB    00:00   
updates/metalink                                                                                              | 3.2 kB    00:00   
Available Packages
wine.i686                                                      1.1.38-1.fc13                                                    fedora
wine.x86_64                                                    1.1.38-1.fc13                                                    fedora
root ~ $ yum downgrade wine
Loaded plugins: presto, refresh-packagekit
Setting up Downgrade Process
No Match for available package: wine-1.1.38-1.fc13.i686
No Match for available package: wine-1.1.38-1.fc13.x86_64
Nothing to do
root ~ $

Perhaps if I remove the 64 bit version and just use the 32 bit package it will work.

EDIT: I only have the 32bit version ( i686 ) installed. Odd, I'll try the 64 bit package.

EDIT2: Problem still here.

David the H. 06-13-2010 08:30 AM

The winehq download page link for fedora leads here, and this says that the fedora packages have the audio drivers separated into separate packages. Not being a fedora user, it's unclear to me whether this refers to the official repository versions, or to a separate source. In any case, 1.1.38 is now several releases out of date, so you may want to try to compile your own, newer, version.

(Edit: The page also suggests backing up your configuration and testing problems with a fresh installation.)

I also found this bug report (which in turn leads here). It may or may not be related to what you're experiencing.

Incidentally, it also mentions that the 64bit version of wine will only run 64bit programs. (version 1.1.44 has added apparently added support, however.)


All times are GMT -5. The time now is 04:29 AM.