LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 07-20-2006, 10:39 PM   #1
SBN
Member
 
Registered: Jul 2006
Distribution: UBUNTU, CentOS, FEDORA 8
Posts: 474

Rep: Reputation: 30
Wine X11 Driver Problem!!!


I am using UBUNTU linux and i installed WINE. The installation is good...i followed everything that was said in the WINE website on how to install WINE. but when i try to run WINE it says that it can not create a window because X11 driver is missing. I tried to find X11 in the UBUNTU packages if it is there and i install every packe with X11 on it, then i compile and install WINE again but still it is still looking for X11.Pls help!!!!!
 
Old 07-20-2006, 10:43 PM   #2
ugenn
Member
 
Registered: Apr 2002
Posts: 549

Rep: Reputation: 30
Can you paste the exact error pls.
 
Old 07-21-2006, 09:38 PM   #3
SBN
Member
 
Registered: Jul 2006
Distribution: UBUNTU, CentOS, FEDORA 8
Posts: 474

Original Poster
Rep: Reputation: 30
this is the error:

err:imagelist:ImageList_ReplaceIcon no color!
err:imagelist:ImageList_ReplaceIcon no color!
err:imagelist:ImageList_ReplaceIcon no color!
err:imagelist:ImageList_ReplaceIcon no color!
Application tried to create a window, but no driver could be loaded.
The X11 driver is missing. Check your build!
Application tried to create a window, but no driver could be loaded.
The X11 driver is missing. Check your build!
 
Old 07-21-2006, 09:59 PM   #4
ugenn
Member
 
Registered: Apr 2002
Posts: 549

Rep: Reputation: 30
hmmm...is your DISPLAY environment variable setup properly?
 
Old 07-22-2006, 12:44 AM   #5
SBN
Member
 
Registered: Jul 2006
Distribution: UBUNTU, CentOS, FEDORA 8
Posts: 474

Original Poster
Rep: Reputation: 30
What do you mean?
 
Old 07-22-2006, 12:55 AM   #6
ugenn
Member
 
Registered: Apr 2002
Posts: 549

Rep: Reputation: 30
Nevermind that,
do you have a winex11.drv.so in your (prefix)/lib/wine director and is not corrupted?
 
Old 07-22-2006, 05:57 AM   #7
SBN
Member
 
Registered: Jul 2006
Distribution: UBUNTU, CentOS, FEDORA 8
Posts: 474

Original Poster
Rep: Reputation: 30
Yes! its there.
 
Old 07-22-2006, 10:43 AM   #8
ugenn
Member
 
Registered: Apr 2002
Posts: 549

Rep: Reputation: 30
Run ldd on it. Make sure there aren't any missing deps.
 
Old 07-23-2006, 08:53 PM   #9
SBN
Member
 
Registered: Jul 2006
Distribution: UBUNTU, CentOS, FEDORA 8
Posts: 474

Original Poster
Rep: Reputation: 30
Im sorry but i dont know how to do that. can you teach me pls.
 
Old 07-23-2006, 09:23 PM   #10
ugenn
Member
 
Registered: Apr 2002
Posts: 549

Rep: Reputation: 30
ldd (prefix)/lib/wine/winex11.drv.so
 
Old 07-24-2006, 01:04 AM   #11
SBN
Member
 
Registered: Jul 2006
Distribution: UBUNTU, CentOS, FEDORA 8
Posts: 474

Original Poster
Rep: Reputation: 30
Thanks for the help! i cant find the driver so i just uninstall wine and install it again now it works. thanks for the help!

-SBN-
 
Old 06-21-2010, 05:33 PM   #12
Kurоsh
LQ Newbie
 
Registered: Jun 2010
Posts: 1

Rep: Reputation: 0
Hi, sorry for bringing this old topic up!
but I did what ugenn said, I ran ldd on the directory and I received this:
Quote:
linux-gate.so.1 => (0x00fef000)
libSM.so.6 => /usr/lib/libSM.so.6 (0x007fa000)
libICE.so.6 => /usr/lib/libICE.so.6 (0x00bfd000)
libXext.so.6 => /usr/lib/libXext.so.6 (0x00889000)
libX11.so.6 => /usr/lib/libX11.so.6 (0x003a5000)
libwine.so.1 => /usr/local/lib/libwine.so.1 (0x00cdf000)
libm.so.6 => /lib/tls/i686/cmov/libm.so.6 (0x009ae000)
libc.so.6 => /lib/tls/i686/cmov/libc.so.6 (0x00110000)
libuuid.so.1 => /lib/libuuid.so.1 (0x0026a000)
libxcb.so.1 => /usr/lib/libxcb.so.1 (0x0026f000)
libdl.so.2 => /lib/tls/i686/cmov/libdl.so.2 (0x00289000)
/lib/ld-linux.so.2 (0x00781000)
libXau.so.6 => /usr/lib/libXau.so.6 (0x006e0000)
libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0x0028d000)
Now, what should I do? I have still exactly the same problem as SBN
This error occurs using Wine
Quote:
Application tried to create a window, but no driver could be loaded.
The X11 driver is missing. Check your build!
Application tried to create a window, but no driver could be loaded.
The X11 driver is missing. Check your build!
errle:apartment_createwindowifneeded CreateWindow failed with error 126
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
problem with fonts in kmenu and kontrolpanel and wine after ati driver installation seelenbild28 Suse/Novell 1 03-19-2006 06:41 AM
Core 4 - X11-devel complains about X11-libs which are installed Ephracis Fedora 3 09-05-2005 09:32 AM
sarge X11 driver .deb for intel 915 deepclutch Debian 2 06-12-2005 08:38 AM
Synaptics USB Touchpad - X11 Driver GerbilSoft Linux - Laptop and Netbook 0 03-31-2005 03:43 AM
nvidia 66.29 driver-xorg-x11-Mesa-libGL conflict yellowtail Linux - Software 3 02-28-2005 08:34 PM


All times are GMT -5. The time now is 11:50 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration