LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 04-25-2013, 10:41 PM   #1
TechnoJunky
LQ Newbie
 
Registered: Aug 2007
Location: Chicago
Distribution: Mint 14
Posts: 18

Rep: Reputation: 0
Wine audio configuration issues


I have a SB Audigy 2 card, and a 5.1 speaker setup. After installing Mint, I had no sound. I messed with kmix and moved my Sound Blaster devices to the top of the preferred lists. Then went into the Audio Hardware Setup and configured the SB Audigy profile for Analog Surround 5.1 Output. The sound was perfect for everything, except for anything running thru Wine. I had installed the Netflix desktop and the movies would run in fast forward, sound skipping frames skipping by about 3 secs. Games running thru Wine would sound like they're skipping or no sound at all. I reconfigured the SB Audigy profile for Analog Stereo Duplex and then Wine apps sound and work fine. However I'm really not happy with the limited sound (plain 2.0 stereo, ick). So is there anyway to fix Wine so that it runs correctly with the 5.1 sound profile? Or is there a way to make Wine run in 2.0, while everything else Linux native runs in 5.1 (without switching back and forth manually)?
 
Old 04-27-2013, 08:01 AM   #2
Sigg3.net
Member
 
Registered: Mar 2008
Location: Oslo, Norway
Distribution: Fedora 17, Ubuntu 12 LTS and Ubuntu server 10.04
Posts: 161

Rep: Reputation: 23
You could try changing the sound driver wine uses from alsa to pulse or vice-versa.

I seem to recall it's in 'winecfg'. Remember to prefix with your wine-profile, if you use such a thing.

Also, running winetricks and see drivers and / or software could list something audigy related.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] No audio in Wine nnjond Linux - Newbie 3 06-21-2011 07:04 PM
Game Editor with WINE couple issues. (with /lib in linux, and window size in wine) Hevithan Linux - Newbie 1 05-23-2011 02:52 PM
Audio issues on VIA audio :( beatupbilly Linux - Laptop and Netbook 2 07-16-2007 12:12 AM
Wine hangs on "wine: creating configuration directory" ttnunam Linux - Software 9 12-10-2006 03:02 AM
WINE issues: configuration, installation, etc D10|\/|3|)3$ Linux - Software 5 01-24-2005 08:47 AM


All times are GMT -5. The time now is 12:35 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration