LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Windows on HDA1 mounting (http://www.linuxquestions.org/questions/linux-software-2/windows-on-hda1-mounting-509267/)

kcpaige89 12-10-2006 10:53 PM

Windows on HDA1 mounting
 
I've tried several variations on my /etc/fstab to get My debian box to dual boot. I keep getting this error no matter what I put in fstab.
Code:

mount: wrong fs type, bad option, bad superblock on /dev/hda1,
      missing codepage or other error
      (aren't you trying to mount an extended partition,
      instead of some logical partition inside?)
      In some cases useful info is found in syslog - try
      dmesg | tail  or so

right now my fstab looks like this.
Code:

# /etc/fstab: static file system information.
#
# <file system> <mount point>  <type>  <options>      <dump>  <pass>
proc            /proc          proc    defaults        0      0
/dev/hdb6      /              ext3    defaults,errors=remount-ro 0      1
/dev/hdb7      /home          ext3    defaults        0      2
/dev/hdb8      /windows        vfat    defaults        0      2
/dev/hda1        /XP                ntfs        ro,user                0        2
/dev/hdb5      none            swap    sw              0      0
/dev/hdd        /media/cdrom0  iso9660 ro,user,noauto  0      0
/dev/hdc        /media/cdrom1  iso9660 ro,user,noauto  0      0
/dev/fd0        /media/floppy0  auto    rw,user,noauto  0      0
/dev/sda        /media/usb0    auto    rw,user,noauto  0      0


tshrinivasan 12-11-2006 01:09 AM

is that /dev/hda1 i.e c: in windows XP is an ntfs partition?
try giving vfat.

kcpaige89 12-11-2006 01:21 AM

yes
 
yes, it is nfts. hda1 is C:/

Bruce Hill 12-11-2006 04:06 PM

In a terminal as root issue "fdisk -l" and post the output.

But I believe this is your problem:
Code:

/dev/hda1        /XP                ntfs        ro,user                0        2
Users can't mount a filesystem owned by root (e.g. NTFS).

Change your line in /etc/fstab to this and try again:
Code:

/dev/hda1        /XP          ntfs        ro              1  0

kcpaige89 12-11-2006 08:05 PM

tried
 
I tried that and did not succeed. IDK what the <dump> and <pass> doo but i tried 0 0, 1 0, 0 1, 1 1, 2 1, 1 2, and 2 2. with no luck. I've also changed ro to defaults, rw, and left it blank. Still no luck. Anyone else have any ideas?

pixellany 12-11-2006 08:23 PM

This train may have left the tracks at the station.....you said you were trying to get your system to dual boot. That has nothing to do with fstab.

If you are trying to mount an ntfs partition, note that ntfs support must be in the kernel.

Here is my fstab entry for my Windows partition:

/dev/sda1 /mnt/sda1 ntfs noauto,users,exec,ro,umask=0222 0 0

This mounts it as read-only for all users

kcpaige89 12-11-2006 09:41 PM

ok, I figured out that I had a back up drive on windows as hda1 that was vfat, the hda2 is the ntfs drive and i mounted it correctly.

Now all I need to do is to set it so only root and my user account can read this. what umask setting would that be. I tried 666 and 777 but i'm pretty sure i don't know what I'm doing in fstab. I used to use Fedora and it would mount it in installation, but i forgot to do that in Debian. Thanks in advance.

pixellany 12-11-2006 10:40 PM

Quote:

Originally Posted by kcpaige89
ok, I figured out that I had a back up drive on windows as hda1 that was vfat, the hda2 is the ntfs drive and i mounted it correctly.

Now all I need to do is to set it so only root and my user account can read this. what umask setting would that be. I tried 666 and 777 but i'm pretty sure i don't know what I'm doing in fstab. I used to use Fedora and it would mount it in installation, but i forgot to do that in Debian. Thanks in advance.

umask is the inverse of the octal codes specified for --eg--the chmod command.

Read each rwx group as an octal number from 0-7:
r=4
w=2
x=1
So, in chmod: 7=rwx, 6=rw, 5=rx......etc.

umask TURNS OFF bits that would otherwise be on. thus umask 222 turns off write privileges for everyone. Root always has full privileges so to turn off privileges for all but one account, you would need 7 in the last field AND the user with privileges would have to either be the file owner or belong to the group.

I may have already spoken beyond my knowledge...;) Look at man umask, man chmod, etc.


All times are GMT -5. The time now is 08:44 AM.