LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 11-23-2006, 05:06 PM   #1
easuter
Member
 
Registered: Dec 2005
Location: Portugal
Distribution: Slackware64 13.0, Slackware64 13.1
Posts: 538

Rep: Reputation: 62
Exclamation WindowMaker problems: WPrefs is corrupted?


Last week I compiled WindowMaker 0.92 on VectorLinux RC3 and packaged it.

After booting into WindowMaker, i get the usual default purple-ish wallpaper, the paper-clip, and the 3 dock-apps on the right (step, terminal, and wprefs).
However, the WPrefs dock-app didn't have its icon (a flat screw-driver). In its place was a bitmap with what looked like several colorful ribbons, which in Windowmaker means thatits using a "generic" bitmap because the proper one wasn't found.
Opening WPrefs brought up the usual window, but with ABSOLUTELY NO BITMAPS. the buttons and bullets were there, but there were no icons/bitmaps where they should be. For those who are familiar with WPrefs, its a pain in the butt to blindly click to find the right menu.

I have tried compiling WindowMaker with different flags, but none of them fix this problem.
The first compilation i did was with these flags:


Code:
./configure --prefix=/usr --enable-kde --enable-gnome

I decided to recompile with the prefix to /usr/X11R6 instead, but that didn't help either, i just got the same icon-less WPrefs.

Here is a screenshot:

http://clientes.netvisao.pt/alynnsut/vl/wprefs.png

No error/warning messages were issued during the configure/make process.

Any idea what I'm doing wrong here?

Thanks in advance!
 
Old 11-25-2006, 02:13 AM   #2
b0uncer
Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
Heh, funny that you mention it I compiled the (newest) WindowMaker a few weeks ago, without errors (didn't create any kind of binary package) and installed it. And as you may guess, I don't neither have the bitmaps you mentioned -- now the funny part is that I didn't even miss them. It's been so long ago since I last used WMaker so I couldn't even remember if there should be anything. Of course it looked a bit odd having just plain squares there on the screen, but I thought "maybe it's just the way this works".

And no, it's not a pain in the ass - on one of the settings "tabs" there is an option (checkbox) to turn "balloon help" on. It means that when you put your mouse over one of those "empty boxes", you'll get a nice balloon which tells what's inside that tab. It helps a bit, at least -- the bitmaps wouldn't harm I guess, but I don't use that tool that often anyway, that I couldn't deal with it (and after two times of using it I can somehow remember where the options are I'm looking for, at least in which end, so it's just about seconds to find it).

Anyway, if you find a way to get some images there, I'd be glad to hear. Here it can be seen again that if one doesn't know about something, one can't miss it.
 
Old 11-26-2006, 04:24 AM   #3
easuter
Member
 
Registered: Dec 2005
Location: Portugal
Distribution: Slackware64 13.0, Slackware64 13.1
Posts: 538

Original Poster
Rep: Reputation: 62
Yeah, I was eventually pointed in the right direction in another forum, so here is the fix:

Code:
./configure --prefix=/usr --with-gnustepdir=/usr/lib/GNUstep
Don't ask me why the GNUstep dir has to be that one, because it makes no sense to me, but it fixes it!

By the way, depending on which system you use, your prefix may be different, but the GNUstep dir has to be /usr/lib/GNUstep

 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
windowmaker zeratul3 Linux - Newbie 1 10-17-2003 02:05 PM
Continuous problems installing WindowMaker? BajaNick Linux - General 7 09-01-2003 12:34 AM
windowmaker problems salparadise Linux - Newbie 5 01-28-2003 12:05 PM
WindowMaker (LOF)Chm0d Linux - Distributions 1 01-21-2003 04:41 AM
Cant get out of WindowMaker--HELP SirLostalot Linux - Newbie 2 11-11-2002 12:03 PM


All times are GMT -5. The time now is 06:17 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration