LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-05-2002, 11:10 AM   #1
darthtux
Senior Member
 
Registered: Dec 2001
Location: 35.7480 N, 95.3690 W
Distribution: Debian, Gentoo, Red Hat, Solaris
Posts: 2,070

Rep: Reputation: 46
Red face WindowMaker installation problem


I am using Red Hat 6.1 and had WindowMaker0.61. Tried to install 0.80. The installation produced good output. However, when I start X using root 0.61 still starts. When starting X with a user account I get the error:
"wmaker: error in shared libraries: libwraster.s0.2: cannot open shared object file: no such file or directory".
I tried reinstalling 0.61 but no good.
If I can't get 0.80 going I would still like to be able to user 0.61 on the user accounts.

Thanks,
James
 
Old 07-05-2002, 11:15 AM   #2
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
sounds like you need to run ldconfig, and maybe add the lib path to /etc/ld.so.conf
 
Old 07-05-2002, 11:33 AM   #3
darthtux
Senior Member
 
Registered: Dec 2001
Location: 35.7480 N, 95.3690 W
Distribution: Debian, Gentoo, Red Hat, Solaris
Posts: 2,070

Original Poster
Rep: Reputation: 46
I did as you said and same problem.
 
Old 07-05-2002, 11:36 AM   #4
darthtux
Senior Member
 
Registered: Dec 2001
Location: 35.7480 N, 95.3690 W
Distribution: Debian, Gentoo, Red Hat, Solaris
Posts: 2,070

Original Poster
Rep: Reputation: 46
Why does the root account get 0.61 and the users the error? I would be satisfied getting 0.61 going.
 
Old 07-05-2002, 12:42 PM   #5
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
did you try removing the files in the home folder for wmaker
 
Old 07-05-2002, 01:31 PM   #6
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,569

Rep: Reputation: 171Reputation: 171
Or you may try to create a symlink to new startwindowmaker in a directory that's in your PATH before the one the old startwindowmaker is in.
 
Old 07-05-2002, 02:18 PM   #7
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
when I installed wmaker I ran switchdesk and then it worked in gdm


did you run wmaker.inst
 
Old 07-05-2002, 09:33 PM   #8
darthtux
Senior Member
 
Registered: Dec 2001
Location: 35.7480 N, 95.3690 W
Distribution: Debian, Gentoo, Red Hat, Solaris
Posts: 2,070

Original Poster
Rep: Reputation: 46
I learned all about ldconfig, backed up my GNUstep directory, and ran wmaker.inst. Now, WindowMaker comes up to the Desktop and crashes. The error is:

"wmaker: error in loading shared libraries:
wmaker: undefined symbol: PLShallowSynchronize"

Thanks for all your help and knowledge so far,
James
 
Old 07-05-2002, 10:40 PM   #9
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
make sure that /etc/ld.so.config has /usr/local/lib

I believe the libs should be there.


also look around for some old libs left over from the old install, if they are found in the libs paths before that right ones are they will cause problems.
 
Old 07-06-2002, 02:48 PM   #10
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,569

Rep: Reputation: 171Reputation: 171
In ld.co.config every directory is in another line. So put /usr/local/lib in the next line after the last one you have (in most distros there's only one line there).
 
Old 07-06-2002, 10:43 PM   #11
darthtux
Senior Member
 
Registered: Dec 2001
Location: 35.7480 N, 95.3690 W
Distribution: Debian, Gentoo, Red Hat, Solaris
Posts: 2,070

Original Poster
Rep: Reputation: 46
Tried all failed. Is there any way to get rid of version 0.80. I mean, 0.61 works fine for the root account and I would just rather have it working for the users accounts.
 
Old 07-07-2002, 01:29 PM   #12
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
you can run make uninstall
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
WindowMaker Compilation Problem megadeth Linux - Software 0 10-08-2005 10:59 PM
installation shell script not running (mandrake 10.1 / windowmaker) batfastad Linux - Newbie 6 11-15-2004 04:11 PM
WindowMaker Problem VIP3R Linux - Software 4 03-18-2004 08:49 AM
WindowMaker Icon Problem SML Linux - Newbie 4 03-10-2004 02:48 PM
Need more help with windowmaker installation BajaNick Linux - Software 3 07-08-2003 11:42 PM


All times are GMT -5. The time now is 02:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration