LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Win98 cannot acces share on Samba (http://www.linuxquestions.org/questions/linux-software-2/win98-cannot-acces-share-on-samba-111930/)

jonabyte 11-03-2003 03:14 PM

Win98 cannot acces share on Samba
 
Hey all

I have got a nt domain and 25 users with mixed 98-xp, I have setup a samba server on rh9.
I can see the computer in net neighbourhood. I can double click the samba computer and see the shares, when I try to access the share it wants a password. I have tried the root pass, the pass for the one user setup on rh9, as well as many others, but no luck. Any ideas? Below is the smb.conf.
Thanks

# Global parameters
[global]
workgroup = CSD
netbios name = SAMBA
server string = samba
security = DOMAIN
encrypt passwords = Yes
obey pam restrictions = Yes
password server = Server
pam password change = Yes
passwd program = /usr/bin/passwd %u
passwd chat = *New*password* %n\n *Retype*new*password* %n\n *passwd:*all*authentication*tokens*updated*successfully*
username map = /etc/samba/smbusers
unix password sync = Yes
log file = /var/log/samba/%m.log
max log size = 0
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
dns proxy = No
guest ok = Yes
printing = cups

[homes]
comment = Home Directories
valid users = %S
read only = No
create mask = 0664
directory mask = 0775
browseable = No

[printers]
comment = All Printers
path = /var/spool/samba
printable = Yes
browseable = No

[data]
path = /data
valid users = %S
read only = No
hosts allow = 10.0.0.

nightjar 11-03-2003 04:05 PM

Need you a pass?
If you think that it's not necessary then set security = share
and...restart samba :)

jonabyte 11-04-2003 09:01 AM

Already tried that, but I could not access the Samba server, I got a windows error stating that the network path could not be found, even though the server appears on network neighbourhood.

jjohnston62 11-04-2003 03:24 PM

First of all, go through the samba docs to make sure your security is actually set how you want it. You don't mention whether you want to use the authentication within the NT domain (joining your samba server to that domain), or if you're expecting to use local authentication.

If you're using local authentication, you need to make sure that you've got both a linux user and a samba user created and that the mappings are correct.


Jon J.

nightjar 11-04-2003 03:37 PM

Quote:

Originally posted by jonabyte
Already tried that, but I could not access the Samba server, I got a windows error stating that the network path could not be found, even though the server appears on network neighbourhood.
Is /data
a real path?

I give you the Global parameters of my samba

# Global parameters
[global]
log file = /var/log/samba/log.%m
dns proxy = No
netbios name = XXXXXXX (the name of your)
server string = Samba Server %v
passwd chat = *New*UNIX*password* %n\n *ReType*new*UNIX*password* %n\n
printing = cups
socket options = TCP_NODELAY SO_SNDBUF=8192 SO_RCVBUF=8192
unix password sync = Yes
workgroup = smooth
os level = 20
printcap name = cups
security = share
passwd program = /usr/bin/passwd %u
max log size = 50

[jorge]
path = /home/jorge
read only = No
create mask = 0777
guest only = Yes
guest ok = Yes
browseable = yes
[root]
path = /
read only = No
create mask = 0777
guest only = Yes
guest ok = Yes
browseable = yes

you can add printers, etc

After that run testparm

and then restart samba

/etc/rc.d/init.d/smb restart

jonabyte 11-07-2003 12:31 PM

Hi there
Yes I a pretty sure thats the way I want the security set (it was the only was the I could enter the samba server to see the shares), and I was successful in joining the NT domain.
When you say both samba and linux user, do I need the user name and pass the same in the NT domain, (ie use my win98/nt user name and pass that I use to logon to the domain).
And, yes the path does exist.
Thanks

mjrdzine 12-02-2003 01:15 AM

i think i lost the response i tried to send so pardon me if i actually respond twice. I think what jjohnston62 was suggesting is that you need to try creating a linux user and then create a samba user with the same name/pswd You use the command smbuseradd (or some thing very close to that) It will reply back with directions for the proper syntax. Sorry i can't be more detailed, my memory is 2 steps closer to bed than my body. Hope i helped.

paul.nel 12-02-2003 09:04 AM

Also remember that the samba user that the Windows machines uses to log into the linux box should have access privilages on the shared linux directories. Ie, if you created the shared directories on the linux box as root, your samba user will probably not have access. If this is a problem, you can change your directory privilages with chmod or change ownership with chown.

Hope this helps
p.n


All times are GMT -5. The time now is 02:36 AM.