LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 02-25-2003, 05:17 PM   #1
scheidel21
Senior Member
 
Registered: Feb 2003
Location: CT
Distribution: Debian PPC/i386/AMD64 6/7, Vista, XP , WIN7, Server 03/08
Posts: 1,287

Rep: Reputation: 97
Unhappy win xp home edition and samba home shares


I have a samba server setup on my home lan running a debian 3.0 server 2.2 kernal samba 2.2.3a-12 I have 2 winXP homedition PCs connected I can see all the computers in the workgroup, I can access shares on the win machines from linux, and I can access all shares on the samba server except for the homes share, even my own , I have security set to user and I logo on fine initially with any user name I have listed except when I attempt to access the homes share, or my own shares folder it requests I re-enter username password, I do so and it spits back at me with my computer name and the username I entered without allowing me access to those folders.

\\Alex\scheidel21 is what it spits back in username box...the valid smbpasswd username is scheidel21....the username alone allows me access to printers, other shares, just not home share any ideas?
 
Old 02-25-2003, 11:47 PM   #2
ranger_nemo
Senior Member
 
Registered: Feb 2003
Location: N'rn WI -- USA
Distribution: Kubuntu 8.04, ClarkConnect 4
Posts: 1,142

Rep: Reputation: 47
Might be a typo in your [homes] section of your samba.conf . Post it here so we can look.
 
Old 02-26-2003, 12:16 AM   #3
scheidel21
Senior Member
 
Registered: Feb 2003
Location: CT
Distribution: Debian PPC/i386/AMD64 6/7, Vista, XP , WIN7, Server 03/08
Posts: 1,287

Original Poster
Rep: Reputation: 97
This is the smb.conf file it seems ok.

[global]
passwd program = /usr/bin/passwd %u
domain master = yes
printing = bsd
dns proxy = yes
syslog only = no
name resolve order = lmhosts host wins bcast
encrypt passwords = yes
socket options = TCP_NODELAY IPTOS_LOWDELAY SO_SNDBUF=4096 SO_RCVBUF=4096
short preserve case = yes
wins support = true
printcap name = /etc/printcap
invalid users = root
max log size = 1000
announce as = NT Server
passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spassword:* %n\n
prefered master = yes
preserve case = yes
security = user
unix password sync = true
local master = yes
workgroup = MSHOME
server string = %h server (Samba %v)
syslog = 4;
netbios name = debian
load printers = yes
os level = 65
public = yes

[homes]
writable = yes
comment = Home Directories
create mask = 0700
only user = yes
directory mask = 0700
browseable = yes

[tmp]
path = /tmp
browseable = yes
writeable = yes

[icecast]
path = /usr/share/icecast/static/
browseable = yes
writeable = yes

[printers]
comment = All Printers
browseable = no
path = /tmp
printable = yes
public = no
writable = no
create mode = 0700


I'm kinda dumbfounded don't know what to do. thanks guys
 
Old 02-26-2003, 06:25 PM   #4
ranger_nemo
Senior Member
 
Registered: Feb 2003
Location: N'rn WI -- USA
Distribution: Kubuntu 8.04, ClarkConnect 4
Posts: 1,142

Rep: Reputation: 47
I have...
Code:
[homes]
   comment = Home Directories
   browseable = no
   writable = yes
   valid users = %S
   create mode = 0664
   directory mode = 0775
 
Old 02-26-2003, 06:29 PM   #5
ranger_nemo
Senior Member
 
Registered: Feb 2003
Location: N'rn WI -- USA
Distribution: Kubuntu 8.04, ClarkConnect 4
Posts: 1,142

Rep: Reputation: 47
From the smb.conf man page...
Code:
only user (S)
              This  is a boolean option that controls whether connections with
              usernames not in the user list will be allowed. By default  this
              option  is disabled so that a client can supply a username to be
              used by the server.  Enabling  this  parameter  will  force  the
              server  to  only  user the login names from the user list and is
              only really useful in shave level security.

              Note that this also means Samba won’t try  to  deduce  usernames
              from the service name. This can be annoying for the [homes] sec‐
              tion. To get around this you could use user  =  %S  which  means
              your  user  list  will  be just the service name, which for home
              directories is the name of the user.
 
Old 02-27-2003, 12:26 AM   #6
scheidel21
Senior Member
 
Registered: Feb 2003
Location: CT
Distribution: Debian PPC/i386/AMD64 6/7, Vista, XP , WIN7, Server 03/08
Posts: 1,287

Original Poster
Rep: Reputation: 97
thanks man it worked, worked like a dream
 
Old 09-19-2003, 04:40 AM   #7
chk
LQ Newbie
 
Registered: Sep 2003
Location: Switzerland
Distribution: debian
Posts: 1

Rep: Reputation: 0
Question Same Configuration => Same Error, even after hints

Hi all,
In principle I have the same configuration as described here: WIN XP Home (German SP1, Workgroup ART ComputerName Greifensee) and Linux (Debian Kernel 2.4.20) Samba 2.2.3a-6 for Debian. I can ssh from winxp using PUTTY to linux. I can even use samba from a WIN2kPro PC but not from my WINXPHOME.

I used the conf file published here but changed : workgroup = ART and uncommented icecast section.

Trying to log on password dialog opens and I give details for my home account on this machine and the dialog comes back with \\GREIFENSEE\kaas the log files of samba in /var/log/samba/ say : passdb/pdb_smdpasswd.cdb_getsampwnam(1367) unable to open passdb database ?

Any hint would help.
Thanks
Christian
 
Old 09-26-2003, 06:10 AM   #8
scheidel21
Senior Member
 
Registered: Feb 2003
Location: CT
Distribution: Debian PPC/i386/AMD64 6/7, Vista, XP , WIN7, Server 03/08
Posts: 1,287

Original Poster
Rep: Reputation: 97
logon problem

sounds as though it is unable to acccess your database of passwords.....I don't know I wonder if it may be somethings to do with service pack 1 I have heard of it causing problems similar to this with Samba, I suggest if you can try it with an XP machine without SP1 and see what that gets you, good luck sir

AS
 
Old 10-09-2008, 01:47 AM   #9
khan_ihsanullah
LQ Newbie
 
Registered: Oct 2008
Posts: 3

Rep: Reputation: 0
samba configuration VISTA and LINUx

I have vista home edition in my laptop.
I have to connect it with LINUX server.
I have used samba 3.0.x for that purpose.
VISTA does not support secpol.msc then i changed my registry value of LSA Lmcompitability Dword value to 1. But VISTA is not connecting with server. One thing that xp home edition is working perfectly.Please answer as quickly as possible.
 
  


Reply

Tags
samba


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba does not allow writing to public shares / browsing home directories disallowed Xolo Linux - Software 6 02-14-2005 05:22 PM
Apache subdomains like Samba home-shares toffi22 Linux - Software 1 01-30-2005 08:16 PM
samba home directory shares walewis Linux - Software 8 09-28-2003 07:03 PM
XP home fails to connect to samba shares J_Szucs Linux - Software 1 05-16-2003 11:21 PM
Samba & WIN XP Home pid79 Linux - Networking 1 03-18-2003 01:36 PM


All times are GMT -5. The time now is 10:05 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration