LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 04-23-2003, 03:34 PM   #1
bripage
Member
 
Registered: Jan 2002
Location: Moorpark
Distribution: SLACK 8!
Posts: 230

Rep: Reputation: 30
Win XP doesnt see samba share, but can connect to it.


I have samba configured. I know it works because I can get into it from my windows machine by using the address:

\\192.168.2.150

From there the samba server asks for the username and password like normal and works fine. What I want to know is why my windows XP machine wont see the samba hare when there set to be on the same workgroup and what not.


Heres my smb.conf:


[global]
workgroup = home
encrypt passwords = yes
smb passwd file = /etc/samba/private/smbpasswd
log file = /var/log/samba.log.%m.%T.
security = user
hosts allow = 192.168.1. 192.168.2.
socket options = TCP_NODELAY



[homes]
comment = Home Directories
writable = yes
guest ok = no
valid users = %S
browsable = yes
read only = no
create mask = 0600
directory mode = 0700


[public]
comment = PUBLIC
path = /home/public
public = yes
writable = yes
printable = no
read only = no
browsable = yes


Also... for some reason I can right to my homes share.. but not the public share.. why is that?
 
Old 04-23-2003, 05:28 PM   #2
Burke
Member
 
Registered: Dec 2002
Location: Virginia, USA
Distribution: Fedora Core 3
Posts: 131

Rep: Reputation: 15
Here's what seems to work well for my little network: (WinXP Pro, Win2k Pro workstations). I think there is a registry tweak that has been mentioned several times before in the forums here for XP to work with Samba. I don't remember it though..

[public]
writeable = yes
path = /home/public
force directory mode = 775
force group = users
force create mode = 775
comment = Public Stuff
create mode = 775
directory mode = 775
 
Old 04-23-2003, 05:54 PM   #3
kc8tbe
Member
 
Registered: Feb 2003
Location: Cleveland, Ohio (USA)
Distribution: Gentoo, Kubuntu 6.06
Posts: 179

Rep: Reputation: 30
If you type "net view" from the Windows command line, does your Linux box appear?

And you may want to refer to this thread about a similar problem I'm having for a potentially useful registry tweak.
 
Old 04-23-2003, 06:54 PM   #4
bripage
Member
 
Registered: Jan 2002
Location: Moorpark
Distribution: SLACK 8!
Posts: 230

Original Poster
Rep: Reputation: 30
nah... my linux box doesnt seem to appear when I type net view. Just my Win XP box shows up.
 
Old 04-23-2003, 07:39 PM   #5
kc8tbe
Member
 
Registered: Feb 2003
Location: Cleveland, Ohio (USA)
Distribution: Gentoo, Kubuntu 6.06
Posts: 179

Rep: Reputation: 30
What's connecting your boxes - a router? And if so, made by whom?
 
Old 04-23-2003, 08:37 PM   #6
bripage
Member
 
Registered: Jan 2002
Location: Moorpark
Distribution: SLACK 8!
Posts: 230

Original Poster
Rep: Reputation: 30
I have the two computers connected by a netgear switch. They ping.. and what not. Yeah and they connect too but the linux amchine wont show up in the NEtwork Nieghborhood.
 
Old 04-23-2003, 09:18 PM   #7
kc8tbe
Member
 
Registered: Feb 2003
Location: Cleveland, Ohio (USA)
Distribution: Gentoo, Kubuntu 6.06
Posts: 179

Rep: Reputation: 30
Go to http://192.168.0.1 to manage your Netgear switch (I think that should work). See if your Linux box shows up as a listed device. If it doesn't, that may be your problem. Making your Linux box master of the local domain (just edit the appropriate line in smb.conf and type "service smb restart") may resolve that issue, but it also may prevent the boxes from connecting altogether.

Bear in mind that you can simply create a shortcut to \\lin.uxb.oxe.sip\ in "My Network Places" and not worry about why WinXP doesn't see your Linux box in the Network Neighborhood.
 
Old 04-23-2003, 09:39 PM   #8
bripage
Member
 
Registered: Jan 2002
Location: Moorpark
Distribution: SLACK 8!
Posts: 230

Original Poster
Rep: Reputation: 30
well.. when I try to go to http://192.168.0.1 I get nothing. Heres how my networks set up .. so youget an idea what Im workin with. I have a Linksys router doing PPPoE authentication to the DSL modem. Then I have a my 1st linux computer connected to the router (theres other poeples computers directly attached to the router, thats why we have one). This 1st machine is doing IP forwarding/masquerading, and DHCP on the 2nd nic. The 2nd nic is creating the 192.168.2.0/24 subnet. The 1st linux box is connected to the switch along with the other nix box and the win XP machine.


But I still dont know why I cant get this crap workin.. I might just have to go with the link plan.... if that works.
 
Old 04-24-2003, 07:04 AM   #9
kc8tbe
Member
 
Registered: Feb 2003
Location: Cleveland, Ohio (USA)
Distribution: Gentoo, Kubuntu 6.06
Posts: 179

Rep: Reputation: 30
In my experience, a Netgear router that does not list your computer may "hide" it from other machines on the network. You can usually fix this by reserving an IP address on the router. To do this, use must access the router setup - usually from http://192.168.0.1 or http://192.168.0.254 or the like (the first or last IP address on your network).

Beyond that, your network situation is beyond my experience level. Good luck!
 
Old 04-24-2003, 02:53 PM   #10
zollodav
LQ Newbie
 
Registered: Apr 2003
Posts: 18

Rep: Reputation: 0
Put this in your smb.conf file and restart the smbd and nmbd service

remote announce 255.255.255.0

or whatever your netmask is for your xp and linux boxes
please check my spelling on announce, seam to be a little tired.

after that you should see the linux box, if not, do you have the firewal setup on your linux box. Also, you have encryption enabled on your linux box, after you see the computer, unless you have things setup correctly then your gonna have problems, but hopefully not.

Also, do you know what machine is the domain master browser?
 
Old 04-24-2003, 03:15 PM   #11
bripage
Member
 
Registered: Jan 2002
Location: Moorpark
Distribution: SLACK 8!
Posts: 230

Original Poster
Rep: Reputation: 30
I dont think that either machine is set up to be the subnets domain browser. How do I set this, and do I need to?
 
Old 04-24-2003, 04:38 PM   #12
zollodav
LQ Newbie
 
Registered: Apr 2003
Posts: 18

Rep: Reputation: 0
Well what's happening is the machines on your network from time to time have an election on who will manage this list of computers on the network, and if there are none or if there are two master browsers then some problems may occurr. Not so much if your systems aren't configured. So, what you have to ask yourself, is which computer is mostly on? If this is a windows box then it is quite easy, sort of. You would do this if it is a windows box that you want as the master browser ALL the time.

goto your Start menu and click Run. Type REGEDIT and hit ENTER

goto this key:

HKEY_LOCAL_MACHINE
SYSTEM
CurrentControlSet
Services
Browser
Parameters

and click on parameters, you should see two keys, IsDomainMaster and MaintainServerList

If you doubleclick on both you set them to Yes
Both of them

If it is the Linux box you want to set as the domain master browser all you need to do it put these entries in the smb.conf file

domain master = yes
local master = yes
preferred master = yes

and then restart the smbd and the nmbd services and your all set

did you put remote announce into your smb.conf?
 
Old 04-24-2003, 04:55 PM   #13
bripage
Member
 
Registered: Jan 2002
Location: Moorpark
Distribution: SLACK 8!
Posts: 230

Original Poster
Rep: Reputation: 30
yeah I entered all that stuff into my smb.conf file. Then I restarted the file server machine, and then after that was booted, I restarted the windows machine. But for some reason the the XP machine still cant see the nix box. I want teh nix box to be the domain master.. so that I dont have to f*ck withthe registry and stuff.


[global]
workgroup = HOME
encrypt passwords = yes
smb passwd file = /etc/samba/private/smbpasswd
log file = /var/log/sambalog.%m.%T.
security = user
hosts allow = 192.168.2.
socket options = TCP_NODELAY
remote announce = 255.255.255.0
domain master = yes
local master = yes
preferred master = yes

[homes]
comment = Home Directories
writable = yes
guest ok = no
valid users = %S
browseable = yes
read only = no
create mask = 0600
directory mode = 0700


[public]
comment = PUBLIC STUFF
path = /home/public
public = yes
force group = users
writable = yes
printable = no
read only = no
browseable = yes
directory mode = 775
create mode = 775
force directory mode = 775
force create mode = 775
 
Old 04-24-2003, 05:05 PM   #14
zollodav
LQ Newbie
 
Registered: Apr 2003
Posts: 18

Rep: Reputation: 0
do a "find a computer" through XP.

also, do you have the firewall going on the linux box?
 
Old 04-24-2003, 05:18 PM   #15
bripage
Member
 
Registered: Jan 2002
Location: Moorpark
Distribution: SLACK 8!
Posts: 230

Original Poster
Rep: Reputation: 30
nah theres no fire wall on the internal linux machine. I have ipforwarding disabled as well. I dont know if that has anythign to do with it though. When I do the find computer... the samba server does appear... and I can connect to it and what not. But it still wont show up directly... in the Network neighborhood.

Last edited by bripage; 04-24-2003 at 05:19 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
SAMBA can't access win share through ip address emailssent Linux - Software 4 09-19-2004 08:29 AM
Can't connect to Samba share outside of subnet digitalghost Linux - Software 0 04-01-2004 12:52 PM
connect to windows share without samba? zuessh Linux - Software 7 01-30-2004 03:37 PM
Samba -> WIn XP file share issue Starblade Linux - Software 1 10-26-2003 07:03 AM
Win XP and Samba Share red X on login janon Linux - Software 0 04-30-2003 02:35 PM


All times are GMT -5. The time now is 08:49 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration