LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 04-04-2010, 10:46 PM   #1
Polanski
Member
 
Registered: Sep 2004
Posts: 234

Rep: Reputation: 30
wicd


To whom it may concern,

I am having problems with wicd on Linux mint 8 fluxbox ce edition. My wireless connection is wpa2 personal and wicd has the network registered as a wep password protected connection. Is there a way to fix this problem? Your help is greatly appreciated.
 
Old 04-05-2010, 03:46 AM   #2
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,036

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
Open wicd.
Click on your network's "Properties".
Change the encryption to wpa2
 
Old 04-05-2010, 10:20 AM   #3
Polanski
Member
 
Registered: Sep 2004
Posts: 234

Original Poster
Rep: Reputation: 30
I tried to change the properties. Wicd believes that the network is wep protected and whatever I change the properties wicd doesn't register it, it still remains at wep. Maybe it's an internal problem, a problem with the script?
 
Old 04-05-2010, 10:28 AM   #4
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,036

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
Do you have wpa-supplicant installed?
If not, please install it, then restart networking with
sudo /etc/init.d/networking restart
Then try wicd again.
 
Old 04-06-2010, 04:38 PM   #5
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,036

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
So, did you get your wireless working with WPA?

Or not?

A follow-up post would be appreciated, not least because other people will be finding this thread and wondering, as I am, what the answer might be.
 
Old 04-06-2010, 08:14 PM   #6
Polanski
Member
 
Registered: Sep 2004
Posts: 234

Original Poster
Rep: Reputation: 30
When I installed wicd it removed network manager and the os requires network manager to boot up. After I turned the computer off it brings me to a screen that says starting crypto disk and won't boot into the login screen. Completely re-installing the os is my last resort. Is there a way to place network manager back into the correct location through the terminal on the live cd? I partitioned the hdd manually and can't remember how I partitioned it. Or how can I find out how the drive is currently partitioned through the live cd terminal and write it down?
 
Old 04-06-2010, 08:17 PM   #7
damgar
Senior Member
 
Registered: Sep 2009
Location: dallas, tx
Distribution: Slackware - current multilib/gsb Arch
Posts: 1,949
Blog Entries: 8

Rep: Reputation: 201Reputation: 201Reputation: 201
Quote:
Originally Posted by Polanski View Post
When I installed wicd it removed network manager and the os requires network manager to boot up. After I turned the computer off it brings me to a screen that says starting crypto disk and won't boot into the login screen. Completely re-installing the os is my last resort. Is there a way to place network manager back into the correct location through the terminal on the live cd? I partitioned the hdd manually and can't remember how I partitioned it. Or how can I find out how the drive is currently partitioned through the live cd terminal and write it down?
Code:
fdisk -l
will list the partitions. It's possible that you might have to do
Code:
sudo fdisk -l
.
 
Old 04-08-2010, 08:05 PM   #8
Polanski
Member
 
Registered: Sep 2004
Posts: 234

Original Poster
Rep: Reputation: 30
I now have the message on network manager "device not managed" when I click on the network manager program on the toolbar in linux mint ce fluxbox 8. Is there another program like network manager that's not wicd that I can install on linux mint 8 fluxbox ce?
 
Old 04-09-2010, 09:07 AM   #9
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,036

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
Quote:
the os requires network manager to boot up.
I don't understand this at all. Please explain in detail what is happening.

I just installed wicd to a new install of ubuntu 9.10 this morning, it removed NM and after the next boot, wicd was ready to configure.
 
Old 04-09-2010, 09:30 PM   #10
Polanski
Member
 
Registered: Sep 2004
Posts: 234

Original Poster
Rep: Reputation: 30
Last time I installed wicd it automatically removed nm and after I turned the computer off I couldn't boot into the login manager any more. I will try to install wicd again and see what happens. Also when I click on nm in the toolbar it says not managed and won't detect any networks. I reworked some of the settings in the .conf file I made, I will probably remove the file I made and see what happens.
 
Old 04-10-2010, 12:46 PM   #11
Polanski
Member
 
Registered: Sep 2004
Posts: 234

Original Poster
Rep: Reputation: 30
when I run sudo iwconfig this is what comes up:

eth1 IEEE 802.11b ESSID:"pokeumbrella" Nickname:"HERMES I"
Mode:Managed Frequency:2.457 GHz Access Point: None
Bit Rate:11 Mb/s Sensitivity:1/3
Retry limit:4 RTS thrff Fragment thrff
Encryption keyff
Power Managementff
Link Quality=0/92 Signal level=-68 dBm Noise level=-93 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:4
Tx excessive retries:2 Invalid misc:0 Missed beacon:0
In the wicd gui it identifies this network as a wep blocked network and the block is wpa personal with a passphrase. How can I turn on the encryption key and should I add some items in wpa_supplicant.conf?
 
Old 04-11-2010, 05:54 PM   #12
Polanski
Member
 
Registered: Sep 2004
Posts: 234

Original Poster
Rep: Reputation: 30
To whom it may concern,

The specific problem I am having is with linux mint. In network manager when I click the edit connections on the network manager symbol in the bottom corner of the toolbar there is an option for wpa personal 1/2, but when I left click on the same symbol in the toolbar, the two screens symbol I select my wireless ssid and there is no option for wpa personal 1/2 only options for wep. Does anyone know how this problem can be solved? I am running dhcp on the router with and ipv4 connection. What script do I have to change? Do I have to alter wpa_supplicant.conf? The edit connections is in the user interface for networkmanager. Any kind of help would be greatly appreciated.
 
Old 04-11-2010, 09:29 PM   #13
Polanski
Member
 
Registered: Sep 2004
Posts: 234

Original Poster
Rep: Reputation: 30
I am back on wicd, but I still think it is an internal problem with wpa supplicant. Thank you for your help.
 
Old 04-13-2010, 07:50 PM   #14
Polanski
Member
 
Registered: Sep 2004
Posts: 234

Original Poster
Rep: Reputation: 30
I still have the same problem. I cannot get wireless internet on wicd. My network is detected but the gui on wicd identifies it as a wep protected network and it is not wep protected network, it is a wpa personal protected network. How can I get wicd to identify as a wpa personal network? It is a problem with wpa_supplicant.conf or something else? Your help is greatly appreciated. I know posting in my own thread is not how I should do this but I need help and I would like to get wifi back on my desktop.
 
Old 04-13-2010, 07:51 PM   #15
Polanski
Member
 
Registered: Sep 2004
Posts: 234

Original Poster
Rep: Reputation: 30
When I run iwlist scan this is what comes up:

lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

eth1 Scan completed :
Cell 01 - Address: 00:1E:C2:F6:407
ESSID:"pokeumbrella"
Mode:Master
Channel:1
Frequency:2.412 GHz (Channel 1)
Signal level:-25 dBm Noise level:-89 dBm
Encryption keyn
Extra:bcn_int=100
Extra:capab=0x0431
Extra: Last beacon: 148ms ago
Cell 02 - Address: 00:03:93:E88:32
ESSID:"Dan's Airport"
Mode:Master
Channel:10
Frequency:2.457 GHz (Channel 10)
Signal level:-66 dBm Noise level:-97 dBm
Encryption keyn
Extra:bcn_int=100
Extra:capab=0x0411
Extra: Last beacon: 148ms ago
Cell 03 - Address: 00:17:3FB:9F:25
ESSID:"belkin54g"
Mode:Master
Channel:11
Frequency:2.462 GHz (Channel 11)
Signal level:-80 dBm Noise level:-88 dBm
Encryption keyff
Extra:bcn_int=100
Extra:capab=0x0021
Extra: Last beacon: 148ms ago
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Getting Wicd on Ubuntu Rockspud5693 Linux - Newbie 45 06-29-2011 09:01 AM
where is wicd 1.7 ? witek Slackware 6 01-25-2010 05:36 PM
WICD tray icon says not connected, WICD manager says conneted to wired network?!?! intheshadows Linux - Newbie 1 12-24-2009 01:15 PM
Wicd error biske Slackware 6 10-11-2009 07:09 AM
WICD cannot connect . garrydog Linux - Newbie 30 09-22-2009 01:38 PM


All times are GMT -5. The time now is 05:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration