LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Why My laptop keyboard is not working (http://www.linuxquestions.org/questions/linux-software-2/why-my-laptop-keyboard-is-not-working-614432/)

vinnuavc 01-18-2008 12:27 AM

Why My laptop keyboard is not working
 
Hi..
I have Lenovo Y500 series Laptop. Recently i installed Fedora 8 with the DVD which is came with "Linux For U" magazine. OS Installation is successful. Even though installation is successful, my keyboard & Touch Pad are not working. When I connected USB Mouse,it is working fine but keyboard is not working.

Same problems with "Linux Mint" OS also.

Can any one gudie me how to over come with these problems.

In another side everything is working fine with SUSE linux.

Thank U,
Vinod

thedonkdonk 01-18-2008 01:38 AM

First i would check your xorg.con file to make sure it has the following:
Code:

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "Device" "/dev/input/event1"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "us"
EndSection

Section "InputDevice"
        Identifier  "Synaptics"
        Driver      "synaptics"
        Option      "Device" "/dev/input/mice"
        Option      "Protocol" "auto-dev"
        Option      "Emulate3Buttons" "yes"
EndSection

If you have something like this already in oyur xorg.conf file, i would ask you if you have a non-standard U.S.A. keyboard. If you do have a non-standard U.S.A. keyboard let me know what it is and i can google what to add to your boot options. i did find this for the Lenovo Y500. http://ubuntuforums.org/showthread.php?p=4152003

vinnuavc 01-18-2008 05:26 AM

Am new to Linux
 
Hi...
Thank U for quick response.
Am new to linux. can u tell me where can I find "xorg.con" file.

Thank U
Vinod

thedonkdonk 01-18-2008 05:59 AM

The xorg.conf file is in /etc/X11/. So you can view the file by typing on the command line: sudo view /etc/X11/xorg.conf. I guess you will need a usb keyboard to do this. If you dont have one then i would try first, the method at http://ubuntuforums.org/showthread.php?p=4152003.

Basicly when you boot the system you will have a screen that looks like this one.
http://thedonkdonk.net/images/grub1.jpg
Press any key within three seconds.
The you will get a screen like this one.
http://thedonkdonk.net/images/grub2.png
Use your arrow keys to select the kernel line. Press e.
You can then edit the boot options. at the end of the line add locale=fr_FR i8042.reset
press enter. then press b. it will boot with the new options.

indraniltupa 02-08-2009 12:37 PM

It worked for Fedora 7 on Lenovo Y500

meabi 12-19-2010 09:56 AM

got a solution from googling and posted it on my blog
refer http://www.meabi.com/linux-keyboard-...y500-solution/


All times are GMT -5. The time now is 07:40 AM.