LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-14-2003, 12:19 PM   #1
Robert0380
LQ Guru
 
Registered: Apr 2002
Location: Atlanta
Distribution: Gentoo
Posts: 1,280

Rep: Reputation: 47
why me (kernel/iptables)


things were working fine, had my iptables rules fine, apache was working (like 3 weeks ago), got my mail server configured correctly.....everything was going fine. Now, apache wont take SSL requests, iptables doesnt work and fluxbox doesnt seem to like me (it wont display the background image automatically).


the iptables one is crucial...i have to have a firewall. here is what i get when i do a simple iptables -L command:
Code:

/lib/modules/2.4.20-18.7/kernel/net/ipv4/netfilter/ip_tables.o: init_module: Device or resource busy
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
      You may find more information in syslog or the output from dmesg
/lib/modules/2.4.20-18.7/kernel/net/ipv4/netfilter/ip_tables.o: insmod /lib/modules/2.4.20-18.7/kernel/net/ipv4/netfilter/ip_tables.o failed
/lib/modules/2.4.20-18.7/kernel/net/ipv4/netfilter/ip_tables.o: insmod ip_tables failed
iptables v1.2.5: can't initialize iptables table `filter': iptables who? (do you need to insmod?)
Perhaps iptables or your kernel needs to be upgraded.


mind you, iptables is compiled in


so, i tried to re compile the kernel right...well...i make the bzImage, but when i do "make modules" i get this error.

Code:

module.c: In function `cipe_check_kernel':
module.c:73: warning: implicit declaration of function `printk_R1b7d4074'
make[3]: *** [module.o] Error 1
make[3]: Leaving directory `/usr/src/linux-2.4.20-18.7/drivers/addon/cipe'
make[2]: *** [_modsubdir_cipe] Error 2
make[2]: Leaving directory `/usr/src/linux-2.4.20-18.7/drivers/addon'
make[1]: *** [_modsubdir_addon] Error 2
make[1]: Leaving directory `/usr/src/linux-2.4.20-18.7/drivers'
make: *** [_mod_drivers] Error 2


and it exits.... ok, NO CLUE what that is, all i did was configure the kernel the way i wanted, actually, i took the kernel the way it was already installed, and make sure the iptables stuff was compiled in, then did the compile process and got that on make modules

so then i try to just go ahead with make modules_install, and i get this:
[code]
cp: cannot stat `cipcb.o': No such file or directory
make[3]: *** [_modinst__] Error 1
make[3]: Leaving directory `/usr/src/linux-2.4.20-18.7/drivers/addon/cipe'
make[2]: *** [_modinst_cipe] Error 2
make[2]: Leaving directory `/usr/src/linux-2.4.20-18.7/drivers/addon'
make[1]: *** [_modinst_addon] Error 2
make[1]: Leaving directory `/usr/src/linux-2.4.20-18.7/drivers'
make: *** [_modinst_drivers] Error 2
[code]



same stuff from make modules almost (makes sense)

1. what is cipcb?
2. what happened to my iptables, why wont they work?
note:( just typing iptables and hitting enter does work)

if it helps, deleted some old kernels (not the source) from the /boot
directory, maybe my System.map is messed up but i dont even know what that does. i tried to compile the stuff in the cipe directory but it gives all kind of errors. tried fixing its source code but that only got rid of the "file not found errors" but produced other errors (it couldnt find the include files udp.h, sock.h and ip.h so i helped it out and pointed it to the correct places where those files reside) if i cant get this to work, i guess i'll have to backup everything...and reformat the system AGAIN!!

there must be a better way.

Last edited by Robert0380; 06-14-2003 at 12:21 PM.
 
Old 06-14-2003, 12:32 PM   #2
nyllt
LQ Newbie
 
Registered: Jun 2003
Posts: 1

Rep: Reputation: 0
Angry

 
Old 06-14-2003, 12:39 PM   #3
mad_ady
Member
 
Registered: Jan 2003
Location: I'm all in your mind!
Distribution: Debian
Posts: 248

Rep: Reputation: 30
Did you do anything unusual to your system? (Installed something perhaps?)
 
Old 06-14-2003, 01:09 PM   #4
Robert0380
LQ Guru
 
Registered: Apr 2002
Location: Atlanta
Distribution: Gentoo
Posts: 1,280

Original Poster
Rep: Reputation: 47
last thing i did was install fluxbox and play with apache and deleted some kernels, i did change the symbolic link for System.map, but after that i
did an rpm kernel install that should have fixed all of that up but still nothing.
I got this iptables error before when i tried to use the 2.5 kernel for fun
but i didnt get those compilation errors with the 2.5 kernel and i just stopped using it becuse it wouldnt allow me to use iptables. i just backed up everything crucial, im about to just reformat the drive and re-install everything. good thing i have all the rpms from up2date, that cuts my
re-install time in half. be back in a few hours i guess
 
Old 06-14-2003, 03:49 PM   #5
mad_ady
Member
 
Registered: Jan 2003
Location: I'm all in your mind!
Distribution: Debian
Posts: 248

Rep: Reputation: 30
Then, if you tinkered with kernels, it's most likely that some modules got mixed up. If you haven't formatted you system yet, check /lib/modules. There should be at leas a directory that corresponds to your running kernel. Maybe it's not the right directory and the kernel simply can't find the modules...

A reinstall should solve this... Be more carefull in the future!
 
Old 06-14-2003, 04:37 PM   #6
Robert0380
LQ Guru
 
Registered: Apr 2002
Location: Atlanta
Distribution: Gentoo
Posts: 1,280

Original Poster
Rep: Reputation: 47
re-installed everything, almost back up and running 100%, just gotta get imp working again. lost a lot of fluff from before. only thing i hate is that i had to install Gnome to get gaim (atleast according to RedHat). I also gained 40GB of free space from a hard drive that had windows on it, gave it a mount point of /freespace. Anyway, my problems are gone for now. I'll attempt to compile my own kernel again, maybe this time it will work.

Last edited by Robert0380; 06-14-2003 at 04:39 PM.
 
Old 06-15-2003, 06:18 AM   #7
mad_ady
Member
 
Registered: Jan 2003
Location: I'm all in your mind!
Distribution: Debian
Posts: 248

Rep: Reputation: 30
You don't have to install gnome to get gaim to work... It just needs a few packets!
 
Old 06-15-2003, 06:36 AM   #8
Robert0380
LQ Guru
 
Registered: Apr 2002
Location: Atlanta
Distribution: Gentoo
Posts: 1,280

Original Poster
Rep: Reputation: 47
you know, i figured as much, but according to RedHat 7.3's install thingy, it depended on quite a lot of stuff (like the gnome-base, which depended on sawfish???(why!!!) which depended on sumthin else...etc.) all that led up to gnome being installed because i choose to satisfy the dependancies...f**k i hate gnome.
 
Old 06-15-2003, 07:30 AM   #9
mad_ady
Member
 
Registered: Jan 2003
Location: I'm all in your mind!
Distribution: Debian
Posts: 248

Rep: Reputation: 30
Oh, well... That's life. Maybe you can get the sources for gaim and compile it statically. Then delete the dependencies, because it won't need it anymore!
 
Old 06-15-2003, 07:33 AM   #10
Robert0380
LQ Guru
 
Registered: Apr 2002
Location: Atlanta
Distribution: Gentoo
Posts: 1,280

Original Poster
Rep: Reputation: 47
true, true. thanks for that advice.
 
Old 06-15-2003, 07:35 AM   #11
mad_ady
Member
 
Registered: Jan 2003
Location: I'm all in your mind!
Distribution: Debian
Posts: 248

Rep: Reputation: 30
I'm curious... How do you compile something statically? is there a switch to make?
 
Old 06-15-2003, 01:44 PM   #12
Qzukk
Member
 
Registered: Jun 2003
Posts: 132

Rep: Reputation: 15
Compiling something statically requires using a different compiling command, so unless the author of the Makefile thought of this and provided a target for static compilation (try make static or make static-binary) you'll have to run the final linking command by hand. basically, you'll need to change the final linking command (usually the last gcc command run which lists all of the files compiled and all of the libraries needed, to include the "-static" option.

Some makefiles will accept a CFLAGS environemnt variable for this purpose.
 
Old 06-16-2003, 03:06 AM   #13
mad_ady
Member
 
Registered: Jan 2003
Location: I'm all in your mind!
Distribution: Debian
Posts: 248

Rep: Reputation: 30
I see... So, if I want to compile something statically, I must add the -static option...

I'll have a look... Thanks!
 
Old 06-16-2003, 02:03 PM   #14
Proud
Senior Member
 
Registered: Dec 2002
Location: England
Distribution: Used to use Mandrake/Mandriva
Posts: 2,794

Rep: Reputation: 116Reputation: 116
See ./configure --help
 
Old 06-17-2003, 10:32 AM   #15
mad_ady
Member
 
Registered: Jan 2003
Location: I'm all in your mind!
Distribution: Debian
Posts: 248

Rep: Reputation: 30
Dooh... Thanks!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
iptables and kernel 2.6 rb2k Linux - Networking 3 02-13-2004 11:38 AM
IPTABLES 1.2.9 on Kernel 2.6.1 kemplej Linux - Security 6 01-16-2004 09:03 AM
Kernel 2.6.0 + iptables Waldi Slackware 3 01-02-2004 09:29 AM
iptables and kernel 2.6.0 dingding66 Mandriva 4 12-23-2003 10:56 PM
kernel 2.4.20 and iptables? jownas Linux - Networking 2 07-01-2003 08:44 PM


All times are GMT -5. The time now is 01:14 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration