-   Linux - Software (
-   -   Why doesn't mplayer work?????? (

Caveman 09-30-2003 06:42 AM

Why doesn't mplayer work??????
Hi there!


I have mandrake 9.1 and I installed the package for mplayer, everything was alrigth with the installation so I tried to play a movie and mplayer is giving me this error:

"Fatal error!

Error opening/initializing the selected video_out(-vo) device

The file is fine, cause I can open it with Xine, but I just can't solve this error and play any kind of file with mplayer!

Any hint 4 this newbie?




iceman47 09-30-2003 06:48 AM

You'll have to change the selected video_out(-vo) device, so go into mplayer preferences and change the video driver.

Caveman 09-30-2003 07:59 AM

Thanx Iceman, got it!


Caveman 09-30-2003 08:24 AM

Sorry Iceman, just 1 more thing please!

How can I resize the actual size of the movie, i.e., even in Full screen mode, the video always keeps the original size, can't I change it (like microDVD player, windows Media Player or BSPlayer) ?

Thanx for helping this newbie,


RockmanExe 09-30-2003 08:30 AM

in Mplayer options, change the video controler from x11 to xv and restart Mplayer.
Hope this helps

Caveman 09-30-2003 08:58 AM


In Preferences->Video I have the avilable drivers:


But the only that doesn't gives me "video_out(-vo) device" error is the x11 driver, so when I change to xv like you said the app gives me that error and doesn't play anything at all!

Any suggestion?

Thanx Cave.!

iceman47 09-30-2003 11:42 AM

afaik you can't resize the actual video image with the x11 driver but you should ask acid_kewpie, he's the video expert here.

All times are GMT -5. The time now is 07:49 AM.