LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 04-10-2007, 12:29 AM   #31
moaimullet
LQ Newbie
 
Registered: Jan 2007
Posts: 7

Rep: Reputation: 0

Quote:
Originally Posted by Electro
moaimullet, you could have just buy a hardware controller to make it very, very easy for yourself. Probably there are some files on the NTFS partition that are corrupt. Lucky for you they were not system based and they did not have obscured permissions. RAID 5 needs a lot of processor resources for I/O transactions. However, you may have even higher chance of data corruption or data loss, so I suggest backing up your data.

I would not do it your way because the reliability and stability have to go both ways for good operation. I know Linux is reliable and stable, but Windows is never reliable and stable. I rather pick being in debt for several months after buying a hardware RAID controller like from 3ware instead of doing it your way.

Note:
Using SCSI or SATA hard drives in a software RAID can change from one device node and to the next node. You may have to set the ID or use software labels to make it predictable upon boot up.

BTW, I have not yet setup RAID, but I studied the documentation at every angle.

Hi Electro.. Yeah, it was a complete stab in the dark with this one. What made me take the jump was the fact that, should my costly hardware RAID controller die, I'd have to get a perfectly compatible replacement (e.g. the exact same model) or else lose everything. If the original RAID lasted a couple of years, that could get seriously expensive. That is way too much faith in hardware for me. So I did this knowing I had some free time ahead that could be spent reconfiguring if need be.

That said, so far so good. Haven't run into any NTFS corruption or permission problems to date. But you're dead on with the Linux vs Windows reliability: my biggest problem is that when XP randomly reboots, which it likes to do every couple of weeks without any warning or useful debug info, it does a rebuild on all volumes at once. Since they are all on the same physical disks, this does create some grindage, and can last around 7 hours. My solution is to reboot manually every week or so.. using Firefox it's hardly a problem to get back to where I was (reboot without closing any of its windows , but having to remember is a pain sometimes..

Anyway, that is better left for a different thread. What is more relevant is that the CPU usage doesn't stray above 10%, even when rebuilding.. and I'm using an AMD 3500, hardly top of the line today. It's really negligible considering how much processor is on the market now. It might become an issue after Moore's Law does battle with the periodic table (and loses), but for now I'm happy..
 
Old 04-10-2007, 04:11 AM   #32
fanqi1234
LQ Newbie
 
Registered: Apr 2007
Posts: 8

Rep: Reputation: 0
Code:
fans:~ # mount /dev/md0 /mnt/md0
mount: you must specify the filesystem type
fans:~ #
 
Old 04-10-2007, 12:29 PM   #33
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,192

Rep: Reputation: 120Reputation: 120
At this point, since the array is clean, it's no longer an array problem, I guess. It's a filesystem problem. It doesn't look like you have much choice other than to run "e2fsck -y /dev/md0" and have it repair the filesystem for you. I can't imagine why you wanted to run -S.
 
Old 04-12-2007, 04:19 AM   #34
fanqi1234
LQ Newbie
 
Registered: Apr 2007
Posts: 8

Rep: Reputation: 0
e2fsck -y /dev/md0
Haha !


I can mount it now ,and all data is ok
 
Old 04-12-2007, 11:50 AM   #35
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,192

Rep: Reputation: 120Reputation: 120
Yay!!!!!!! Success is a wonderful thing!
 
Old 01-05-2013, 03:35 PM   #36
Ish
LQ Newbie
 
Registered: Jan 2013
Posts: 1

Rep: Reputation: Disabled
D'oh

New post on old thread...

Been trying to set up a raid5 on Ubuntu 12.04 server and successfully created a raid on /dev/md0 but couldn't mount. I kept hitting the bad fs error.

Command tried to mount it:

me@myserver # sudo mount -t ext2 /dev/md0 /mnt/RaidDrive

SHOULD have been trying:

me@myserver # sudo mount -t ext2 /dev/md0p1 /mnt/RaidDrive

--Just adding this in case anyone else came up with the same error... Google pointed this thread out, it may do so for someone in the future!
 
  


Reply

Tags
fs, md0, mdadm, mount, type


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
RAID5 using mdadm, how to mount /dev/md0? ggduff Linux - Software 4 11-14-2007 01:59 AM
can not mount RAID 0 /dev/md0 dysenteryduke Linux - Software 3 09-15-2005 03:19 PM
help me setup software raid 1 on slackware with mdadm xrado Slackware 2 03-02-2005 05:50 AM
Software RAID with mdadm problems... robbow52 Debian 2 04-19-2004 07:06 PM
mdadm mail with software RAID brucehohl Linux - Software 1 12-20-2003 06:17 AM


All times are GMT -5. The time now is 12:13 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration