LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 05-11-2012, 04:53 PM   #1
mreff555
Member
 
Registered: Sep 2011
Location: Philly
Distribution: Gentoo
Posts: 444

Rep: Reputation: Disabled
where is libffi.so.6?


I'm trying to satisfy dependancies for gimp 2.8

I've been trying to install glib 2.32.1 but I'm getting errors loading libffi.so.6.

It doesn't appear to be installed on my system. I have installed libffi 3.0.11 and it appears to correctly install but still not libffi.so.6

any suggestions?
 
Old 05-11-2012, 10:58 PM   #2
blue_print
Member
 
Registered: May 2010
Location: In world
Distribution: RHEL, CentOS, Ubuntu
Posts: 275
Blog Entries: 3

Rep: Reputation: 49
Aren't you able to find the package in /usr/lib?

If it is a rpm based installation, please use the following command,

Quote:
rpm -ql libffi
This will give you the path of libffi so file
 
Old 05-12-2012, 12:24 AM   #3
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,563

Rep: Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512
Still the Debian Sid based Crunchbang ?

Today's Debian Sid has libglib2.0-0 version 2.32.2,
and it uses libffi5 : libffi.so.5
http://packages.debian.org/sid/libglib2.0-0


If you have the libffi.so.6 from libffi 3.0.11 in a hideaway location,
glib 2.32.1 may not be able to find it.


Anyway, gimp-2.8.0 will do fine with glib-2.30.2, which is often
compiled to use libffi.so.4 or libffi.so.5


.

Last edited by knudfl; 05-12-2012 at 01:08 AM.
 
Old 05-12-2012, 08:14 AM   #4
mreff555
Member
 
Registered: Sep 2011
Location: Philly
Distribution: Gentoo
Posts: 444

Original Poster
Rep: Reputation: Disabled
Thanks guys.

here is what I had in my /usr/lib
Code:
dan@hobo:~/downloads/glib-2.30.2$ ls -l /usr/lib/libffi*
lrwxrwxrwx 1 root root    16 Mar 25 07:38 /usr/lib/libffi.so.5 -> libffi.so.5.0.10
-rw-r--r-- 1 root root 31792 Oct  1  2010 /usr/lib/libffi.so.5.0.10
dan@hobo:~/downloads/glib-2.30.2$
I tried glib-2.32.2 but it appears to be also looking for libffi.so.6
2.30.2 seems to have installed ok. I guess I'll give that a try
 
Old 05-12-2012, 08:54 AM   #5
mreff555
Member
 
Registered: Sep 2011
Location: Philly
Distribution: Gentoo
Posts: 444

Original Poster
Rep: Reputation: Disabled
update

Gimp 2.8 also requires Pango >= 1.29.4 which requires libffi.so.6 arggggg!
 
Old 05-12-2012, 09:13 AM   #6
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,563

Rep: Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512
Where do you get those strange packages that require libffi.so.6 ? ?

The current Debian Sid : libpango ver. 1.30.0 :
Depends on a glib2, built with libffi.so -> libffi.so.5
http://packages.debian.org/sid/libpango1.0-0
http://packages.debian.org/source/sid/glib2.0
http://packages.debian.org/sid/libffi5

Which OS are you using ? Version ?

.
 
Old 05-12-2012, 09:20 AM   #7
mreff555
Member
 
Registered: Sep 2011
Location: Philly
Distribution: Gentoo
Posts: 444

Original Poster
Rep: Reputation: Disabled
I was trying to compile from source
 
Old 05-12-2012, 09:44 AM   #8
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,563

Rep: Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512
I did a gimp-2.8.0 build on Suse 12.1 yesterday.
That's the one with the "old" libffi-4.6.2 : libffi.so -> libffi.so.4 !
And pango-1.29.4 is the default installed system version.
http://www.linuxquestions.org/questi...lems-944359/#8

No issues at all.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No package 'libffi' found woow Linux - Software 7 02-07-2012 08:30 PM


All times are GMT -5. The time now is 04:56 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration