LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 04-06-2007, 03:08 PM   #1
Ryupower
Member
 
Registered: Oct 2006
Posts: 75

Rep: Reputation: 16
when I ./configure Gimpshop it gives me this error


checking for pkg-config... /usr/bin/pkg-config
checking for GLIB - version >= 2.4.5...
*** 'pkg-config --modversion glib-2.0' returned 2.9.6, but GLIB (2.12.4)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
configure: error: Test for GLIB failed. See the file 'INSTALL' for help.


That's what I get when I try to install it, I know I have the newest verions of GLIB installed.

It tells me how to fix it ( if that even works ). What is ment by: set the environment variable PKG_CONFIG_PATH to point to the correct configuration files?
How does one do that?

Using: Ubuntu Edgy Eft CE

thx!

Last edited by Ryupower; 04-06-2007 at 03:16 PM.
 
Old 04-06-2007, 03:17 PM   #2
weibullguy
ReliaFree Maintainer
 
Registered: Aug 2004
Location: Kalamazoo, Michigan
Distribution: Slackware-current, Cross Linux from Scratch, Gentoo
Posts: 2,747
Blog Entries: 1

Rep: Reputation: 225Reputation: 225Reputation: 225
Do have the glib development files installed? If not install them and try again.
 
Old 04-06-2007, 06:26 PM   #3
lebabyg
Member
 
Registered: Mar 2006
Location: UK
Distribution: Ubuntu Feisty
Posts: 272

Rep: Reputation: 30
sudo apt-get install glib-dev might work?
 
  


Reply

Tags
gimp, glib


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
./configure fails with: libz... configure: error: not found. erpe Linux - Software 17 10-11-2006 05:56 PM
Trouble with Gimpshop on Suse 9.3 trox Linux - Software 2 05-29-2006 01:07 AM
GIMPshop doesn`t install UnrealX Slackware 7 03-02-2006 07:25 PM
Easiest Way to Install Gimpshop FWSquatch Debian 3 02-05-2006 11:41 AM
Ubuntu and GIMPshop metalgirsolid Linux - Software 3 04-10-2005 09:24 AM


All times are GMT -5. The time now is 12:52 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration