LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 08-07-2006, 05:46 AM   #1
darkscot
Member
 
Registered: Jul 2006
Location: West Yorkshire, UK
Distribution: Mandriva, Leeenux, Saluki
Posts: 103

Rep: Reputation: 20
What is the correct syntax for Lame


I am trying to use Lame to convert a WAV file to MP3. Do I need to put in any options or should the following work?

Lame /home/user/file.wav /home/user/file.mp3
 
Old 08-07-2006, 10:41 PM   #2
jens
Senior Member
 
Registered: May 2004
Location: Belgium
Distribution: Debian, Slackware, Fedora
Posts: 1,229

Rep: Reputation: 175Reputation: 175
Quote:
Originally Posted by darkscot
I am trying to use Lame to convert a WAV file to MP3. Do I need to put in any options or should the following work?

Lame /home/user/file.wav /home/user/file.mp3
You don't have to type the resulting file if you don't use any options.

Code:
lame file.wav
...will ceate an mp3 version (file.wav.mp3)
But it will not give you real stereo and only a 128Kbits/sec bitrate.

For stereo and a higher bitrate(in this case you do need to type the resulting file):
Code:
lame -b 160 -m s file.wav file.mp3
(replace 160 with something like 256 if you wish so)

Last edited by jens; 08-07-2006 at 11:11 PM.
 
Old 08-14-2006, 02:29 AM   #3
darkscot
Member
 
Registered: Jul 2006
Location: West Yorkshire, UK
Distribution: Mandriva, Leeenux, Saluki
Posts: 103

Original Poster
Rep: Reputation: 20
Quote:
Originally Posted by jens
You don't have to type the resulting file if you don't use any options. lame file.wav will ceate an mp3 version (file.wav.mp3)
Thanks, I think the problem was the file name was too complicated (artist name album name track title.wav) and Lame was getting confused. changing to a simpler file name solved the problem.

Quote:
But it will not give you real stereo and only a 128Kbits/sec bitrate. For stereo and a higher bitrate(in this case you do need to type the resulting file): lame -b 160 -m s file.wav file.mp3
That is interesting to know!

Last edited by darkscot; 08-14-2006 at 02:31 AM.
 
  


Reply

Tags
audio, encoding


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Installed LAME, command 'lame' works but lame's not in any program directories! ayteebee Linux - Software 8 05-24-2006 06:48 PM
darkice with lame support can't find lame h2gofast Debian 4 03-17-2006 12:20 PM
Correct syntax to disable pcmcia? wickedbob Linux - Newbie 2 06-05-2004 06:15 AM
correct syntax for a canonical file? rioguia Linux - Software 1 11-04-2003 03:11 AM
what is the correct syntax shanenin Linux - Software 2 10-19-2003 01:31 PM


All times are GMT -5. The time now is 03:41 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration