LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 10-14-2003, 12:10 AM   #1
kkathman
Member
 
Registered: Sep 2003
Location: Coppell, Texas
Distribution: SUSE 10.1, Kubuntu 6.06 (Dapper)
Posts: 81

Rep: Reputation: 15
What's best for RH9 and PLS files coming from Internet Radio Feeds?


I have been quite successful in getting most everything in my RH9 set up properly, except
for one thing..I seem to be having a problem with listening to Internet Radio feeds.

I have a pretty kewl station I listen to quite often, and it broadcasts through SHOUTcast which is just a broadcast streaming server. Its perfectly legal, and they send out a PLS file format. When I examine the file association, it points to XMMS. Again this is good. When I click on the connect link on the website (www.streamingsoundtracks.com) sure enough XMMS launches, but no sound. When I click the "play" button, I get some vague message about Red Hat disabling something due to licensing conflicts and restrictions.

My question: Am I just screwed because RedHat wont let me listen to any MP3 or streaming format? Or is there some other solution that I could try. I cant imagine that RedHat would just say ...uhm..NO you cant listen to any MP3s, seeing that all the files are pre-assigned!

Thanks alot for the help in advance.
Kork
 
Old 10-14-2003, 12:40 AM   #2
ilikejam
Senior Member
 
Registered: Aug 2003
Location: Glasgow
Distribution: Fedora / Solaris
Posts: 3,109

Rep: Reputation: 96
I can personally recommend 'xine' as an MP3/Video player (and its 'kaffiene' interface).

http://xinehq.de/

RedHat didn't include MP3 support because the MPEG format is copyrighed, and isn't free.

There's a package with all the major sound and video codecs on the xine site (or at least there's links anyway). Once you've downloaded and installed the codecs there should be a way to get xmms to play MP3s with those codecs as well as xine.

(There's RPMs with the 'win32' codecs (mp3, real, quicktime etc) here:
http://cambuca.ldhs.cetuc.puc-rio.br/xine/
at the bottom of the page)

Hope that helps.

Dave

Last edited by ilikejam; 10-14-2003 at 01:17 AM.
 
Old 10-14-2003, 11:11 AM   #3
kkathman
Member
 
Registered: Sep 2003
Location: Coppell, Texas
Distribution: SUSE 10.1, Kubuntu 6.06 (Dapper)
Posts: 81

Original Poster
Rep: Reputation: 15
Dave,

Thanks very much for your recommendation. I will take a look at that.

I finally got to the root (no pun intended) of the issue last night. It is, as you say, an issue with the MP3 itself. Even though RH9 ships with XMMS, the plugin to play any form of MP3 format, including the PLS streaming format isnt included.

I found the plugin for XMMS at www.gurulabs.com/downloads.html and downloaded the RPMs and installed them. XMMS now plays the stream just fine.

However, there is still an issue in that the site I listen to is an MP3Pro site, which effectively doubles the quality of the sound, but uses the same bandwidth. In the Windows world the plugin that is used is the Thompson MP3Pro plugin for Winamp. Apparently this is not available for Linux/XMMS yet...but..maybe soon??

Thanks,
Kork
 
Old 12-08-2003, 08:54 PM   #4
VxJasonxV
Member
 
Registered: Apr 2003
Location: Mesa, AZ
Distribution: RH9, LFS5, Knoppix 3.2/3.3 (Live), FC1, FC2, MDK10CE, MDK10OE, Gentoo
Posts: 51

Rep: Reputation: 15
May I bump this?
I also have an internet radio site which just went MP3PRO, and the stream quality is most definately noticable between systems.

Thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
web sites not coming up RH9 matneyc Linux - Networking 16 12-22-2004 04:24 PM
X-Net Radio! Internet Radio with an attitude! xnetradio General 1 01-11-2004 11:01 AM
listening to .pls files on RH9 PionexUser Linux - General 1 10-27-2003 03:50 AM
Old RH5.2 user coming back with RH9.0 with many problems franciscofossa Linux - Newbie 1 07-17-2003 06:32 AM
Linux laptop not coming on network...pls help!!!!! Anubhuti Linux - Networking 5 04-22-2003 02:20 PM


All times are GMT -5. The time now is 02:05 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration