LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-30-2003, 01:20 PM   #1
herc
Member
 
Registered: Jul 2003
Posts: 90

Rep: Reputation: 15
webalizer problems


Having some trouble, and I can't figure out how to fix it.
Quote:
$ webalizer
libpng warning: Application was compiled with png.h from libpng-1.0.15
libpng warning: Application is running with png.c from libpng-1.2.2
gd-png: fatal libpng error: Incompatible libpng version in application and library
-bash: line 951: 16217 Segmentation fault webalizer
 
Old 10-30-2003, 02:13 PM   #2
_KDF
Member
 
Registered: Oct 2003
Distribution: FC4/5 & RHEL4
Posts: 133

Rep: Reputation: 15
Incompatible libpng version in application and library

At a guess your version of libpng is not compatible with that version of webalizer ?
 
Old 10-30-2003, 04:28 PM   #3
herc
Member
 
Registered: Jul 2003
Posts: 90

Original Poster
Rep: Reputation: 15
Yes I can see that but I have no idea how to fix it
 
Old 10-30-2003, 04:34 PM   #4
musrum
Member
 
Registered: Oct 2003
Distribution: Slackware
Posts: 112

Rep: Reputation: 15
http://www.libpng.org/pub/png/libpng.html

That's the libpng home page. Scroll down a bit and you'll find a bit labeled "Current Binaries". Click around on the links labeled 'Linux' and you may find a binary for your disto.

If not, download the sources and build!
 
Old 10-31-2003, 03:15 AM   #5
herc
Member
 
Registered: Jul 2003
Posts: 90

Original Poster
Rep: Reputation: 15
you can't read, huh?

I have libpng installed but messed up a bit, and I'm wondering how to fix it.
 
Old 10-31-2003, 07:22 AM   #6
musrum
Member
 
Registered: Oct 2003
Distribution: Slackware
Posts: 112

Rep: Reputation: 15
I don't know if you intended to be rude....

You have a version mismatch with libpng. Your copy of webalizer wants 1.0.15, you have 1.2.2.

Either get libpng 1.0.15 or rebuild webalizer to use 1.2.2.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Webalizer MDSJB Linux - Newbie 4 06-01-2004 06:05 AM
Webalizer Stats + language problems slyomatic Linux - General 0 05-12-2004 11:37 AM
Problems with Webmin - webalizer mattbeekler Linux - Software 0 10-28-2003 03:09 PM
Webalizer herc Linux - Software 0 09-06-2003 07:45 AM
Webalizer Help KillerCheeto Linux - Newbie 0 12-23-2002 06:23 PM


All times are GMT -5. The time now is 05:11 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration