LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-26-2003, 09:24 PM   #1
sameermanagoli
LQ Newbie
 
Registered: Jun 2003
Location: San Diego
Posts: 11

Rep: Reputation: 0
Question web server apache


Hi,

Do u know how to start the apache web server in Red hat linux 9.please giude me how to set up. and to verify whether its already configured.

Thanks,
Sameer Managoli
 
Old 06-26-2003, 09:28 PM   #2
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 234Reputation: 234Reputation: 234
Locate your httpd.conf file to configure your server which is the main configuration. Not sure where its located by default, do a:

find / -name httpd.conf

or

locate httpd.conf

The apache standard way to do it is:

apachectl start <=== to start the server
apachectl stop <=== to stop the server
apachectl restart <=== restarts the server

apachectl configtest <=== tests your configuration file before you might want to start the server to check and make sure it won't start with errors, etc.

apachectl command is usually by default located in /usr/sbin and in most cases you need to be logged in as root to run the command.

Sites that might be of help using apache. http://www.apache.org

Last edited by trickykid; 06-26-2003 at 09:30 PM.
 
Old 06-26-2003, 10:17 PM   #3
sameermanagoli
LQ Newbie
 
Registered: Jun 2003
Location: San Diego
Posts: 11

Original Poster
Rep: Reputation: 0
when i tried apachetl start
i got the message has below
bash: apachetl: command not found

Sameermanagoli
 
Old 06-26-2003, 10:20 PM   #4
cyph3r7
Member
 
Registered: Apr 2003
Location: Silicon Valley East, Northern Virginia
Distribution: FreeBSD,Debian, RH, ok well most of em...
Posts: 238

Rep: Reputation: 30
are you sure you typed it right? your error says "apachetl" not apachectl.
 
Old 06-26-2003, 10:35 PM   #5
sameermanagoli
LQ Newbie
 
Registered: Jun 2003
Location: San Diego
Posts: 11

Original Poster
Rep: Reputation: 0
i DID TYPE CORRECTLY apachectl ,i tried may combinations.what may be the problem?DO i have to download and installl again?
I was able to locate the httpd/

Thanks,
Sameer
 
Old 06-26-2003, 10:47 PM   #6
sameermanagoli
LQ Newbie
 
Registered: Jun 2003
Location: San Diego
Posts: 11

Original Poster
Rep: Reputation: 0
Hi ,

I located apache in my /usr/sbin

but when i type apachectl start its showing apachectl command not found

let me know the reason !!!!!!!!!
 
Old 06-26-2003, 11:05 PM   #7
slizadel
LQ Newbie
 
Registered: Jun 2003
Distribution: RH9, Gentoo, Slack
Posts: 23

Rep: Reputation: 15
Are you in the directory /usr/sbin when you try to run the apachectl command?

With RH9 standard users do not have /usr/sbin in their PATH. If you change to root with just the su command instead of su - then you will not use root's PATH, which does contain /usr/sbin. Try changing to the /usr/sbin directory and then starting apache with ./apachectl start.
 
Old 06-27-2003, 01:17 AM   #8
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 234Reputation: 234Reputation: 234
Calm down. When you type in all UPPER CASE LETTERS IT COMES OFF AS YOU YELLING AT US!

Type this at the prompt also logged in as root:

/usr/sbin/apachectl <start, stop or restart>

Like slizadel said, you probably don't have /usr/sbin in your current path or your logged in as a regular user which won't have it in your current path. Login or su to root and then attempt the above or just apachectl, etc.

Or find the command by typing:

locate apachectl
 
Old 06-27-2003, 03:57 AM   #9
twantrd
Senior Member
 
Registered: Nov 2002
Location: CA
Distribution: redhat 7.3
Posts: 1,440

Rep: Reputation: 52
If the above commands still say "bash: apachetl: command not found"

then I would suggest using a different shell. Try using tcsh. Then run those commands listed above again and see if that resolves any problems.

-twantrd
 
Old 06-27-2003, 05:31 PM   #10
sameermanagoli
LQ Newbie
 
Registered: Jun 2003
Location: San Diego
Posts: 11

Original Poster
Rep: Reputation: 0
Hi alll!!!
Thanks Trickykid,i'm sorry i did not intend to yell nor shout.I typed the reply in a hurry.
sorry for that.
I'll try logging on as root.
Thanks everybody for your reply,
Sameer Managoli
 
Old 06-27-2003, 05:40 PM   #11
Looking_Lost
Senior Member
 
Registered: Apr 2003
Location: Eire
Distribution: Slackware 12.0, OpenSuse 10.3
Posts: 1,120

Rep: Reputation: 45
Or try as root

/etc/init.d/httpd start
 
Old 07-06-2003, 05:21 PM   #12
sameermanagoli
LQ Newbie
 
Registered: Jun 2003
Location: San Diego
Posts: 11

Original Poster
Rep: Reputation: 0
Hi Guys,

I did all the above told .The apache is located at

/usr/share/icons/Bluecurve/16x16/apps/apacheconf.png
/usr/share/icons/Bluecurve/32x32/apps/apacheconf.png
/usr/share/icons/Bluecurve/48x48/apps/apacheconf.png
/usr/share/vim/vim61/syntax/apachestyle.vim
/usr/share/vim/vim61/syntax/apache.vim

i logged as root and did try this command
/usr/sbin/apachectl <start, stop or restart>

but i'm getting as /usr/sbin/apachectl: Command not found.
please let me know how to start the apache and upload my website i created.

THanks,
Sameer Managoli
 
Old 07-06-2003, 07:12 PM   #13
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 234Reputation: 234Reputation: 234
locate apachectl

or

find / -name apachectl

Also, do you even have apache installed?
 
Old 07-06-2003, 07:57 PM   #14
sameermanagoli
LQ Newbie
 
Registered: Jun 2003
Location: San Diego
Posts: 11

Original Poster
Rep: Reputation: 0
Hi trickykid,
When i type the command from root locate apachectl
there is no action at all like this
[root@dyn-2-72 ~]# locate apachectl
[root@dyn-2-72 ~]#

As i'm totally clueless as how should i proceed further.PLease help me.
 
Old 07-06-2003, 08:25 PM   #15
grizzly
Member
 
Registered: Jun 2003
Distribution: Slackware 9.1, Solaris 9, and IPcop
Posts: 101

Rep: Reputation: 15
I am am running redhat 7.3, (I believe it is 7.3). I installed Apache by compiling from source and used the default location for the install to place its files. When I did this the apachectl file was put into:
/usr/local/httpd/bin
If you are using the package that came with Redhat, I am not sure what default location that would be in. But the path I gave might be worth a try.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
using apache web server r_squared Linux - Networking 4 12-02-2004 08:57 PM
setting up password protected web forms on an apache web server AZDAVE Linux - Security 3 07-07-2004 01:03 PM
apache web server citrus Linux - Newbie 6 03-24-2004 06:58 AM
apache web server .. johnyy Linux - Software 1 11-22-2003 06:07 AM
apache web server AZDAVE Linux - Newbie 2 10-03-2003 02:52 PM


All times are GMT -5. The time now is 01:13 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration