LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 11-13-2003, 09:29 AM   #1
qwijibow
LQ Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Rep: Reputation: 47
want user to be able to mount vfat (fstab ?)


hey guys.

so far ive been mounting my windows disk (primary slave ide hard disk)
in the following way

su
passwd
mount -t vfat /dev/hdb1 /mnt/windows

which works fine, but i want to allow normal users to mount the drive
i have made the following modifications...

su
password
ln -s /dev/hdb1 /dev/windows
chmod 666 /dev/hdb1
chmod 666 /dev/windows
chmod 666 /mnt/windows

and i have added the following line to fstab
/dev/windows /mnt/windows vfat defaults 0 0


but whwn issuing the following command as standard user
mount /dev/windows

i get an "only root can do that" error.

what am i missing ???
 
Old 11-13-2003, 09:36 AM   #2
aaa
LQ Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
Quote:
and i have added the following line to fstab
/dev/windows /mnt/windows vfat defaults 0 0
Next to 'defaults', put 'user'. You also might want to put 'umask=0' there to set the permissions to rwxrwxrwx.
 
Old 11-13-2003, 09:56 AM   #3
qwijibow
LQ Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Original Poster
Rep: Reputation: 47
thank for the reply. im getting closer,

the fstab line now reads
/dev/windows /mnt/windows vfat defaults user umask=0 0 0

but now mount says this line is "bad" are my settings in the wrong order, (wrong side of defaults ?????)

thanKs
 
Old 11-13-2003, 10:01 AM   #4
qwijibow
LQ Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Original Poster
Rep: Reputation: 47
Fixed it with commer's between defualts and user, thanXs

so it now reads /dev/windows /mnt/windows vfat defaults,user 0 0
 
Old 11-13-2003, 10:43 AM   #5
shanenin
Member
 
Registered: Aug 2003
Location: Rochester, MN, U.S.A
Distribution: Gentoo
Posts: 987

Rep: Reputation: 30
I think you want it like this

/dev/hdb1 /mnt/windows vfat user,umask=000 0 0


/dev/hdb1 /mnt/windows vfat noauto,user,umask=000 0 0

this first line will mount it at bootup the second line you will have to mount it with this command
mount /mnt/windows

Last edited by shanenin; 11-13-2003 at 10:46 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SAMBA - VFAT local mount for all user write access... dolvmin Linux - Software 13 12-21-2006 03:50 PM
Changing Fstab in ubuntu to mount vfat drive mikeymorgan Linux - Newbie 13 06-23-2005 07:50 AM
mount/fstab issues, vfat filename conventions: 8.3 vs long tisource Linux - Software 2 03-23-2005 09:22 PM
What fstab mount setting do you use to get full access to a vfat drive? BarkingBonefish Linux - Newbie 4 03-12-2004 12:36 AM
mount fat32 in fstab in gentoo, user privs yowwww Linux - General 1 08-22-2003 04:36 PM


All times are GMT -5. The time now is 06:45 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration