LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 12-18-2009, 01:09 PM   #1
sisyphus1978
LQ Newbie
 
Registered: Sep 2009
Posts: 10

Rep: Reputation: 1
w3m hard-wrap in sent emails


I use w3m on ubuntu 9.10. I can access my gmail fine (tip, when you get the loop with cookies try deleting the url up to mail.google.com and presto, a screen appears which allows you to choose html mode - <if you try it in google docs apparently you're breaking intergalactic law!>).

But no matter what I do, I can't stop w3m adding hard breaks to my email messages. At first I thought it was nano and so I spent quite some time trying to get nano to softwrap And now nano works great (no spurious hard-wraps) but my emails from w3m still have them. I tried it with gedit as the editor (o for options) and no luck. [Fold line in text area] does make the sentences wrap nicely in the text entry box (try it and see) but still the text comes out wonky.

I really don't know why I am spending so long on getting the text to be hard-wrap free, but I've set myself the challenge...

Any ideas?
 
Old 12-21-2009, 06:13 AM   #2
sisyphus1978
LQ Newbie
 
Registered: Sep 2009
Posts: 10

Original Poster
Rep: Reputation: 1
Could the problem be with the terminal app (I use gnome-terminal). I have just tried it in mrxvt and got the same behaviour. Does that mean that the issue is with w3m? I also tested out lynx, but it seemed to do the same thing.

I honestly don't get enough emails to set up mutt. I would just like to send out emails without hard breaks in them. No ideas at all?
 
Old 12-21-2009, 10:07 AM   #3
sisyphus1978
LQ Newbie
 
Registered: Sep 2009
Posts: 10

Original Poster
Rep: Reputation: 1
The more I investigate, the more I feel this is an issue with gmail, not w3m (sorry for casting the aspersion). I am writing this post inside a screen session, inside w3m over ssh and I bet it will wrap fine. In that case, do you recommend setting up something like Mutt to get around the problem?
 
Old 12-21-2009, 10:53 AM   #4
sisyphus1978
LQ Newbie
 
Registered: Sep 2009
Posts: 10

Original Poster
Rep: Reputation: 1
Consider this solved. I have set up mutt and I'm getting wrapping behaviour as expected.
 
  


Reply

Tags
break, hard, line, w3m, wrap


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
w3m uid0sd Linux - Software 2 09-21-2007 12:02 PM
"enscript --word-wrap" does not wrap line of text file powah Linux - General 3 05-16-2006 10:12 PM
w3m question Peff Linux - Software 2 02-10-2006 03:04 PM
convert html emails to plain text emails andredude Linux - General 6 03-20-2005 01:33 PM
w3m in framebuffer console? wr3ck3d Linux - Software 10 08-04-2003 12:54 PM


All times are GMT -5. The time now is 05:51 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration