LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 06-21-2006, 03:09 AM   #1
sethb
LQ Newbie
 
Registered: Jul 2003
Location: Mpls
Distribution: RedHat 9
Posts: 6

Rep: Reputation: 0
vsftpd stopped working: LIST gives 500 Unknown command


Up to about 24 hours ago, it worked fine (I downloaded a few hundred gig from my server in the last few weeks). Then it stopped.

Now, connecting to it and changing directory works, but the LIST command returns "500 Unknown command".

I'm running vsftpd.i386 2.0.1-5.EL4.3

I don't think anything got changed when it stopped working, but obviously something did.

Permissions on the directory changed to are 775, the ones above are all 755. The directory changed to is owned by the user logging in to ftp. That directory contains further directories which are all 775. Everything is readable all the way down.

Nothing shows up in the log.
 
Old 06-21-2006, 03:31 AM   #2
timmeke
Senior Member
 
Registered: Nov 2005
Location: Belgium
Distribution: Red Hat, Fedora
Posts: 1,515

Rep: Reputation: 61
Do you use a chroot jail? Is the "ls" program available? Is the disk almost full?
 
Old 06-21-2006, 11:29 AM   #3
sethb
LQ Newbie
 
Registered: Jul 2003
Location: Mpls
Distribution: RedHat 9
Posts: 6

Original Poster
Rep: Reputation: 0
No jail (it's a private server). ls works fine, and the disk is half empty.

And it started working again. I hate nondeterminism I can't control.
 
Old 06-22-2006, 02:15 AM   #4
timmeke
Senior Member
 
Registered: Nov 2005
Location: Belgium
Distribution: Red Hat, Fedora
Posts: 1,515

Rep: Reputation: 61
Maybe a problem with your FTP control (command) connection.
Please post back if it occurs again.
 
Old 06-22-2006, 04:24 PM   #5
worldgnat
Member
 
Registered: Oct 2004
Posts: 337

Rep: Reputation: 30
I used vsftpd for a website building camp last week. I got a bunch of "User cannot login" errors. Try restarting vsftpd. It took me a few hours of trouble shooting, and when I restarted vsftpd, it worked. I may have done something else, because after two hours of troubleshooting at 9 in the morning I was totally exhausted and really didn't care what I had done to fix it.

-Peter
 
Old 06-22-2006, 06:17 PM   #6
shorun
Member
 
Registered: Mar 2006
Location: belguim
Distribution: fedora, mandriva, suse
Posts: 148

Rep: Reputation: 15
i had this problem 2. check your vsftpd.conf for the following line:
passive_disabled=yes

it gave the same error, and denied some users and some not.
the users denied used a client that MUST have passive connections.
but the server refuses that.

maybe this helps
 
Old 06-24-2006, 04:23 PM   #7
sethb
LQ Newbie
 
Registered: Jul 2003
Location: Mpls
Distribution: RedHat 9
Posts: 6

Original Poster
Rep: Reputation: 0
There's nothing in vsftpd.conf about passive. (In fact, iptables won't allow it, until I figure out how to handle it automatically.)

If the problem should recur, any advice on what to look for/log to help figure it out?
 
Old 06-26-2006, 02:13 AM   #8
timmeke
Senior Member
 
Registered: Nov 2005
Location: Belgium
Distribution: Red Hat, Fedora
Posts: 1,515

Rep: Reputation: 61
Passive FTP requires a connection on a port > 1024.
Your firewall (iptables) will indeed need to allow this.
However, if you don't want to open all ports > 1024 (which is a serious security hazard),
you can limit the port numbers vsftpd uses to a certain range.
Check out the pasv_min_port and pasv_max_port options (man vsftpd.conf).
If you set these options, you only need to open the given range of ports in iptables.
 
Old 10-27-2010, 10:00 PM   #9
Solaris11
LQ Newbie
 
Registered: Oct 2010
Posts: 1

Rep: Reputation: 0
Passive FTP Mode

I followed the steps outlined here, and it worked for me:
serverfault.com/questions/194190/setting-up-vsftpd-hangs-on-list-command

Basically, I entered in the command:
modprobe nf_conntrack_ftp
 
Old 10-28-2010, 06:58 AM   #10
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,778
Blog Entries: 1

Rep: Reputation: 412Reputation: 412Reputation: 412Reputation: 412Reputation: 412
Please don't resurrect long-dead threads. This one is over 4 years old.
 
  


Reply

Tags
vsftpd


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
500 OOpS error w/ vsftpd 5amYan *BSD 5 11-08-2006 05:59 PM
FTP stopped working, except on the command line sekelsenmat Linux - Networking 5 07-03-2005 07:44 AM
VSFTPD with 500 oops :vsftpd: missing argv[0] mole_13 Linux - Newbie 0 05-04-2005 01:05 AM
Shar Command Stopped Working thef0x82 Red Hat 0 11-18-2003 07:24 AM
vsftpd 500 illegal port command jglazner Linux - Software 3 09-30-2003 04:53 PM


All times are GMT -5. The time now is 01:09 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration