LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-21-2003, 04:50 PM   #1
soonerjim
LQ Newbie
 
Registered: May 2003
Posts: 4

Rep: Reputation: 0
vsftpd configuration help


I'm a newbie and have been trying to get an ftp server working using vsftpd. It is set up to not allow anonymous logins and to my knowledge the vsftpd.conf looks correct, but when ever I try to log on to the site using a username and password I have created in the usermanager and added to the correct group I get denied access. I have attached my vsftpd.conf file below. Someone please help me!!!!! This file is from the directory: /etc/vsftpd/vsftpd.conf

thanks!

Example config file /etc/vsftpd.conf
#
# The default compiled in settings are very paranoid. This sample file
# loosens things up a bit, to make the ftp daemon more usable.
#
# Allow anonymous FTP?
anonymous_enable=NO
#
# Uncomment this to allow local users to log in.
local_enable=YES
#
# Uncomment this to enable any form of FTP write command.
write_enable=YES
#
# Default umask for local users is 077. You may wish to change this to 022,
# if your users expect that (022 is used by most other ftpd's)
local_umask=022
#
# Uncomment this to allow the anonymous FTP user to upload files. This only
# has an effect if the above global write enable is activated. Also, you will
# obviously need to create a directory writable by the FTP user.
#anon_upload_enable=YES
#
# Uncomment this if you want the anonymous FTP user to be able to create
# new directories.
#anon_mkdir_write_enable=YES
#
# Activate directory messages - messages given to remote users when they
# go into a certain directory.
dirmessage_enable=YES
#
# Activate logging of uploads/downloads.
xferlog_enable=YES
#
# Make sure PORT transfer connections originate from port 20 (ftp-data).
connect_from_port_20=YES
#
# If you want, you can arrange for uploaded anonymous files to be owned by
# a different user. Note! Using "root" for uploaded files is not
# recommended!
#chown_uploads=YES
#chown_username=whoever
#
# You may override where the log file goes if you like. The default is shown
# below.
#xferlog_file=/var/log/vsftpd.log
#
# If you want, you can have your log file in standard ftpd xferlog format
xferlog_std_format=YES
#
# You may change the default value for timing out an idle session.
#idle_session_timeout=600
#
# You may change the default value for timing out a data connection.
#data_connection_timeout=120
#
# It is recommended that you define on your system a unique user which the
# ftp server can use as a totally isolated and unprivileged user.
#nopriv_user=ftpsecure
#
# Enable this and the server will recognise asynchronous ABOR requests. Not
# recommended for security (the code is non-trivial). Not enabling it,
# however, may confuse older FTP clients.
#async_abor_enable=YES
#
# By default the server will pretend to allow ASCII mode but in fact ignore
# the request. Turn on the below options to have the server actually do ASCII
# mangling on files when in ASCII mode.
# Beware that turning on ascii_download_enable enables malicious remote parties
# to consume your I/O resources, by issuing the command "SIZE /big/file" in
# ASCII mode.
# These ASCII options are split into upload and download because you may wish
# to enable ASCII uploads (to prevent uploaded scripts etc. from breaking),
# without the DoS risk of SIZE and ASCII downloads. ASCII mangling should be
# on the client anyway..
#ascii_upload_enable=YES
#ascii_download_enable=YES
#
# You may fully customise the login banner string:
#ftpd_banner=Welcome to blah FTP service.
#
# You may specify a file of disallowed anonymous e-mail addresses. Apparently
# useful for combatting certain DoS attacks.
#deny_email_enable=YES
# (default follows)
#banned_email_file=/etc/vsftpd.banned_emails
#
# You may specify an explicit list of local users to chroot() to their home
# directory. If chroot_local_user is YES, then this list becomes a list of
# users to NOT chroot().
#chroot_list_enable=YES
# (default follows)
#chroot_list_file=/etc/vsftpd.chroot_list
#
# You may activate the "-R" option to the builtin ls. This is disabled by
# default to avoid remote users being able to cause excessive I/O on large
# sites. However, some broken FTP clients such as "ncftp" and "mirror" assume
# the presence of the "-R" option, so there is a strong case for enabling it.
#ls_recurse_enable=YES

pam_service_name=vsftpd
check_shell=NO
userlist_enable=YES
#enable for standalone mode
listen=YES
tcp_wrappers=YES
 
Old 05-21-2003, 05:16 PM   #2
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
I think with:
userlist_enable=YES

You need:
userlist_file=/etc/vsftpd.user_list

Then to add usernames that are allowed to connect to that file.

If you want all users to connct by default you can removethe enable line and the file becomes a list of users to deny.
 
Old 05-22-2003, 08:38 AM   #3
soonerjim
LQ Newbie
 
Registered: May 2003
Posts: 4

Original Poster
Rep: Reputation: 0
still no luck

thanks for the reply. I tried that and still no luck after adding a username to the list and trying to log on. Any other ideas out there? Also, I was wondering weather or not it mattered what group you add users to that you want to have access to your ftp site. I'm pretty stumped so any help would be appreciated. If someone has a vsftpd.conf file configured to accept username and passwords to allow access to certain folders, posting that would also be a big help. thanks everyone!!!!
 
Old 05-22-2003, 09:09 AM   #4
soonerjim
LQ Newbie
 
Registered: May 2003
Posts: 4

Original Poster
Rep: Reputation: 0
I noticed that when the folder "file owner" that I am trying to access if set to root, then I cannot get into the folder. When the owner is set to anything else I can log in anonamously. What do I need to set as the file owner in order for username and password to be required????
 
Old 05-22-2003, 12:41 PM   #5
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
The same as the user you are trying to log in as.
 
Old 05-22-2003, 01:49 PM   #6
soonerjim
LQ Newbie
 
Registered: May 2003
Posts: 4

Original Poster
Rep: Reputation: 0
thanks, I got it to work. Do you know of any way to allow other users who are not the file owner to have access to the folder? I tried to set it up in the folder properties but had no luck. Thanks for your help!!
 
Old 05-22-2003, 01:58 PM   #7
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
Put them all in a group and give that group access to the folder with the relevant permissions.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
VSFTPD Configuration Help dsheller Linux - Software 26 11-06-2010 11:06 PM
VSFTPD Configuration bharaniks Linux - Security 2 10-16-2005 11:58 PM
VSFTPD Configuration Help Hexadecimal Linux - Networking 8 08-10-2005 10:12 PM
vsftpd configuration help. jsbush Linux - Newbie 3 10-25-2003 05:40 AM
vsftpd configuration pazvant Linux - Security 1 10-22-2003 01:05 PM


All times are GMT -5. The time now is 02:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration