LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 09-30-2003, 04:19 PM   #1
jglazner
LQ Newbie
 
Registered: Aug 2003
Posts: 17

Rep: Reputation: 0
vsftpd 500 illegal port command


Hi,

i just installed RedHat9 over RedHat8. ftpused to be fine in RedHat8 but now when ever i try to conenct from a windows client machine i get

< 220 (vsFTPd 1.1.3)
> USER jed
< 331 Please specify the password.
> PASS *****
< 230 Login successful. Have fun.
> REST 1
< 350 Restart position accepted (1).
> REST 0
< 350 Restart position accepted (0).
> SYST
< 215 UNIX Type: L8
> PWD
< 257 "/web/jed"
~ Login completed.
> PORT 10,10,1,67,7,143
< 500 Illegal PORT command.
~ Could not retrieve directory listing for "/web/jed/"

I can connect fine from Linux boxes without any problems. is this a new problem? I can't find any answers on the web. I have removed vsftpd from my pc, and re-installed it using apt-get.

I have a back up of my conf file, and i have left all settings a default.

Can SOMEONE PLEASE HELP ME!
 
Old 09-30-2003, 04:34 PM   #2
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 197Reputation: 197
Try to turn passive mode off if your ftp'ing from Windows to Linux.
 
Old 09-30-2003, 04:48 PM   #3
jglazner
LQ Newbie
 
Registered: Aug 2003
Posts: 17

Original Poster
Rep: Reputation: 0
How do you do that? Windows ftp doesn't support taht or have any clue what i'm talking about. I'm also using LeachFTP and i dont' see any settings for that. any other ideas?

(EDIT)

I found out the problem. i have to USE passive mode evidently.
I found a setting in ie settings for using passive mode. it worked fine after that. THANKS!

Last edited by jglazner; 09-30-2003 at 04:52 PM.
 
Old 09-30-2003, 04:53 PM   #4
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 197Reputation: 197
I'm not familiar with LeachFTP but most FTP programs in Windows like WS-FTP and SmartFTP have these options to not use Passive when transferring. I'd check with LeachFTP's manual or documentation if it has this option, or how to enable/disable, etc.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
500 OOPS: vsftpd: must be started as root userbr Linux - Networking 3 06-27-2011 12:44 AM
500 OOpS error w/ vsftpd 5amYan *BSD 5 11-08-2006 05:59 PM
VSFTPD with 500 oops :vsftpd: missing argv[0] mole_13 Linux - Newbie 0 05-04-2005 01:05 AM
iptables / FTP masquerading: Port command illegal radiowhiz Linux - Networking 1 03-23-2005 05:15 PM
ProFTPd- "Illegal PORT Command" JCdude2525 Linux - Networking 5 12-06-2004 05:42 AM


All times are GMT -5. The time now is 10:52 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration